Cant install any amd driver after 10.2 Amd driver installation freezes.

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by MTSeldon, Nov 19, 2017.

  1. MTSeldon

    MTSeldon Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    Asus R 290 / 4Gb
    Computer Type: Desktop, custom build GPU:Sapphire AMD R290 CPU: intel 4770k , mem @2333 Motherboard: Asus Hero VI RAM:corsair 8x2 , 2300 PSU: seasonic 750 Operating System & Version:Windows 10 , fall update GPU Drivers:amd 11.2

    I Cant install any Amd driver after trying to install 10.2. Amd drivers stuck at the installer and finish with 1603 error. I cleaned with DDU and Amd driver clean utility.Uninstalled all Visual C++ packages. And tried installing the latest drivers (i'm downloading the full driver package not the web installer.), again it stucks at installing the driver part and finishes with error 1603. Now i can install 11.2 and under safe mode with device manager driver update,but other drivers software can't be installed at all. I can't find what the problem is. Any ideas?
    install log. https://pastebin.com/RJeV2jYG
     
  2. MTSeldon

    MTSeldon Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    Asus R 290 / 4Gb
    Used the DDU again , and tried installing the latest drivers 11.2 under safe mode , i get the "drivers not signed digitally " error. downdload the latest whql drivers (11.1) , still the same "digitally not signed error" . But i used the device manager ,update drivers (still under safe mode) , now the latest drivers could be installed that way . But now again i can't use the AMD software . Why would the drivers could be installed in device manager if they aren't digitally signed?
     
  3. Chastity

    Chastity Master Guru

    Messages:
    829
    Likes Received:
    60
    GPU:
    Sapph Nitro 390 BP
    Smells like a corrupted OS installation.
     
  4. MTSeldon

    MTSeldon Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    Asus R 290 / 4Gb
    is there a way to check this? Everything else seems to be working fine, and before the windows fall update and 10.1 drivers , there wasn't problem with the installition.
     

  5. thatguy91

    thatguy91 Ancient Guru

    Messages:
    6,579
    Likes Received:
    57
    GPU:
    XFX RX 480 RS 4 GB
    From an elevated command prompt, run the following (in order):
    Code:
    dism /online /cleanup-image /startcomponentcleanup /resetbase
    dism /online /cleanup-image /restorehealth
    sfc /scannow
    winmgmt /resetrepository
    winmgmt /resyncperf
    

    Restart your computer.

    If the first command errors, run the second command and third command, then re-run the first command followed by the remaing commands.

    You can also try a decent reg cleaner (many are crap and do more harm than good). This is a decent one, and is free (for the reg cleaner part):
    https://www.auslogics.com/en/software/registry-cleaner/

    When running make sure all boxes on the left are ticked. Run this after doing the above steps, and after which restart.

    Hopefully that will help. If not, you may just need to reinstall Windows...
     

Share This Page