Cannot disable Rivatuner OSD in LibreOffice Writer

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by MattyMatt, Dec 9, 2015.

  1. MattyMatt

    MattyMatt New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    hdgfs
    I've added every .exe in the libreoffice directory to the exclusion, but the OSD stays, even though it is currently disabled.

    What do I have to do here?
     
  2. ATi7500

    ATi7500 Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    R7 Graphics
    same issue here :(
     
  3. boogieman

    boogieman Ancient Guru

    Messages:
    1,849
    Likes Received:
    1
    GPU:
    MSI GTX 1080X
    Did you then set detection level to None in RTSS for that exe?
     
  4. twiztedtbone

    twiztedtbone New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 980ti 6GB
    I am having the exact same issue and have yet to come up with a solution. I've added all associated .exes from the 'Program Files (x86)\LibreOffice 5\program' folder, set detection on all to none, and still the OSD shows. I even copied the sample config for a built-in disabled program (which, incidentally, is only two lines of code), restarted RTSS, and no dice.

    To be clear, I very much don't want to disable RTSS. I love it and its sexy OSD, just not when it's hiding the top left portion of LibreOffice.

    I fully expect Unwinder to pop in and tell me to RTFM, and I'm perfectly fine with that. If this is something I'm missing due to my own lack of trying than I'm the one to blame. Problem is I can't think of the step I might be missing...
     

  5. Radier

    Radier Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    MSI RX 470 Gaming X 4 GB
    Does anyone have any ideas?
     
  6. The1

    The1 Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    2x EVGA 780ti SC, H20
    Maybe I am not understanding the issue correctly, but if you open afterburner/setting/on screen display and set hot keys for toggle on\off, hide, would that not solve your issue?
    Mine will show up on foobar and I just toggle off.
     
  7. 0458315753

    0458315753 Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    GTX 1080
    It would be nice if there was a global setting to disable the overlay in all programs running in a window and only enable in software that uses native desktop resolution or exclusive fullscreen.
     
  8. RaXelliX

    RaXelliX Member Guru

    Messages:
    176
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 1080
    Same here. I thought i did something wrong in RTSS settings or LibreOffice uses some other EXE to run but apparently not. Granted it's not a big issue because i can toggle the overlay off via hotkey but then i usually forget to toggle it on again when i exit LibreOffice.
     
  9. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,960
    Likes Received:
    45
    You can easily see proper exe name via pressing "I" button in MSI Afterburner. It will be listed under "Active 3D process".
     
  10. RaXelliX

    RaXelliX Member Guru

    Messages:
    176
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 1080
    Thank you. I managed to get everything working now but not trough RTSS GUI. It seems that the 3D process in question is not an EXE at all but a BIN file instead wich is odd. Since RTSS only allows profiles for EXE files you can't set exception trough the GUI either.

    So what i did was that i
    1. Closed RT and RTSS
    2. Went to C:\Program Files (x86)\RivaTuner Statistics Server\Profiles
    3. Copy pasted an existing profile (CFG file) for a program that i had disabled the OSD for. Does not really matter wich one as long as it's for a disabled one.
    4. Then i renamed it to soffice.bin.cfg (just name - nothing inside CFG itself).
    5. Restarted RT and RTSS
    6. Started LibreOffice and behold. No OSD anymore.

    @ Unwinder. Perhaps add soffice.bin.cfg with hooking disabled to included profiles on the next release of RTSS? That way on future releases people would not have to manually copy files unless they disable included profiles.
    Another option would be to allow RTSS select non-EXE files but this is not really common case for a BIN file to be the 3D process so im not sure it's worth it.
     

  11. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,960
    Likes Received:
    45
    RTSS 7.0.0 allows adding profiles for renamed executables as well, holding <Shift> while clicking <Add profile> button will list all running 3D processes and allow you to create exclusions for them.
    Also, soffice.bin.cfg should be already in built-in profiles list of 7.0.0 AFAIR.
     
  12. RaXelliX

    RaXelliX Member Guru

    Messages:
    176
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 1080
    Well that's my bad. I had the update check disabled so i was stuck on 6.6.0
     

Share This Page