Can you still "Disable Fullscreen Optimizations" globally? Can't seem to do it anymore in Win10

Discussion in 'Operating Systems' started by BlindBison, Sep 2, 2021.

  1. BlindBison

    BlindBison Master Guru

    Messages:
    893
    Likes Received:
    190
    GPU:
    RTX 2080 Super
    I noticed you can still disable FSO on the .exe, but I can't seem to find a way to do it globally anymore. The reason i'd like to do this is primarily because some games don't play nice with G-Sync + V-Sync ON without FSO OFF (Dark Souls 3 / Sekiro for example). Since there really is no benefit I care about from FSO, I'd rather just turn it off globally for consistency if I can. Thanks!

    EDIT: Seems it may still be possible with a registry edit so I'll try that and see how it goes: https://digicruncher.com/disable-fullscreen-optimizations-in-windows-10/

    They say that it entails adding a DWORD GameDVR_FSEBehavior in Computer\HKEY_CURRENT_USER\System\GameConfigStore and setting it from 0 to 2. I'm not sure if this still works, but I'll give it a shot. If any of you are aware of another way to do it (ideally I wish they'd let us do it from within settings) or if you know this approach doesn't even work anymore it'd be very helpful to know. Thanks for your time,

    EDIT #2: This doesn't seem to actually work RIP
     
    Last edited: Sep 4, 2021
  2. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,270
    Likes Received:
    208
    GPU:
    MSI RTX 2080
    It'd sure be nice if you could since you could in older builds, but nothing i've ever tried since then doesn't work. And some games still don't turn it off even if you set them to turn it off. (FFXIV is one example from what I recall)
     
    BlindBison likes this.
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,602
    Likes Received:
    4,377
    GPU:
    GTX 1080ti
    its pointless to do it.
     
  4. BlindBison

    BlindBison Master Guru

    Messages:
    893
    Likes Received:
    190
    GPU:
    RTX 2080 Super
    97% of the time you're correct so maybe it's pointless to do globally, but occasionally some games really don't play nice with it in conjunction with G-Sync (Sekiro / Dark Souls 3 for example require FSO to be OFF for g-sync to engage correctly on my rig).
     

  5. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,602
    Likes Received:
    4,377
    GPU:
    GTX 1080ti
    doesn't SpecialK help with these 2 and fix the gsync issues?


    The guide for Sekiro on Nexus

    To play the game with GSYNC do these additional steps (Nvidia):
    1. Under Nvidia Control Panel navigate to 3D Settings -> Manage 3D settings -> Program Settings -> Sekiro
    2. Set Monitor Technology to G-SYNC
    3. You can keep Vertical sync on Use the 3D application setting now to help remove frame time stutters (see here)
    4. Make sure that Preferred refresh rate is still set to Highest available
    5. If you do not have Preferred refresh rate or Vertical sync see the guide above on how to use the Nvidia Profile Inspector
    6. Don't forget to Apply and close Nvidia Control Panel
    7. Use a 3rd party frame rate limiter like RTSS and set a frame rate limit just a few fps below your monitor refresh rate, on a 144 Hz Monitor use 138
    8. Start Sekiro FPS Unlocker and more and set FPS lock to your monitors refresh rate
    9. Start the game and set it to Fullscreen
    10. Enjoy perfectly tearing free variable high refresh rates without VSYNC
     
    Last edited: Sep 20, 2021
    BlindBison likes this.
  6. BlindBison

    BlindBison Master Guru

    Messages:
    893
    Likes Received:
    190
    GPU:
    RTX 2080 Super
    Thanks I never knew about this, that's helpful to know. I was able to get everything to work great simply by disabling FSO on the exe then using control panel v-sync ON in conjunction with g-sync ON + FPS unlocker with cap set at 140 for 144 hz monitor.

    Next time around I play through the game I'll give what you've laid out a shot, I appreciate your explaining it all there.
     
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,602
    Likes Received:
    4,377
    GPU:
    GTX 1080ti
    apparently its not recommended to play DS3 with SpecialK, it can get you flagged by the anticheat.
     
    BlindBison likes this.

Share This Page