Call of duty Warzone stutter FIX (may help other games )

Discussion in 'Games, Gaming & Game-demos' started by bluedevil, Sep 7, 2020.

  1. bluedevil

    bluedevil Master Guru

    Messages:
    355
    Likes Received:
    10
    GPU:
    Kfa2 RTX 2060 6gb
    1. Force windows to keep Warzone in ram .
    This really helped fix my stuttering and can help other games.
    Use LargePage_Util and add ModernWarfare.exe then save
    http://www.mediafire.com/download/aiudd2j3at03j12/LargePage_util.zip

    Extra step for Windows 10 Home Edition
    You need to enable GPEdit for this to work.
    Use the guide from here : https://www.itechtics.com/enable-gpedit-windows-10-home/
    Use Method 2.

    For LargePages to work useraccount must have the 'Lock pages in memory' privilege enabled
    run secpol.msc
    Security settings then Local Policies User Rights Assignment folder.
    The policies will be displayed in the details pane.
    In the pane, double-click Lock pages in memory.
    In the Lock pages in memory dialog box if your username does not appear click Add User or Group, Advanced Find Now and select your username then ok and ok.
    Also add the administrator account there.
    You may also need to go to your game.exe click properties and tick Run as Administrator in the Compatibility tab.
    Restart.
    More info about the LargePage_Util here : https://forums.guru3d.com/threads/performance-boost-for-most-games.389072/
    Big thanks to harkinsteven and mbk1969 for the utility
    2.(Optional step can be skipped )
    Go to Documents\Call of Duty Modern Warfare\players and backup everything there then delete everything except your backup :>. Open up the game so it remakes the files then exit it. Your settings should be cloud saved and nothing should have changed but now you made sure that your config is the same as the one in the cloud.
    I recommend doing this because after i compared my config.cfg to the one the game recreated there were some diferences. Maybe the last update didn't recreate them or i had config.cfg readonly before the update... idk.

    3.Go to Documents\Call of Duty Modern Warfare\players
    Back up adv_options.ini.
    Open adv_options.ini and set VideoMemoryScale = 0.01 (my personal recommendation) or try to lower it from default to 0.55 0.5 or lower ... etc..(recommended from reddit)
    You can experiment and increase it to 0.99 and see if it stutters more. It will use more vram and also more ram.

    4.Ingame settings
    Set render resolution to 100. I recommend setting it to fullscreen not borderless.
    The most important one being texture resolution(Eats ram). I set mine to high and get no stutter but you might need to lower it.
    Disable Nvidia Highlits.
    Disable Catch Spot shadows and Catch Sun Shadows(eats RAM). You can experiment with them if you have plenty of ram 16gb or more.
    You can experiment with Shadow Resolution (Eats ram). I set mine to high . You might need to lower it.
    Streaming quality you can leave it on normal or try low if you still get stutters.

    5.Defragment your HDD. Do not defragment your SSD, it's bad for the SSD. Use Trim for SSD.
    Warzone stream a lot of stuff this is why this noob tip makes sense .

    6.Leave Sysmain on if you have a HDD and whaterver the default for SSD is .(It might be off for SSD by default). So just don't do anything :) . It compresses ram so it does not have to read from HDD as often.Less HDD access less chance for stuttering.
    Some may argue that it may use cpu to do it's job but the impact is probably close to zero and i believe it can help especially on low ram systems.
    I have it on .It probably does not matter but i disabled prefetch and superfetch anyway.

    Extra tips:
    Try with Game mode on/off and hardware acelerated gpu scheduling(HAGS) on/off.
    I set game mode off and HAGS on.
    SetTimerResolutionService
    https://forums.guru3d.com/threads/windows-timer-resolution-tool-in-form-of-system-service.376458/
    Experiment with turning off indexing

    Tip for 5:4 old style monitors.
    Set in game aspect ratio to auto then exit it.
    Open config.cfg search for auto and change it to 5:4". You need to make the file readonly else if you change any of the graphics settings ingame it will revert the config.cfg. This also means that each time you want to change something in game you disable readonly go ingame change exit and change the config.cfg back to readonly .
    -----------------------------------------------------------------------------------------------------------------------------------------------
    A B C and D are For advanced users only! I take no responsibility if you frack up your system .
    You risk messing up for little to no gain , 1 to 6 made the most difference for me.
    -----------------------------------------------------------------------------------------------------------------------------------------------
    A. Use a good guide to disable services that eat up your ram. A good start is https://github.com/madbomb122/BlackViperScript/releases (It's safe enough)
    Or for a more hardcore guide Fr33thy's services guide from youtube .
    Leave Sysmain alone. Experiment with it off only if you have plenty of ram.
    Experiment with prefetch and superfetch off.

    B. bcdedit stuff
    Disable HPET
    bcdedit /deletevalue useplatformclock
    Disable dynamic tick (laptop power savings)
    bcdedit /set disabledynamictick yes
    Disable synthetic timers
    bcdedit /set useplatformtick yes

    C. Regedit stuff
    Optimize Split Threshold
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control]
    "SvcHostSplitThresholdInKB
    set it according to how much ram your system has . Decimal should be
    ram X 1024 X 1024
    4194304 for 4gb ram
    8388608 for 8gb ram
    16777216 for 16gb ram
    The purpose is to not split svchosts so it will use less ram on your system .
    default value is 380000

    Ntfs stuff so it won't do a write when it does a read.
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
    "NtfsDisable8dot3NameCreation"=dword:00000001
    "NtfsDisableLastAccessUpdate"=dword:80000001
    I hope Windows is smart enough to DisableLastAccessUpdate for SSD else it wears it down .

    D.This can corrupt files on the disk !!! It can break your windows, you can lose files .
    I don't know if it's the same setting for SSD or even if it's ok to do it on a SSD. So i would not recommend it. All that being said :
    Turn off windows write catch buffer flushing on this device. It can give a lil bit more speed to your HDD.

    I would prefer that you don't ask questions about the advanced part, and use google instead.
    I don't really want to turn this thread into a game/system optimization guide because it will get derailed from the main subject, Call of Duty Warzone.

    Nvidia drivers seem buggy because they recreate the shaders every time i launch the game .
    Call of duty Warzone has a real problem it uses system ram from shared gpu memory instead of fully using my 6gb on my RTX 2060.
    I can force it to use more video memory by setting VideoMemoryScale higher but this also means it will use excessive amount of ram as shared gpu memory and this is what i don't want.
    If anyone has any idea how to disable or lower shared gpu memory please let me know.
     
    Last edited: Sep 8, 2020
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    8,411
    Likes Received:
    2,810
    GPU:
    GTX 1080ti
    what a load of crap.

    some of the things in your "guide" do not do what you seem to think they do.
     
    ShadowDuke likes this.
  3. bluedevil

    bluedevil Master Guru

    Messages:
    355
    Likes Received:
    10
    GPU:
    Kfa2 RTX 2060 6gb
    Correct me then , tell me what is wrong . Don't just say "what a load of crap" without any arguments.
     

Share This Page