C&c3 + 7950gx2

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Nazeeh, Mar 28, 2007.

  1. Nazeeh

    Nazeeh New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Nvidia 7950GX2
    Hey guys...

    Command & Conquer 3 came out today...and having had played the demo and loved it, I picked it up. Notice that the demo was working just fine on my Vista Ultimate 32 bit + 7950GX2 + 101.41 drivers. Smooth as butter...

    Game itself... nope...crashes just after splash screen haha... at work, the same game (installed it before leaving) runs very nicely on my 8800GTS card + 101.41 drivers.

    Luckily I had an ATI x1600XT to use and swapped for the Nvidia card and of course the game runs just fine.

    How did you guys do? Looks to me that Nvidia is focusing very hard on 8800 cards for Vista drivers with the series 7 ones an afterthought...

    Did anyone manage to get C&C3 running on 7950GX2 + 101.41?

    Thanks guys
     
  2. Auvers

    Auvers Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    Sapphire HD 5870
    Yep same thing happens to me :( lets hope nVidia gets the finger out pretty soon.
     
  3. x-speed69

    x-speed69 Ancient Guru

    Messages:
    2,248
    Likes Received:
    0
    GPU:
    2080 Ti Lightning
    yea when i had my 7950gx2 and 101.41 only War Front: Turning Point worked and all the others crashed before even seeing games main menu :(
     
  4. HulaHal

    HulaHal Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    XFX 5850 XXX
    Same Troubles here

    I, too, had the same problems.

    First, it took a few tries just to get the driver to load for both GPUs. That's another story.

    As with the others, the demo ran fine. Full game (even with the patch) gave me only the EA splash...then CTD.

    Vista gave me a report....looks to be primarily DirectX issues I sent a screen to Nvidia on their feedback page as well as to EA.

    So the game with gather dust until one or the other fixes the issues.
     

  5. TeX_UK

    TeX_UK Ancient Guru

    Messages:
    1,952
    Likes Received:
    2
    GPU:
    EVGA 1080 FE
    Try running it with older video drivers 90 series for example ;)
     
  6. Paulo Narciso

    Paulo Narciso Maha Guru

    Messages:
    1,226
    Likes Received:
    36
    GPU:
    ASUS Strix GTX 1080 Ti
    I have a better sugestion. Throw vista to the trash, install xp and play all your games smooth as butter :)
     
  7. chezouff

    chezouff New Member

    Messages:
    2
    Likes Received:
    0
    i had no problem playing the Demo but the full version seems to run significantly slower. i have a 7800GTX (95 series) and a p4 3.4 w/ 2Gb ram and its running kinda choppy and the video was out of sync, very strange.
     

Share This Page