C&C Red Alert 2 won´t install :(

Discussion in 'Games, Gaming & Game-demos' started by Andrés, Sep 7, 2006.

  1. Andrés

    Andrés Ancient Guru

    Messages:
    4,554
    Likes Received:
    0
    GPU:
    Sapphire HD 6950 2Gb
    Hi fellows!
    I don´t know how, my Red Alert 2 CD + Yuri´s Revenge runs fine on my computer at work (only in my free time, mind you :)) but here at home it refuses to install, saying the classic "illegal operation blah blah blah wanna send a report?". I´ve tried all the Compatibility tab options with no luck. The difference between both computers is that mine at home has a P4 with HyperThreading, 1Gb RAM and a Nvidia 6600, while the one at work has a standard P4, 512Mb RAM and a Nvidia MX4000.

    Looking on the Internet I´ve seen some people blame HT for this, while others said HT doesn´t bother at all, but I´m not going to disable HT and reinstall XP for only one game.

    Can anyone help me please?. Any ideas?

    Thanks,

    Andrés
     
  2. Jason9875

    Jason9875 Master Guru

    Messages:
    661
    Likes Received:
    0
    GPU:
    eVGA 8800GT
    My friend had this issue, and it was related to the copy protection.

    Do you think you could make an ISO of the disk and then mount it with daemon tools?

    And when using compatability settings, did you try setting 640x480 as the resolution?
     
  3. Andrés

    Andrés Ancient Guru

    Messages:
    4,554
    Likes Received:
    0
    GPU:
    Sapphire HD 6950 2Gb
    Thanks for the reply. I could try making an ISO, what program should I use for that?, Nero?, Alcohol?, BlindWrite?. As for the compatibility settings, I´ve tried everything including the resolution.
     
  4. Andrés

    Andrés Ancient Guru

    Messages:
    4,554
    Likes Received:
    0
    GPU:
    Sapphire HD 6950 2Gb
    Fixed. It turns out the bastard had many requirements:

    1. To connect my hard drive to the RAID chip (IDE mode) and leave the primary IDE channel for the CD drive.
    2. To reinstall the latest Intel chipset driver. This allowed me to install the game.
    3. To launch the game in compatibility mode.
     

  5. XP-200

    XP-200 Ancient Guru

    Messages:
    3,885
    Likes Received:
    20
    GPU:
    Asus GTX 970 Strix
    I know how you feel,although Xp is the best OS we have had up till now, its a bugger to get old games to work on it,I gave up trying to get older games like Klingon Academy and RA2 to run on XP stable,so i partitioned 30 gig and stuck Windows 98SE on it,now i can play the old games i never finished without any problems.:eek:c:
     
  6. Andrés

    Andrés Ancient Guru

    Messages:
    4,554
    Likes Received:
    0
    GPU:
    Sapphire HD 6950 2Gb
    Yeah it´s a shame, the compatibility mode should also include a RAM limit, btw. I don´t like the idea of installing Win98 on my rig mainly because some components don´t have the right drivers, but I admit I considered the idea :)

    Thanks for the feedback, hope this helps someone out there.
     
  7. XP-200

    XP-200 Ancient Guru

    Messages:
    3,885
    Likes Received:
    20
    GPU:
    Asus GTX 970 Strix
    Well just so you know..

    I got a 98 windows nvidia video driver from here no problem and it works fine.
    USB and 4 in 1 drivers for 98 are also easy to find on the net.
    Only problem i had was there is no 98 driver for my SB Audigy 2,but there is for the on board sound card so again everything works fine.
    Even got a 98 driver for my logic attack joystick(really needed for Klingon Academy).
    If you do stick decide to install 98 stick with DX8.1,as DX9 caused problems once installed,causing me to reinstall 98 all over again.

    And then its just a case of dropping into the bios and selecting which HD to boot from.
    Old gaming has never been so good,well it was years ago but then i did not have the hardware to play these old game correctly...:D
     
  8. Dmingo

    Dmingo Member Guru

    Messages:
    113
    Likes Received:
    0
    GPU:
    8800 GTS 512 810/2000/2200
    I used to love playing that game tried to install it on my new comp and didn't work out. Researched a bit and found out that it has incompatibilty issues with SP2 and i tried it on 4 comps with SP2
     

Share This Page