Bug State UVD all AMD cards

Discussion in 'Videocards - AMD Radeon' started by Wolf2079, Feb 5, 2017.

  1. Wolf2079

    Wolf2079 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    NITRO RX 580 8 GB
    Good day, I have a MSI R9 280x, these cards like others have a blinking problem in 2d which has already been fixed by editing my bios, the problem that has not been fixed yet is the error of the UVD state that is 501hz later To navigate youtube or play videos with the acceleration of hadware. I was watching past drivers, specifically the catalyst 14.12 omega, these have a chain that caught my eye, its name is KMD_MaxUVDSessions, this is added to the registry and so far I have not received the error of the UVD state, the clocks go down to 300 in the core and 150 in the memory of the r9 280x respectively, that's why I share this small .reg file to try if you want and so to know that not only is it functional to me, I hope you can use it and let me know if the Error disappears ... Within the file reg is also added the chain DalAllowDirectMemoryAccessTrig the same is also present in the drivers 14.12 omega, it has to do with access to the memory of the card, greetings and excuse my English, I only speak Spanish.

    https://openload.co/f/aLDICWvHAuU/AMD_TUNE.rar
     
  2. OnnA

    OnnA Ancient Guru

    Messages:
    3,451
    Likes Received:
    53
    GPU:
    Nitro Fiji-X HBM 1150/570
    Great Job !
    We will add this to the RadeonMOD :D

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000]
    "KMD_MaxUVDSessions"=dword:00000020
    "DalAllowDirectMemoryAccessTrig"=dword:00000001
     
  3. Wolf2079

    Wolf2079 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    NITRO RX 580 8 GB
    Good day, the missing file here was extracted from amd controllers in particular the 1412 omega, this only done in order to try to help many who like me experienced the annoying UVD error, since the same Error amd itself has not reconciled in its latest drivers for which we are owners of the architecture Core Next 1.0, I am checking other drivers to see if we can finally solve this error and hopefully others do the same for the benefit of the entire community greetings And to continue investigating. Ahhh I forgot my friend OnnA I am from Panama, not from the brother country of Spain and if, unfortunately after hours of tests the error appeared, but it is a positive advance since the time to appear said error has been prolonged enough, greetings.
     
  4. chris89

    chris89 Member Guru

    Messages:
    130
    Likes Received:
    0
    GPU:
    1 bit of video ram pcie
    I was able to pseudo correct this issue via bios mod. I can force it to 8 watt idle continuous even under dxva load... without 3d clock allowance though... would need to have one bios switch on 2d fix, other on full speed 3d and use CRU Restart64.exe to reset driver without restarting...

    By the way I worked tirelessly working on this issue with 380x/ 290x. In particular on the 380x, altering UVD status in any way does nothing what so ever.

    It's all about defining the precise amount of clock voltage for the state the card is in, in any given scenario. No cup of tea, I'll tell you.

    You could PM me your GPUZ Bios .rom and I can take a look, if interested.
     
    Last edited: Feb 24, 2017

  5. bryter

    bryter New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Gigabyte 7950 Windforce
    For the first time since 16.7.2 with Windows Creator Update and yesterday AMD driver update 17.4.3 I now don't have the UVD bug anymore. I was finally able to switch back to my original bios (I had a custom to by-pass the bug). My 7950 now idles at 300/150 like it's supposed to and not at 501/1250 (UVD state 1), and while gaming I have my overclocked frequencies and I'm not stuck at 900/1250 (UVD state 2)
     
  6. Assiduous

    Assiduous New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    R9 270 / 2GB
    I've experienced the UVD bug with every driver release i've tested after 16.7.2. I've scanned my registry and can find no trace of a "KMD_MaxUVDSessions" dword. I am using 16.7.2 and do not have the UVD bug. R9 270 GCN 1.0.
     

Share This Page