Bug: Catalyst reverts Pixel format when launching games in full screen

Discussion in 'Videocards - AMD Radeon Drivers Section' started by artina90, Dec 26, 2013.

  1. artina90

    artina90 Active Member

    Messages:
    66
    Likes Received:
    12
    GPU:
    RTX 2080Ti
    Every time I launch Battlefield 3,4 War Thunder and many other games my screen goes blank for 2 seconds then when the game starts the pixel format has been changed to ycbcr which makes the games look all like pixellated garbage. I suspect that this is due to a change of screen resolution/mode since during those 2 seconds at the beginning my screen says no input detected, the weird thing is that my desktop resolution is the same as my full screen in-game resolution. The real problem is that once it switches to ycbcr it's impossible to revert back to RGB because If I alt-tab the pixel format goes automatically back to RGB and if I go in the catalyst it is indeed set to RGB, but if I alt-tab back to the game it becomes ycbcr again and I can't access the catalyst blindly while keeping the game in full screen :bang: it happens with all driver versions I'm currently using 13.12, is there anyway to force pixel format modifying the registry?
     
  2. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    7
    GPU:
    7950 Vapor-X 1100/1500
    More likely to be your monitor I think. What model is it?
     
  3. artina90

    artina90 Active Member

    Messages:
    66
    Likes Received:
    12
    GPU:
    RTX 2080Ti
    My screen is a Packard Bell Maestro 220 but I don't think it's a screen issue it must be the driver because I can replicate the result by changing the pixel format to ycbcr in the catalyst without touching any settings on my monitor
     
  4. artina90

    artina90 Active Member

    Messages:
    66
    Likes Received:
    12
    GPU:
    RTX 2080Ti
    I've figured out what the problem is, when I launch battlefield If I go in the video settings I can see that the display mode switches to 1920x1080 @59hz and there is no option for 60hz, the monitor supports 1920x1080 @60 @59 and @30hz. If I go to the screen resolution windows control panel option and I manually set the screen at 59hz I get the pixellation and if I go in the catalyst and change the pixel format it stays pixellated no matter which pixel format option I choose. Using the remote I figured out what the problem is, the settings in the tv menu for 59hz are different from those @60hz, it probably has a PC mode for 60hz and a tv mode for 59hz there are other settings that pop up like saturation and sharpness that are not available in the 60hz mode. What I would like to do now is deleting the 59hz mode from windows somehow so battlefield will be forced to use the 60hz mode that gives me no problems, if you know a way to do so please reply :)
     

  5. artina90

    artina90 Active Member

    Messages:
    66
    Likes Received:
    12
    GPU:
    RTX 2080Ti
    So I've found out another thing, the refresh rate change happens only with applications that run in full screen exclusive mode, my monitor doesn't support 59hz running in PC mode and uses the fall-back tv mode to display 59hz. The screen is detected as a generic pnp monitor and has the 59hz mode listed as supported, I tried to create a custom inf driver to change the edid with phoenix edid designer but it says that the edid is invalid :bang: I'm still looking for a way to remove the 59hz mode or for a way to force the full screen exclusive mode to use the 60hz mode :help:
     
  6. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,731
    Likes Received:
    183
    GPU:
    EVGA GTX 1080Ti SC
  7. JohnLai

    JohnLai Member Guru

    Messages:
    136
    Likes Received:
    7
    GPU:
    ASUS GTX 970 3.5+0.5GB
    So....HDMI?
    Okay, try this. Open CCC, go to Video, then Color. At 'Basic Video Color', select 'Use AMD Settings' and of course, select 'Standard' as preset.

    It will fix the darn YCBCR/RGB issue.
     
  8. artina90

    artina90 Active Member

    Messages:
    66
    Likes Received:
    12
    GPU:
    RTX 2080Ti
    I've finally fixed it!!! :banana: I used a software called powerstrip and after 2 hours of tweaking I managed to force the screen to stay in PC mode, to do so I had to create a new resolution different from the 1080p 60hz, editing the existing one didn't work so I had to go beyond 60hz. Now I'm running at 64hz and the screen stays in the same mode even when switching to exclusive full-screen mode, I've been playing battlefield for 3 hours and the screen is still working fine, since it's not supposed to run at 64hz will it break with time? I noticed that the games now with v-sync run at 64fps, is there any downside in running such a weird refresh rate, should I push it to 70 to make the number even?
     
  9. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,731
    Likes Received:
    183
    GPU:
    EVGA GTX 1080Ti SC
    Round numbers? hahahaha

    If anything, 64, a power of 2, is a rounder number than 70 for a PC.

    If you can overclock, why not, 72Hz is smoother than 60Hz.Just make sure you don't get any frameskipping by going to testufo.com and taking a photo of the frameskipping test there.
     

Share This Page