BSOD's in crossfire

Discussion in 'Videocards - AMD Radeon Drivers Section' started by tom91x, Mar 30, 2011.

  1. tom91x

    tom91x Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    6950 CF
    Both cards run fine on their own so its not faulty cards, tested mem, run everything at stock, basicly its just driver problems with running two 6950's in crossfire.

    Its either been system service exception: atikmpag.sys errors

    or something about the driver reseting.

    Are these just ATI's poor drivers that im going to have to put up with?

    Atm im just running one card, i cant be bothered with the hassel, ill stick the other in when a game that actually uses it comes out.

    edit: also psu is a 850w corsair, so no probs there.
     
    Last edited: Mar 30, 2011
  2. dade_kash_xD

    dade_kash_xD Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    2x XFX DD R9-280x 3gb
    I'm having the same issue. Same exact bsod with the same exact dlp error. The only time it happens is with crysis 2 in fullscreen. It doesn't happen with any other game or any benchmark. I ran unigine for 1 hr and didn't have any issue. I also played black ops for an hour maxed out fullscreen with no issue. Now when I run crysis 2 in fullscreen with 6950 bios I have no issue.

    Now this only started happening when I flashed to 6970 bios. Did you flash to 6970 bios? Is it happening with crysis 2? What games does it happen to you with?
     
    Last edited: Mar 30, 2011
  3. Amdgameplayer

    Amdgameplayer Master Guru

    Messages:
    325
    Likes Received:
    0
    GPU:
    Amd HD6970 crossfire
    have you installed your motherboard chipset drivers this is what fixed it for me hope it helps :D
     
  4. tom91x

    tom91x Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    6950 CF
    Hi, nah havent tried crysis 2, for me heaven doesnt start at all, it wont run with crossfire on my system just BSODs, works fine with 1 card though. Bad company 2 runs fine, shogun was ok, this just happens sometimes at start up, sometimes when i open a graphics card app like msi afterburner or gpu-z.

    I unlocked the shaders (modified original bios rather than switched to 6970.) but these problems were happening before i did that.

    So frustrating, the cards are amazing when they work, but i miss nvidia and their stable drivers!
     

  5. tom91x

    tom91x Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    6950 CF
    also another thing, bad company 2 wont load with my graphics cards overclocked anywhere above the original 800mhz .
     
  6. dade_kash_xD

    dade_kash_xD Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    2x XFX DD R9-280x 3gb
    Which mobo chipset drivers are you referring to? When I built this system 2 weeks ago I downloaded and ran every single driver Asus had on their site for my board. I just noticed they did a bios update so I'll do that tonight.
     
  7. Brandon_34

    Brandon_34 Master Guru

    Messages:
    320
    Likes Received:
    0
    GPU:
    EVGA 690GTX
    did this work for you? Had the same problem with 6970s in crossfire.
    disabling speedstep and bumping the vtt voltage from 1.3 to 1.325 seems to have cleared it up so far.
     
  8. Detection

    Detection Banned

    Messages:
    1,055
    Likes Received:
    0
    GPU:
    2 x 6850 - CrossFireX
    Have you set your mobo BIOS up for Xfire ?

    I had similar issues - I had to enable an option in my BIOS to tell it to use crossfirex
     
  9. dade_kash_xD

    dade_kash_xD Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    2x XFX DD R9-280x 3gb
    My GPU's run excellent in CrossfireX with either 6950 BIOS OC'd or 6970 BIOS OC'd, for every single game EXCEPT CRYSIS 2!!! I am able to run every single game and every single graphics benchmarking tool known to man with absolutely no issue. I can run Crysis 2 with no problem in WINDOWED MODE ONLY! Once I set Crysis 2 to run in 'fullscreen', after about 5-10 minutes of gameplay, I get a BSOD. This doesn't occur in any other game or benchmark when CrossfireX is enabled.
     
  10. mmsandi

    mmsandi Master Guru

    Messages:
    356
    Likes Received:
    0
    GPU:
    5850
    @dade
    in crysis 2 binaries rename crysis2.exe to fear.exe and see if that helps
     

  11. Tmax

    Tmax Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 5870 Crossfire
    I had the exact same problem with my 5870 single and in Crossfire Mode. BFBC2 is very sensitive to clock speads form some reason. I bought a Gigabyte overclocked 5870 at 950Mhz. I actually had to turn it down to 900Mhz before BFBC2 would run right. That is the only game I have had that problem with.
     

Share This Page