Brightness problem (black screen) when updating AMD drivers

Discussion in 'Videocards - AMD Radeon' started by DiogoMartins, Oct 19, 2015.

  1. DiogoMartins

    DiogoMartins New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    idk
    Hello and good day,

    First let me apologise if i'm not using the forum correctly, but this is my first time around...



    So I've been having this problem for about two weeks and i think i have tried just about everything, from changing some settings like "EnableUPLS" on the registry to clean install the drivers again (uninstalling with DDU) .



    I clean installed Windows 7 Home Premium on my ASUS X54H, and when rebooting after installing the latest AMD drivers (specific to my machine) the screen whet black after the windows boot up screen, or so i thought because yesterday I noticed that the screen isn't actually black but just really (and i mean REALY) low on brightness.



    From the two weeks of google searching I noticed that the problem is not that rare (even though most people don't notice that the screen isn't actually totally black).



    The only solution I think could do the trick is installing older drivers , wich i dont actually mind, BUT there is a problem with that, when i try to install the older version of the driver it looks like the attached images.

    [​IMG]

    [​IMG]


    As you can see the older "drivers" don't actually have the "display drivers", so when you install and reboot the computer stays the same.



    (I also forgot to mention that if i connect the computer to a tv via HDMI or to an old monitor i can see the screen fine, without any problem).



    Any help would be apreciated, and if you need anything from my side just ask.
    Sorry for the long post,



    Diogo Martins
     
  2. jura11

    jura11 Ancient Guru

    Messages:
    2,165
    Likes Received:
    357
    GPU:
    GTX1080 Ti 1080 FE
    Hi there

    Did you tried to install drivers as unsigned,something very similar happen to my friend with his HD4890(I know its pretty old GPU) and we are tried everything possible to install drivers,but we been unable to install until we are enforced Load unsigned driver

    Please have look on this

    https://www.raymond.cc/blog/loading-unsigned-drivers-in-windows-7-and-vista-64-bit-x64/2/

    In yours case you are running I think HD6470m which should be supported on several Catalyst drivers,did you tried some older drivers ?

    I think if you can search over here,you can find them over here


    And this power saving mode,did you check Power saving option,if not then please check that,its strange,never happen to me and I've two laptops which does have AMD GPU there and never saw such issue there

    Good luck and hope this helps

    Thanks,Jura
     

Share This Page