bricked RTX 2070 (bad flash)

Discussion in 'Videocards - NVIDIA GeForce' started by revenge, Jan 25, 2023.

  1. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    [SOLVED]

    I flashed a wrong bios into my RTX 2070.
    I have a RTX 2070 VENTUS GP, and i flashed a VENTUS bios with a little higher power limit, because mine was max 100% power limit.
    Then it flashed, and black screen.

    Then it would not boot with GPU installed. (found out later, i had to switch PCI graphics to onboard)

    Device manager shows RTX 2070, but it won't work whatsoever. I can even install Nvidia drivers. But when i try to flash my old bios back into it, it keep saying
    No Nvidia adapters found...

    Is there something i can do?
    Please help i will never flash bios again i promise

    [​IMG] [​IMG] [​IMG]
     
    Last edited: Feb 1, 2023
  2. Maddness

    Maddness Ancient Guru

    Messages:
    2,440
    Likes Received:
    1,738
    GPU:
    3080 Aorus Xtreme
  3. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    i cannot do anything with NvFlash as it does not detect any Nvidia Display Adapters.

    Got some advice to buy an CH341A flasher, will try this
     
  4. chinobino

    chinobino Maha Guru

    Messages:
    1,140
    Likes Received:
    75
    GPU:
    MSI 3060Ti Gaming X
    @revenge I have an Asus RTX 2070 mini that I successfully cross-flashed with the Asus RTX 2070 EVO OC V2 BIOS to increase to power limit from 175 W up to 222 W.

    Which version(s) of nvflash have you you tried?

    If Nvflash is no longer recognising the card you may need to try different versions.

    I have uploaded some patched versions of nvflash that should work with your RTX 2070. They have all been patched to disable "Override PCI Subsystem ID mismatch".

    Nvflash Patched

    You should use the following command to flash the original BIOS back to the card (assuming you only have one nvidia card in your system and it is index 0) then reboot the system:
    Code:
    nvflash64_5.xxx_patched.exe -i=0 -6 <BIOS.ROM>
    Start with the most recent version of the patched nvflash in the mega link above and work your way back to the older ones if the card is still not being recognised.
     

  5. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    Thank you for your help!
    Tried them all, but it keeps saying "No Nvidia Display Adapters Found"
     
    Last edited: Jan 26, 2023
  6. chinobino

    chinobino Maha Guru

    Messages:
    1,140
    Likes Received:
    75
    GPU:
    MSI 3060Ti Gaming X
    @revenge If Device Manager is showing the device as "Nvidia GeForce RTX 2070" with a yellow bang then it looks like Windows has attempted to install drivers and failed.

    Use DDU in safe mode to "clean up and do not restart" and then try Nvflash while still in safe mode.
     
    Last edited: Jan 26, 2023
  7. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    I have tries exactly that too. Didn't work
     
  8. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    Only with a paperclip trick i was able to boot with the GPU installed. ** Found out later it would boot up with GPU installed
     
  9. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    Got it back to working again with the flasher ;)
     
    Airbud, chinobino and fantaskarsef like this.
  10. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    15,730
    Likes Received:
    9,627
    GPU:
    4090@H2O
    Glad you got it sorted and can use your GPU again to game ;)
     
    revenge likes this.

  11. chinobino

    chinobino Maha Guru

    Messages:
    1,140
    Likes Received:
    75
    GPU:
    MSI 3060Ti Gaming X
    @revenge That's great to hear - so you're back to stock VBIOS?
     
    revenge and Airbud like this.
  12. Airbud

    Airbud Ancient Guru

    Messages:
    2,593
    Likes Received:
    4,129
    GPU:
    XFX RX 5600XT
    perfect example of....if it works don't f*** with it...
     
    revenge likes this.
  13. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    yes i had a backup of the original bios

    but i have to say, i had a hard time using the flasher, because the winbond bios chip was very close to a transistor on this particular gpu..
    So i could not mount the clip on the bios.
    Then i burned some plastic off the clip, and got it mounted after like 20 times, because the clip would not clamp anymore after the burnings, i had to hold it manually very still.
    Each pin must make contact of course with the pins on the bios.
    That was not easy.
    But iam very happy it worked again. Could not believe my eyes to be honest :eek:

    [​IMG] [​IMG] [​IMG]
     
    Last edited: Jan 31, 2023
    user1 and Airbud like this.
  14. revenge

    revenge Member

    Messages:
    13
    Likes Received:
    6
    GPU:
    gtx 680 lightning
    You are right. But i did flash alot of gpu's, and never had this problem before. Now i think i will never flash bios again
     
    Airbud likes this.
  15. Culpeper

    Culpeper Member

    Messages:
    23
    Likes Received:
    12
    GPU:
    3080 ti FE
    Personally anytime I have ever flashed a bios or firmware on anything it never worked again. That's why I'm on websites like this.
     
    pegasus1 likes this.

Share This Page