Borderless fullscreen question

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Netherwind, Aug 15, 2020.

  1. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,647
    Likes Received:
    1,534
    GPU:
    MSI 3080 Gaming X
    I've always wondered why the GPU clock speed and voltage increases once I "tab out" of WoW for example while it being in Borderless mode (as seen on the picture).

    Left : tabbed out
    Right : in game

    [​IMG]
     
    Last edited: Aug 15, 2020
  2. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,367
    Likes Received:
    765
    GPU:
    EVGA 1070Ti Black
    I thought it is bug that been around for while. thought I thought at some point it actual effect framerates too, that might been fixed?

    Cant say i ever noticed it though. is Gamemode enabled or disable in windows?

    my guess would be that the browser is triggering full clocks and game is using adaptive/optimised?

    I have been using Max peformance in global for well over 2 decade , i put adaptive on any process/program that keep my system from doping in to idle when my system is just sitting on the desktop?
     
    Last edited: Aug 15, 2020
  3. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,647
    Likes Received:
    1,534
    GPU:
    MSI 3080 Gaming X
    Strange thing is that yesterday and this morning I noticed that the bug was gone, but later today I got it back and I haven't really restarted my computer, just put it in sleep two or three times. I'm wondering if it's a program or something else triggering this bug. Same in Horizon Zero Dawn, I opened the map which normally puts the GPU in close to 2D clocks but when I tabbed out (running the game in borderless ofc) the GPU jumped up to 1575MHz.

    Game mode is disabled in Windows...or it should be, I'll check.

    I don't run Max performance due to certain programs triggering 3D clocks like iCUE or Chrome (if HW acceleration is enabled).
     
  4. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,367
    Likes Received:
    765
    GPU:
    EVGA 1070Ti Black
    make profile for it and set them to adaptive which make global max peformance let gpu drop to idle providing it not the only process triggering 3d clocks. I dont trust dynamic clock so i avoid it when possible and I dont use Sleep/hibernation either, maybe it a side effect that happen when using sleep/hibernation ?
     
    Last edited: Aug 16, 2020

  5. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,058
    Likes Received:
    100
    GPU:
    RTX 3090 ROG Strix
    Do you keep iCUE running? If so, try to disable it from startup and not use it for a while and see if the problem occurs again. From my experience Corsair's iCUE can lead to strange behavior, especially in conjunction with sleep and/or hibernation, so it might be worth a shot.
     
  6. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,647
    Likes Received:
    1,534
    GPU:
    MSI 3080 Gaming X
    I guess you are right but generally I don't need the Max Performance since Adaptive was enough and Optimal was too conservative but lately I just don't bother.

    I do but I'd of course prefer just to leave it at my standard settings and not have it start up every time. I mainly use iCUE to increase fans if I play a very GPU intensive game where I prefer to run a fixed RPM, but that doesn't happen too often. Anyway, not sure I even know what happens if iCUE doesn't start when Windows starts.
     
  7. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,058
    Likes Received:
    100
    GPU:
    RTX 3090 ROG Strix
    I keep iCUE Autostart disabled and start it manually when I need or want to change fan speeds/curves or lights, then close it again. If you don't rely on iCUE for advanced functionality (for mice and keyboard macros for example, or some advanced, non-hardware lighting profiles), it's certainly something you could try and see if it helps and still works the way you want it to.
     
    Last edited: Aug 17, 2020
    Netherwind likes this.
  8. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,367
    Likes Received:
    765
    GPU:
    EVGA 1070Ti Black
    @Netherwind it perfernce thing some rather use adaptive/optimal some rather use max performance .in the end all them will let system gpu go in idle clocks when system is idle when properly configured.

    Max peformance fail to let system go in idle if there process that hit gpu that dont have there own profile and are set to adaptive,
     
  9. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,647
    Likes Received:
    1,534
    GPU:
    MSI 3080 Gaming X
    Good idea, I'll try that.

    Gotcha, thanks for letting me know how it works.
     

Share This Page