Borderlands 2 + MSI 670 oc + Physx High

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by mentalpeace, Sep 26, 2012.

  1. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    9,819
    Likes Received:
    65
    GPU:
    1080Ti H20
    Screenshot exactly where it happens for reproduction purposes?
     
  2. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    729
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    I tried the game out on my 5820k/980Ti system and it still has issues when the engine is displaying too many particles, the framerate can still take a dive no matter how much power you throw at it. Even without PhysX on, some scenes near the end of the game with dozens of robotic enemies and far view distances, it can still drop below 60 occasionally. UE3 was never built to handle thousands of draw calls a second, nothing we can do about it unfortunately.
     
  3. CrazyBaldhead

    CrazyBaldhead Master Guru

    Messages:
    256
    Likes Received:
    0
    GPU:
    GTX 1070
    There is absolutely nothing wrong with your system, no one has ever been able to max out PhysX in Borderlands 2 and maintain decent framerates. Turn it down already.
     
  4. adabiviak

    adabiviak Master Guru

    Messages:
    716
    Likes Received:
    0
    GPU:
    Gigabyte GTX 980Ti
    I'll bite. I've been playing the game with Physx on high since the game came out. With my old Core2Duo, I turned other video features down to let Physx rock (and even then, there were occasional slowdowns), but my current rig hasn't. I also "play" with the Physx a lot. I'll drop a bunch of Physx goop in front of PWR Loaders so their blades will spray it around when they walk through it. I'll drop a bunch of Physx goop on the ground in front of me, and kite an enraged Goliath into a ground pound in the middle of the puddle to send it flying. I'll send a tidal wave of Physx goop at an enemy by Executing through a fresh puddle. I'll go "bowling" with Hyperion e-tech shotguns (where you shoot low so the "ball" winds up bouncing very close together, where each bounce will cause a little explosion of Physx goop so you get a brief fountain near the end of the "roll". I don't know how many times I've thrown singularity grenades at these puddles just to see the goop get sucked into the air and then sprayed around. I'll shoot the ground around warping Rift Threshers just to throw more particles into their singularity. Hand to god, I was just doing this not half an hour ago.

    Physx is my favorite eye candy in this game... let me fire some of these things up with an FPS counter on. If you have a known Physx situation that causes a slowdown, let me know.

    edit - I'm in Thousand Cuts with corrosive weapons throwing green goop, Scorn throwing purple goop, ground particles flying everywhere and I'm 60+ FPS. I see brief slowdowns whenever I hit a checkpoint though. Let me try a fire weapon (sometimes they throw a lot of ash).
     
    Last edited: Jun 22, 2016

  5. jaredpace

    jaredpace Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    4890 975/1150
    Use Notepad to open Willowengine.ini located here:

    C:\Users\username\Documents\My Games\Borderlands 2\WillowGame\Config\Willowengine.ini

    To get a small boost, change

    Physxlevel=2
    MaxParticleResize=512

    For a larger boost, change

    Physxlevel=1
    MaxParticleResize=256



    Still won't alleviate 40 fps when Gunzerking dual DPUH at point blank range...

    Hehe!
     
  6. adabiviak

    adabiviak Master Guru

    Messages:
    716
    Likes Received:
    0
    GPU:
    Gigabyte GTX 980Ti
    I should mention that I did change the rendering engine to Ryan (as opposed to Cinematic or the default). I'm not sure if that's helping or hindering this, but I prefer the way this looks. I'll try gunzerking like that.

    edit - I do see a difference in framerate with Physx on or off, but not so much that I'd turn that eye candy off. That's just me though.
     
    Last edited: Jun 22, 2016
  7. CrazyBaldhead

    CrazyBaldhead Master Guru

    Messages:
    256
    Likes Received:
    0
    GPU:
    GTX 1070
    You're gonna have to rebut everyone else along with me with these claims. The game is years old by this point and the issues with PhysX are beyond well documented. All you need to do is a google search. If you have a fix or if somehow this does not affect you, document it and pass it along. If only you weren't a few years late.
    My game used to dip below 60 FPS at points which I found to be unacceptable- I looked it up and it was due to High PhysX.

    Well, I don't think a game from 2012 warrants those framerate drops- especially when it runs perfectly well at 4k with PhysX turned down only a notch. I guess tolerance levels vary.
     
    Last edited: Jun 22, 2016
  8. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    5,263
    Likes Received:
    5
    GPU:
    GTX1080Ti

    I'm running a GTX 980Ti with a GTX TITAN SC dedicated to PhysX and I get slow downs below 60FPS (chugging) when too many PhysX effects are on screen. Everyone does. It is inherent in the game, period.
     
  9. adabiviak

    adabiviak Master Guru

    Messages:
    716
    Likes Received:
    0
    GPU:
    Gigabyte GTX 980Ti
    The next time I kite a wounded HOT Loader around so I can splash around in his fuel and ash spray where the framerate doesn't dip below 80, I'll keep that in mind.
     
  10. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    5,263
    Likes Received:
    5
    GPU:
    GTX1080Ti
    Right. You have a magical system that doesn't have the inherent issues with the PhysX implementation that pretty much every review ever written for the game mentions. Got it.
     

  11. HonoredShadow

    HonoredShadow Ancient Guru

    Messages:
    4,220
    Likes Received:
    1
    GPU:
    MSI 980Ti OC+ASUS Swift
    I also have exactly the same issues as others here and reviewers. I want a magical system too.

    This is with two different systems and cards (980ti and other 970+970 for PhysX).
     
  12. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    5,263
    Likes Received:
    5
    GPU:
    GTX1080Ti
    Maybe they think we are dissing PhysX. The effects look great. However it has issues. I'm doing another play through on Arkham Asylum at 4K with every setting maxed. It looks amazing. It's almost like a different game when you can play it at that high of visual fidelity.
     
  13. adrock311

    adrock311 Master Guru

    Messages:
    791
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
  14. jaredpace

    jaredpace Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    4890 975/1150
    just change MaxParticleResize from 0 to 256 if you want minimum PhysX fps to go from ~35 to 60
     
  15. TyrianZero1

    TyrianZero1 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    EVGA 980 ti / 6GB
    Not sure if this has been mentioned (didn't read through this entire thread from 2012). But as much as I love the pretty physx in Borderlands 2, I usually have it off because it can cause items to fall through the floor. Go to pass an item to a friend and *bloop* through the floor it goes. Farming bosses, "ooh I saw a legendary!" aaaand it's gone.
     

  16. CrazyBaldhead

    CrazyBaldhead Master Guru

    Messages:
    256
    Likes Received:
    0
    GPU:
    GTX 1070
    Yeah, that's another known issue.
     
  17. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,101
    Likes Received:
    7
    GPU:
    MSI GTX 1070 AERO OC
    Got Borderlands 2 this sale, and as i'm enjoying it the PhysX blows.

    Can't even maintain 60 FPS at Medium PhysX including INI Tweaks for it.

    That's on a 4770K @ 4,5 GHz and GTX 1070 (1920 x 1200)
     
  18. ESlik

    ESlik Ancient Guru

    Messages:
    2,338
    Likes Received:
    0
    GPU:
    EVGA x2 1080 Ti SC Black
    Somethig isn't right. My wife runs that game at 1920 x 1200 with one GTX 980 with in game settings fully maxed, including Phys x. The 980 is also fully maxed, and DSR at maximum resolution. Maybe a driver issue? Try an earlier driver. Can't hurt.
     
  19. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,101
    Likes Received:
    7
    GPU:
    MSI GTX 1070 AERO OC
    Naah it's issue with the Game i read.

    No one can run a steady 60 FPS when intense action happens, not even people with a 1080 and Titan.
     
  20. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    729
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    That kind of performance would be an indicator that PhysX isn't activated and early on in the game. There are some spots in the middle to latter part of the story mode that can dip even with PhysX turned off and using lowered settings due to the sheer amount of draw calls that are being processed by an engine that wasn't built to handle it.
     

Share This Page