1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bizzare Crysis 2 DX11 Ultra Texture Package performance

Discussion in 'Videocards - AMD Radeon Drivers Section' started by dade_kash_xD, Jul 9, 2011.

  1. dade_kash_xD

    dade_kash_xD Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    2x XFX DD R9-280x 3gb
    So, my sig rig is what I'm using (can be found to the left of this post OBVIOUSLY) to run Crysis 2. I have an issue where when I launch Crysis 2 in DX 11 it automatically defers my screen to run at 1080/24p. When I run C2 with DX11, High Res Pack, and EVERYTHING on Ultra Settings at 1080/24p, I get 72-115 FPS. This is great however, being that my screen's refresh rate is stuck at 24hz, although my GPU's are producing 72-115 FPS (according to MSI AB & FRAPS), the game is limited to 24 FPS -- hence 24hz refresh rate. Now, I can do the ALT + TAB 'trick' at launch to force C2 to display at 1080/60p, but when I do, my frames run from 25-45 FPS.

    I have tried using a custom resolution VIA CCC but this does not fix the 1080/24p issue. The only thing that corrects it is the ALT + TAB trick. On to the reason for this post: Is there anyway possible that I can get my rig to produce those lovely 72-115 FPS at 1080/60p?
     
  2. The Goose

    The Goose Ancient Guru

    Messages:
    2,236
    Likes Received:
    38
    GPU:
    Evga 1080FTW
    the only thing i can suggest atm is make sure vsync is disabled,i run my system(see left) on a sharp 32" lcd and have the same problem but just dont use vsync...works for me
     
  3. dade_kash_xD

    dade_kash_xD Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    2x XFX DD R9-280x 3gb
    I don't use VSYNC either. If I use VSYNC in C2, being that it's running in 24hz, it would truly lock my frames at 24 FPS, constant. This is so frustrating! I fear it will only be fixable if Crytek releases a patch and may not be fixable from AMD's standpoint alone. :\
     
  4. TheWhateverDude

    TheWhateverDude Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    HD5870 1GB@Stock1080p60Hz
    Using vsync while running at 24hz would actually be better (less tearing provided fps never dip below 24). no vsync is best used when running at 60hz with the alt+enter at logo trick.
     

  5. GrandMax

    GrandMax Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    GTX 680 @ 1270Hz
    2 simple solutions for the 24p:

    1. Use radeon pro to force the refresh rate or...
    2. Use CCC to create a custom resolution of say 1904x1080 at 60hz. In the game you will be capable of choosing that one and the game won't be have issues selecting the 24p or 60p. This is what I do. Make sure you take that new rez ingame.
     
  6. |ALE|

    |ALE| Master Guru

    Messages:
    387
    Likes Received:
    0
    GPU:
    Sapphire R9 Fury X
    deactivating and reactivating vsync from games, fixed 60hz for me at 1920x1080

    EDIT:

    restarting the game, this tricks doesn't worked anymore. :wanker:

    same problem 24hz 1080p with super streeth fighter IV
     
    Last edited: Jul 9, 2011
  7. adolfotregosa

    adolfotregosa Member

    Messages:
    46
    Likes Received:
    0
    well you can always create a custom monitor inf and remove the 24hz like i did.. problem solved forever
     
  8. alco

    alco Master Guru

    Messages:
    933
    Likes Received:
    0
    GPU:
    Asus gtx780 DirectcuII OC
    i had the same issue what i did was this

    i created a "weird" custom resolution in my (nvidia) control panel
    i made 1919x1080 (normal would be 1920x1080)
    i start up crysis and select that resolution and playing at 60Hz

    just choosing 1920x1080 gets me also to 24P (even if my CP is set to 60hz)

    closing and restarting crysis keeps working on 60 Hz
     
  9. TheWhateverDude

    TheWhateverDude Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    HD5870 1GB@Stock1080p60Hz
    Playing with a custom resolution loses 1:1 pixel mapping resulting in reduced quality.
    This problem is unacceptable and happens in all 3 crysis games. well done crytek...

    By the way, enabling GPU scaling in CCC changes the always 24hz to 50hz for me and makes the alt+enter trick work to restore to 60hz. without it the alt+enter trick doesnt work for me.
     
    Last edited: Jul 9, 2011
  10. dade_kash_xD

    dade_kash_xD Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    2x XFX DD R9-280x 3gb
    I actually set in my autoexec.CFG for C2 to load up at 1904x1080, I do the alt+tab trick, go into settings and set resolution to 1920x1080, specs on Ultra, fullscreen Yes and now my game runs NO LESS THAN 60 FPS! The ranges are now from 60-89 FPS AT 1080x60p!!! WOOOOHOOOOO!!! That's only with 70-80% GPU utilization too! When AMD releases caps 100 FPS here I come!!!
     

  11. alco

    alco Master Guru

    Messages:
    933
    Likes Received:
    0
    GPU:
    Asus gtx780 DirectcuII OC
    whats strange is is that if i uninstall the game then reinstall update everything (without rebooting) i can play @1920x1080@60Hz
    soon as you reboot its 24 P :S and playing feels like a slideshow even if you get more then 60 fps

    ***Playing with a custom resolution loses 1:1 pixel mapping resulting in reduced quality.***

    i did not notice reduced image quality
    gonna see if there is any
     
  12. TheWhateverDude

    TheWhateverDude Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    HD5870 1GB@Stock1080p60Hz
    Using any resolution other than your monitor's native results in reduced quality, its a known fact for lcd monitors. That said, I have trouble noticing it too.
     
  13. Bio Shock

    Bio Shock Member Guru

    Messages:
    175
    Likes Received:
    0
    GPU:
    Radeon 6950
    as others have already said, the alt+enter trick does work

    more specific steps would be something like, run d3doverride and create a profile for crysis 2 @ 60fps (if you want vsync. i personally prefer it as i cant stand screen tearing)

    load crysis 2, turn off vsync and fullscreen in the options menu

    close game

    run crysis 2 again and press alt+enter as soon as the first logo shows (the one that looks like an eye)

    enjoy 60fps (or higher) in dx11

    hope that sorts it all out for ya
     
  14. kcuestag

    kcuestag Master Guru

    Messages:
    904
    Likes Received:
    0
    GPU:
    Gigabyte GTX980Ti G1
    But alt+enter makes the game in Windowed mode, therefor Crossfire won't work.

    Or do you mean alt-enter to windowed mode and then alt-enter to fullscreen again?
     
  15. honkeykrakker

    honkeykrakker Master Guru

    Messages:
    329
    Likes Received:
    0
    GPU:
    6950
    Possibly stupid question, but who cares if you are 2 million FPS when your Refresh Rate is 24 or 60? This Question only applies to Offline Gaming where it has no affects on other settings.
     

  16. TheWhateverDude

    TheWhateverDude Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    HD5870 1GB@Stock1080p60Hz
    yes that's it, you need to do alt-enter 2 times (at the eye logo) if you have started in fullscreen. I don't know about CFX. The best thing for me is to always have it to start windowed and only do 1 alt+enter.

    What's wrong playing it windowed if that works best for you? Is it the title bar that's bothering you? If it's the taskbar staying on top you can use http://www.sevenforums.com/1373509-post106.html to hide it.
     
    Last edited: Jul 9, 2011
  17. King Kong

    King Kong Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    GTX Titan
    Last edited: Jul 9, 2011
  18. TheWhateverDude

    TheWhateverDude Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    HD5870 1GB@Stock1080p60Hz
    that wouldn't work for me when i was trying to sort it out. maybe it works for others.
     
  19. alco

    alco Master Guru

    Messages:
    933
    Likes Received:
    0
    GPU:
    Asus gtx780 DirectcuII OC
    i tried it but its not smooth playing here
    the trick i recommended works better for me
     
  20. lambchop

    lambchop Member Guru

    Messages:
    175
    Likes Received:
    0
    GPU:
    None
    I don't understand the tearing issue, my screen is 75hz yet the only game i have ever played with visible tearing and vsync off is the witcher 1.
     

Share This Page