1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bit of a strange one this....

Discussion in 'Operating Systems' started by The Goose, Jun 27, 2019.

  1. The Goose

    The Goose Ancient Guru

    Messages:
    2,213
    Likes Received:
    35
    GPU:
    Evga 1080FTW
    Hi, ive noticed for some time now that windows back ground apps can use gpu resources.....it comes with drawbacks....my gtx 1080 idles at 1240hz with an idle temp of 53c, not to mention my system now draws 110watts when sitting idle instead of 65, any way of disabling this feature
     
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    2,060
    Likes Received:
    493
    GPU:
    GTX 1080ti
    stop setting the global performance setting to prefer max.
     
  3. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,327
    Likes Received:
    3,838
    GPU:
    GeForce GTX 1070
    May be to disable background apps: Settings => Privacy => Background apps.
    Also may be this one: execute "Disable-MMAgent -ApplicationPreLaunch" in elevated PowerShell.
     
    Jackalito and fantaskarsef like this.
  4. The Goose

    The Goose Ancient Guru

    Messages:
    2,213
    Likes Received:
    35
    GPU:
    Evga 1080FTW
    Its not.
     

  5. The Goose

    The Goose Ancient Guru

    Messages:
    2,213
    Likes Received:
    35
    GPU:
    Evga 1080FTW
    Is it possible that having 3 monitors hooked up to my system even though the other 2 are off most of the time could be preventing my gpu from running at idle clocks
     
  6. WolfPT

    WolfPT Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    ROG-STRIX 1080Ti
    Yes actually, if they are plugged in to the GPU on standby the card might try to run in P7 or P8 clocks.

    When I use a two monitor setup my 1080Ti always like to boost up to 1500mhz.

    What I do is I use Nvidias Profile inspector and within this app you can enable Multi Display Power saving.

    To get to this option you have to open Nvd profile inspector and on the bottom right corner there should be an option like " show overclocking".

    Right click on that and then click multi display saver.

    Here you can enable the option to use a lower performance mode when running multi-monitors.

    Check mark run multi display power saver at startup to make sure it's always enabled.

    Let me know if that worked for you. :)

    You can get the app here:

    https://www.guru3d.com/files-details/nvidia-profile-inspector-download.html
     
    Last edited: Jun 28, 2019
  7. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,327
    Likes Received:
    3,838
    GPU:
    GeForce GTX 1070
    WolfPT likes this.
  8. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,361
    Likes Received:
    288
    GPU:
    EVGA 1070Ti Black
    that has nothing to do with it, I have had my nvcp gobal profile set to perfered maximum pefromance for as long as I can remeber and gpu always idles at its correct speeds
     
  9. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,205
    Likes Received:
    160
    GPU:
    MSI 970 Gaming 4G
    AFAIK, that depends on vid model and if any applications are using GPU.

    Edit; Just tried it on my 970 ,1113 MHz with global HP plan and no GPU usage.
    Normally it is 135mhz.
     
    Last edited: Jul 1, 2019
  10. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,361
    Likes Received:
    288
    GPU:
    EVGA 1070Ti Black
    applications that need seperate profile and mutiple monitor up and running aside Global profile set to maximum performance wont keep it from idling, less nvidia broke something or ms added some new process that is hitting on gpu that needs seprate profile. I remeber when Windows 10 first came out there was process that was needed profile of it own so maximum performance in global didnt idle at full clocks nvidia fixed i beleive by adding internal profile for it.

    and there would seem to be another added process that hit the gpu courtesy of MS, enable "display gpu activity" in the nvcp till show everything run that keeps the gpu from proper idle speeds

    "WindowsInternal.ComposableShell.Experiences.TextInput.InputApp"



    If i terminate the above MS process idle speeds work, Try setting profile for the above, and setting to adaptive and rebooting, if dont work, well then this need to be reported to nvidia and or ms

    This on 1807 build my uncles pc I sure new build will add new process from MS atlest that will need to fixed.

    These are the only situations that really cause the gpu to not idle at correct speeds when performance is used in global

    https://www.reddit.com/r/Windows10/...alcomposableshellexperiencestextinput/maximum


    https://www.reddit.com/r/Windows10/comments/9h5dbh/annoying_windows_10_display_bug/


    there is regedit command in this topic that fixes that bug with process i mentioned

    Uncles pc now idle at correct speeds with maximum performance set in global
     
    Last edited: Jul 2, 2019

  11. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,205
    Likes Received:
    160
    GPU:
    MSI 970 Gaming 4G
    I don't know but as I posted setting global to HP on a clean boot I get 1113mhz, no browser (I even have HW accel off) and I make sure no 3rd party apps using GPU like LGS.
    Ok, I set GPU activity and it is showing startmenuexperiencehost as the only process.

    Edit: ok, that worked there was already a profile for MS Startmenuexperiencehost, so setting it to optimum instead of default with a global profile on HP it is idling ok.
    As soon as I start Origin thatsanother that needs to be set to optimum, so your chasing GPU processes to tame them.

    I still prefer setting app profiles to what I want but at least it is doable now.
     
    Last edited: Jul 2, 2019
  12. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,361
    Likes Received:
    288
    GPU:
    EVGA 1070Ti Black
    yah windows 10 has alot process that tend to hit the gpu and everytime i see this happen it some new process from windows hitting it when it should not,
    I have even randomly seen avast main exe hit, even ccleaner hits the gpu when it runs. (well causes gpu to run full clocks)

    not sure what you mean by hp? you mean the pc?

    All i know is if NVCP "display gpu activity" is enabled and there is something listed in there the gpu will not runn idle speeds when using global profile set to maximum performance. there needs to be profile set for it to with appropriate power setting, which dont always work, or ms and or nvidia as to notified and they have to make fix it them selves. there is just to many process these days to keep track of these days.

    But the Gpu activity display in nvcp is how i track down those rogue programs every time.
     
  13. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,205
    Likes Received:
    160
    GPU:
    MSI 970 Gaming 4G
    HP = high performance power Management plan (GPU).
     
  14. The Goose

    The Goose Ancient Guru

    Messages:
    2,213
    Likes Received:
    35
    GPU:
    Evga 1080FTW
    Well my Evga gtx 1080ftw most least idle speed is 1228mhz which is around an extra 35watts power draw
     
  15. Caesar

    Caesar Master Guru

    Messages:
    557
    Likes Received:
    189
    GPU:
    GTX 1070Ti Titanium
    Chastity likes this.

Share This Page