BioShock Infinite

Discussion in 'Games, Gaming & Game-demos' started by S†v0r, Dec 17, 2011.

  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,830
    Likes Received:
    381
    GPU:
    EVGA GTX 1080 Ti SC2
    Try editing the Engine.ini file in the My Documents/My Game/BioShock Infinite/Config folder and change the Min + MaxSmoothFramerate to 59 and 61 respectively plus change the two MemoryPools variables from 512 to 1024. That significantly reduced the stuttering for me (unless it is coincidental?) but the game does still hitch from time to time, usually when entering a new area or when VRAM gets close to 2 GB. It was really bad before though so any improvement is welcome. I'm playing on maxed out Ultra 1920x1200 settings by the way with Alternate post-processing.
     
  2. mamboboy

    mamboboy Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    Gigabyte Radeon HD 7950
  3. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,115
    Likes Received:
    1,038
    GPU:
    GTX1070 iChillx4
    yes the background streaming tweak breaks the game.
    there was one point where i had to go through a door, and the whole room section wasnt there, it was blank! i could jump under the map! (falling to death obviously)
     
  4. ShadowDuke

    ShadowDuke Ancient Guru

    Messages:
    3,710
    Likes Received:
    334
    GPU:
    MSI Gaming 970
    allready ttied yesterday, no difference.
     

  5. moab600

    moab600 Ancient Guru

    Messages:
    6,115
    Likes Received:
    102
    GPU:
    980TI Gaming
    i tried, kinda helps but still. UE3 had always problem like that but not to that extent... hope they fix it asap.
     
  6. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    7,736
    Likes Received:
    214
    GPU:
    Zotac GTX1080Ti AMP
    Treid setting memory pool sizes (both of them) to my max VRAM limit and it seems to have help dramatically! I never exceed 1.2GB VRAM now and even going from one area to the next it jumps for literally a split second and then its loaded the next area.

    Also disabling smooth frame rate from true to false in the .ini helps but I found leaving this option on makes little to no difference.
     
  7. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,830
    Likes Received:
    381
    GPU:
    EVGA GTX 1080 Ti SC2
    So does the current SM5FXAA=False setting work if set to True (it's one of the Engine.ini settings)? The game only seems to currently use the FXAA=True setting.
     
  8. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,115
    Likes Received:
    1,038
    GPU:
    GTX1070 iChillx4
    just finished the game, great game :)
    not very long though, 9.5 hrs
     
    Last edited: Mar 27, 2013
  9. mikeym

    mikeym New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    HD 4870 x2
    I have an old 4870 X2 and the game runs pretty well on it but it is only using one of the GPUs. Can anyone tell me how to get it working on both of them please?
     
  10. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    7,736
    Likes Received:
    214
    GPU:
    Zotac GTX1080Ti AMP
    mikeym you might need to download the CAP from AMD for your card as its now a legacy card and is not offically supported by AMD drivers anymore.


    POSSIBLE STUTTER FIX

    I think I found something rather interesting out. I think the game has a fullscreen bug that causes stutter.

    I have since set both my memory pools back down to 1024 as it was causing me to have very jumpy fps with it set to my max 3072 VRAM so thats a no go.

    But then I came across this...

    Enable the game to run in FULLSCREEN BORDERLESS WINDOWED MODE!!!

    In one scene I ALL maxed out everything on ultra I stand looking out into the distance after just killing every enemy on screen so there was no A.I other than Elizabeth and I was dropping to 50fps which in this game with vsync enabled feels like 20fps (no vsync causes quite a lot of tearing).

    But then I changed to FULLSCREEN BORDERLESS WINDOWED MODE and bamn... the same scene I didnt even move and its 60fps solid hovering around 59-60fps....

    PLEASE someone else try this and see if it works for you. The game options say that fullscreen windowed mode may cause less performance but for me its better and my mouse movements feel a lot smoother too. I want to see if this can be replicated on other machines.
     
    Last edited: Mar 27, 2013

  11. mitzi76

    mitzi76 Ancient Guru

    Messages:
    8,640
    Likes Received:
    2
    GPU:
    MSI 970 (Gaming)
    eh isnt windows fullscreen mode what we should be running anyways? (runs off to check).
     
  12. mikeym

    mikeym New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    HD 4870 x2
    Thanks RedDawn. I have the latest driver, 'AMD_Catalyst_13.3_Beta3', and have installed 'AMD_Catalyst_12.11_CAP2' but it still doesn't work on both GPUs.

    Using Catalyst Control Centre I have tried forcing it to use both 'AFR Friendly' and 'Optimise 1x1' but neither work.
     
  13. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,115
    Likes Received:
    1,038
    GPU:
    GTX1070 iChillx4
    tried this yesterday, also windows borderless program. didnt change a thing for me
     
  14. vejn

    vejn Maha Guru

    Messages:
    1,002
    Likes Received:
    0
    GPU:
    MSI 7870 TF3
    We have to wait for a patch.
    Devil may cry UE build runs fine with no problems. Does anyone know which is UE build for Bioshock Infinite ?
     
  15. Mr.Bigtime

    Mr.Bigtime Ancient Guru

    Messages:
    20,792
    Likes Received:
    8
    GPU:
    ASUS 1080TI
    I dont think you explored enough the game.
     

  16. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,115
    Likes Received:
    1,038
    GPU:
    GTX1070 iChillx4
    there is no explore besides going inside a few houses. its very liniar
     
  17. mitzi76

    mitzi76 Ancient Guru

    Messages:
    8,640
    Likes Received:
    2
    GPU:
    MSI 970 (Gaming)
    ahh "windowed", if anything this runs worse for me than fullscreen.
     
  18. boodikon

    boodikon Ancient Guru

    Messages:
    3,873
    Likes Received:
    47
    GPU:
    Leadtek 8800 GTS 640mb (600 core)
    Chrono trigger, some are saying.
     
  19. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    7,736
    Likes Received:
    214
    GPU:
    Zotac GTX1080Ti AMP
    I honestly dont get it, I am running the game now with 60fps all maxed out with an occasional dip to 55fps (only in large open areas but very rare) but it still feels smooth unlike before in fullscreen which felt like 50fps was 20fps. Also GPU usage has gone up too around 70-85% now before it was 40-60%.

    EDIT:

    ALT+TAB out of the game and bring up task manager and set bioshock infinite exe to high. Also noticed that the exe is only 32bit... Is there any talk of a 64bit exe so the game can see more memory?

    Also, people who are reporting high VRAM seem to be people using crossfire or SLI... wont Afterburner combine your TWO GPU's VRAM and think its one pool of memory instead of mirrored? I had this when I had 2 7970's in crossfire, BF3 would go up to around 4GB VRAM usage, but it was just Afterburner showing both pools of memory being loaded as one pool.
     
    Last edited: Mar 27, 2013
  20. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    7,736
    Likes Received:
    214
    GPU:
    Zotac GTX1080Ti AMP
    I did not even know that 13.3 beta 3 supported the 4 series cards... I thought they were only for 5,6, and 7 series. Unless your using modded one?

    Also if you do have 13.3 beta 3 you might want to uninstall the CAP as 13.3 beta 3 already contains a built in CAP that is much newer than 12.11 CAP2
     

Share This Page