BIOS/POST not showing on display port monitor

Discussion in 'General Hardware' started by 13thCaesar, Apr 20, 2016.

  1. 13thCaesar

    13thCaesar Active Member

    Messages:
    92
    Likes Received:
    0
    GPU:
    Gigabyte GTX 1080 Ti XE
    Hey guys.

    I got a Asus Rog Swift monitor a some months ago now, and I noticed that when I turn my PC on, it won't display the POST/BIOS screen. It won't show anything until the OS is booted.
    Is there a BIOS settings I have to adjust or maybe something I have to enable on my video card?

    Motherboard is a Gigabyte GA-X79-UP4
    Videocard Gigabyte 980 G1 Gaming edition.
     
  2. AsiJu

    AsiJu Ancient Guru

    Messages:
    3,616
    Likes Received:
    11
    GPU:
    EVGA 980Ti SC+
    Try setting the default input on your monitor to DP. Maybe the monitor cycles through inputs during bootup and that's why you see nothing?

    Also set default graphics adapter to PCI-E in BIOS once you get there.
     
  3. ron7000

    ron7000 Master Guru

    Messages:
    238
    Likes Received:
    0
    GPU:
    MSI 4G GTX970
    your best bet is to contact gigabyte and ask if that specific motherboard with the given bios/efi version is capable of that, and check for the latest bios/efi version.
    I know on my asrock board which is lga1150 and full efi, it can do 1920x1080 efi display thru dp on my gtx970, but not 2560x1440 which my 27" monitor is. And i've dealt with this problem over the years such as when using a 1920x1200 dell monitor and the bios can display at best 1280x1024 and then only thru a dvi connector not dp or hdmi, and then some servers even will only display the bios screen thru the onboard graphics vga port and none at all through any pci-e graphics card. The problem lies in the motherboard firmware.
     
  4. Margolis

    Margolis Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    EVGA 980ti 6GB
    This may be the issue here. I have dual monitors. When I boot, the boot screen shows on the second monitor which is connected thru dvi, while my primary monitor which is connected thru hdmi runs thru the dp, hdmi and dvi ports saying no signal on all of those. Once it gets past the post screen everything is back on the primary monitor
     

  5. pimpernell

    pimpernell Master Guru

    Messages:
    323
    Likes Received:
    1
    GPU:
    EVGA 1080 FTW dt@2ghz
    A bios update for mb and gfx usually solves these issues.
    Newer versions gives dp first priority.
    Had the same when i got my 970's, new gfx bios fixed it.
    And be sure windows is installed in UEFI mode, turn off legacy in bios.
     
  6. vase

    vase Ancient Guru

    Messages:
    1,653
    Likes Received:
    0
    GPU:
    -
    i had this problem with my dvi dual monitor setup.

    solved it by activating the iGPU of my i7 rebooting and then deactivating it again. from then on i see POST boot on my main screen as well.
    before i only saw it on the second screen!

    but you have "Intel i7 3820" which doesnt have iGPU.
    yet i have another advice you could try.
    on my crossfire setup i only see post if i have my monitors plugged into my primary (pcie slot0) card.
    so try switching both monitors to the other card, you have sli right?
    and see if it helps.

    i dont have more ideas than that.
     
  7. Eggy1968

    Eggy1968 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    16GB DDR4
    Solved for my setup

    I know this is little late in the day but others may come across this and find it useful.

    I had a 2 monitor setup. My old 24" monitor on DVI ( in portrait mode to make matters worse!) and a 27" 2K on Display Port connected to my EVGA GTX 970.
    Motherboard is ASUS Z270-P but I know from others that this will work on other boards.

    NOTE: You must have a UEFI setup, if you have an older legacy non-UEFI setup then this will not work.

    If you don't have a UEFI setup I'm not sure what you can do other than to reinstall Windows in UEFI mode on a clean disk/partition. To be honest I would have done this anyway as it reduces boot time quite a bit.

    The BIOS POST and setup screens would only ever show on the monitor connected via DVI. Apparently the graphics card prioritises the connections in this order
    DVI -> HDMI -> Display Port

    After a while rotating my head to read the BIOS screen I decided enough was enough. After some research and trial and error I came across a very simple solution.

    Anyway, to the point finally.
    In the motherboard BIOS settings under the BOOT menu (on my board) there is an option called "CSM (Compatibility Support Module)". This is Enabled by default. Changing this to Disabled instantly fixed the issue. You may want to also try 'Auto' in case you have other non-UEFI devices connected but this may not work, it didn't for me.


    Anyway, hope this helps somebody.
     

Share This Page