Big weird problem HD7970 with new LG TV monitor

Discussion in 'Videocards - AMD Radeon' started by bassmouse, Jan 16, 2014.

  1. bassmouse

    bassmouse New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    HD7970
    Big weird problem HD7970 with new LG TV monitor(temporary solved not solid solution)

    Here is my story. I just bought a 27" LG latest TV monitor (27MT93D). Here is the product link lg.com/au/it-monitors/lg-27MT93D There are some really weird things happened since I starting using it. Firstly, it randomly turning black screen for one sec and back on. Secondly, it shows some short white lines (about 2-3cms) all around the screen(looks like an electric current). Now, at the first place, I thought that the problem maybe my graphic card(AMD HD7970), because when I tried to use my Intel integrate graphic HD4000, it never give me the black screen. However, after I got another brand new AMD HD7970, the problem is still there!!! :bang::bang::bang::bang::bang:Sounds really weird isn't it?! Then, I thought the problem maybe coming from the monitor. So I tried to use my old monitor(21" LG W2261V) connected with the same HDMI cable to the AMD HD7970. There is no black screen and short white line found so far.(I have been used this for 2 days). Well, can anyone understand my situation and post me some explanations and solutions? I will be so grateful!

    updates: I have sent the LG TV monitor to LG repair department. After 5 days, they told me there were nothing wrong found and the only comment on this issue is that the problem maybe the software in the monitor does support the graphics card fully...:bang::bang::bang::bang:

    Here is my PC specifications:
    CPU:i5 3750k
    RAM: 8G DDR3
    Motherboard: ASROCK Z77 Pro3
    Graphic card: AMD HD7970
    HD: SSD
    PSU: antec 620W


    [updated]
    There is my solution below, somehow, it did work for me:

    Firstly, whatever you think the mode will affect the result, it doesn't. So just keep it as 'PC mode'.

    Then download a software called ' Virtu MVP 2.0'(just google it and download from their website for free). Obviously, this software is designed for getting a integrated graphic card working with independent graphics cards. I am not going to tell you its functions in details. I will show to how to use it for fixing the problem.

    After you downloaded and installed the software, turn your PC off and disconnect your display cable(mostly is HDMI CABLE) from independent graphics cards which in this case is my 7970. Then connect the cable to your integrated graphic card( the port can be found from the back panel of your motherboard). Now turn the PC back on and the software will run automatically(if not just run it manually). Open the applications tab,set profiles for the games or apps as'D mode' and tick the box of 'H-Hyperformace'. Then you are good to go. Run the game and check the FPS whether its rate is dropping or not. If it is not, that mean you have run the game via both cards running as the same time. If there is a fps dropping drastically,which means you are running the game either on I-mode(integrated card only mode) or your integrated card are not on 'performance setting'(check this setting from the power settings of control panel).

    So far this temporary solution is working fine.
     
    Last edited: Feb 15, 2014
  2. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,857
    Likes Received:
    246
    GPU:
    EVGA GTX 1080Ti SC
    Tried a different cable? Different port?
     
  3. bassmouse

    bassmouse New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    HD7970
    Yeah, I have tried three different HDMI cables and two HDMI ports (there are no DVI RGB ports), same as usual:bang::bang:
     
  4. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,809
    Likes Received:
    3,366
    GPU:
    6900XT+AW@240Hz
    If it has standard LG menus, then put your HDMI input into PC mode or have input mode for given port empty (acts same usually).
     

  5. bassmouse

    bassmouse New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    HD7970
    Thank you for the tips but I have tried all setting as pc, notebook and normal modes, the problem is still there...
     
  6. bassmouse

    bassmouse New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    HD7970

    need help!:bang::bang:
     
  7. camelot1971

    camelot1971 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    r280X
    I have the same problem too! I upgraded to a R280X and have the same monitor as you. I found what fixes it is not using "PC" as the label for the hdmi input.

    I didn't have a problem with my 6970 so there must be something weird going on with the later generation of ATI card and the monitor.

    Do you know what PC mode does? The manual doesn't explain.
     
  8. Scout

    Scout Member Guru

    Messages:
    166
    Likes Received:
    0
    GPU:
    2 x GTX 980Ti
    wtf.... $699 for a 27" tv ?

    is it your secondary monitor or main one ?

    try to change gpu scaling on or off in the catalyst options under "My Digital Flat Panels" tab
     
    Last edited: Feb 12, 2014
  9. bassmouse

    bassmouse New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    HD7970
    Thank you for your reply. So far, I have figured out a temporary 'solution' for this damn problem:)bang:). There is someone from a PC store where I bought my 7970 explained this problem like this: the latest ATI card is so powerful and its electrical flow somehow bigger than the monitor's. Therefore the monitor cannot fully running on that...

    Although this is not a quite professional answer, it someone give me an idea to bring my 7970 and monitor on the same line. There is my solution below, somehow, it did work for me:

    Firstly, whatever you think the mode will affect the result, it doesn't. So just keep it as 'PC mode'.

    Then download a software called ' Virtu MVP 2.0'(just google it and download from their website for free). Obviously, this software is designed for getting a integrated graphic card working with independent graphics cards. I am not going to tell you its functions in details. I will show to how to use it for fixing the problem.

    After you downloaded and installed the software, turn your PC off and disconnect your display cable(mostly is HDMI CABLE) from independent graphics cards which in this case is my 7970. Then connect the cable to your integrated graphic card( the port can be found from the back panel of your motherboard). Now turn the PC back on and the software will run automatically(if not just run it manually). Open the applications tab,set profiles for the games or apps as'D mode' and tick the box of 'H-Hyperformace'. Then you are good to go. Run the game and check the FPS whether its rate is dropping or not. If it is not, that mean you have run the game via both cards running as the same time. If there is a fps dropping drastically,which means you are running the game either on I-mode(integrated card only mode) or your integrated card are not on 'performance setting'(check this setting from the power settings of control panel).

    So far this temporary solution is working fine.:) I wish you have the same luck. If you need help about this solution just post to me or if you have any solid solutions just let me know. Thank you!:)
     
  10. bassmouse

    bassmouse New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    HD7970
    Thank you for your reply. What you have suggested won't work on my case. I have tried all possible settings of CCC. None of them seems working on the case. But finally, I came up with a temporary solution for this problem. Just check the top post. If you have any better solution ,just let me know thank you!:)
     

  11. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,629
    GPU:
    ROG Strix 1080 OC
    You need to move the Scaling slider along

    [​IMG]
     
  12. bassmouse

    bassmouse New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    HD7970
    Thank you. I've done that. What I mean by 'wont work' is that doing nothing about this problem.:)
     

Share This Page