Big problem afterbuner and win8 and G15

Discussion in 'MSI AfterBurner Overclock Application Discussion' started by Burgurne, Sep 29, 2013.

Thread Status:
Not open for further replies.
  1. Burgurne

    Burgurne Master Guru

    Messages:
    248
    Likes Received:
    0
    Greetings.
    On a new clean installed Windows 8, I can't get Afterburner to work proberly. I used to run it in Windows 7, and have some monitoring shown in my Logitech G15 display. I have checked 3 items to monitor and to show in display, but nothing happens. "Statistic Server" does not start at boot (so no OSD in games), and if I start Statistic Server manually, the OSD is showing in games, but still no info in G15-display.
    I have checked, that Afterburner is indeed running in Logitechs settings for the keyboard.

    In Windows 7 if I shut down Statistic Server, Afterburner is turning it back on within seconds, but in Windows 8 Afterburner does not seem to know about Statistic Server, and is also not able to let the app for G15 receive any data (my guess). It is the same driverversion for my GTX770, and it is the same version of Afterburner (Beta 15 2nd edition) downloaded here at Guru3d.com.

    In windows 8 I have tried to set both programs to run with admin rights, but that did not help at all.

    Any ideas?

    TIA
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,901
    Likes Received:
    2
    Statistics Server has ZERO relation to G15 functionality. You're misunderstanding things and configuring something wrong.
     
  3. Burgurne

    Burgurne Master Guru

    Messages:
    248
    Likes Received:
    0
    Maybe so, but the fact is, that the same settings in afterburner in windows 7 does not work in windows 8 when it comes to G15. I have a dual boot, so I can easely test in both systems.
     
  4. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,901
    Likes Received:
    2
    I repeat the same again and cannot add anything to it: G15 functionality doesn't depend on statistics server AT ALL. You, re searching in wrong direction. That't also absolute fact.
     

  5. Burgurne

    Burgurne Master Guru

    Messages:
    248
    Likes Received:
    0
    Okay. I'll repeat myself clearer. I have a new installed windows 8 Pro. New installed newest WHQL drivers from Nvidia. Newest installed MSI Afterburner (which install Statistic Server by default). Installed newest software to my G15.
    I open Afterburner, clicking on "setting", clicking on the "monitoring" tap. I highlight GPU usage, marking "Show in Logitech LCD display". I then click OK.

    Doing so in Windows 7 brings the selected info on the G15 display.

    Doing so in Windows 8 does NOT bring the selected info on the G15 display. WHY?

    All the talk about Statistic server was about OSD (framerate for me) in games. In Windows 7 Afterburner starts SS automatic, but in Windows 8 I have to start SS myself (otherwice there is no OSD)
     
  6. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,901
    Likes Received:
    2
    Dig in direction of G15 software installation/configuration differences under your win7 and win8 OS'es. Cannot say WHY those things are configured differently from YOUR side, it is up to you to find it out. Nothing but G15 software can affect that. And no, you're mistaking on statistics server again, it is started automatically under any OS as soon as you enable ANY functionality that depend on it. Manual server launch is never needed.
     
  7. Burgurne

    Burgurne Master Guru

    Messages:
    248
    Likes Received:
    0
    Well, not in my Windows 8 installation. In Afterburner I select "FrameRate" under monitoring tab. Nothing happens. No framerate is slowing up in games UNLESS I _manually_ starts Statistic server after boot, no matter if you believe it or not.

    In Windows 7 it works as you write.
     
  8. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,901
    Likes Received:
    2
    Show me your monitoring tab. Yes, I absolutely don't beleive in that.
     
  9. Burgurne

    Burgurne Master Guru

    Messages:
    248
    Likes Received:
    0
  10. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,901
    Likes Received:
    2

  11. pbcopter

    pbcopter Member

    Messages:
    22
    Likes Received:
    0
    I am using a Logitech G-15 keyboard (software version 8.50.281) with Afterburner 3.0 beta 15 and have no issues displaying any monitored item on the LCD. I have used this with Windows 8 and now Windows 8.1 RTM for what it's worth.
     
    Last edited: Oct 1, 2013
  12. Burgurne

    Burgurne Master Guru

    Messages:
    248
    Likes Received:
    0
    Ok, my mistake.
    Here are 2 pics, one showing the monitortab in windows 8, and the other is a photo taken, where you can see that "Afterburner" is running in the G15-software, but it is not showing up in the display itself (pic called showing.jpg)

    http://i738.photobucket.com/albums/xx27/burgurne/eksempler/monitor-win8_zps85ee169c.jpg

    http://i738.photobucket.com/albums/xx27/burgurne/eksempler/showing_zps83e3c666.jpg

    I got the Statistic server to run by itself (as you described) by selecting Afterburner to "run as Administrator", but I still can't get afterburner to show anything on the G15 display.
     
  13. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,901
    Likes Received:
    2
    Lack of RTSS autostart is the only AB-related thing that interesed me from whole story. On G15 check the very beginning of post #6.
     
  14. Burgurne

    Burgurne Master Guru

    Messages:
    248
    Likes Received:
    0
    Okay, if that the case, why did you not tell me to run afterburner in "Admin-mode" the first time?
    The only thing you have bee writing back is that I'm too stupid to install afterburner, that I'm lying (or that you don't believe what I'm writing). So thank you very much for all your guides and ideas to look for these errors.

    EOD
     
  15. boogieman

    boogieman Ancient Guru

    Messages:
    1,845
    Likes Received:
    1
    From the readme file distributed with AB.

     

  16. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,901
    Likes Received:
    2
    Probably because i don't have mind readng skills to guess where you mistaken in your actions? And by the way to surprize you, you physically can not run AB as non-admin because administrative rights requirement are hardcoded in EXE manifest. So running it "as admin" is a placebo and do nothing, you always run it as admin with or without this option.
    EOD
    Each time dealing with user having some issues due to his stupidity ends like that.
     
Thread Status:
Not open for further replies.

Share This Page