BIG mousecursor R9-290

Discussion in 'Videocards - AMD Radeon Drivers Section' started by KBDE, Dec 31, 2013.

  1. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    Ok cool! Great to hear it also worked for you.
     
  2. Mooby29

    Mooby29 Member Guru

    Messages:
    134
    Likes Received:
    0
    GPU:
    R9 290X@1150/1500mhz
    Had to set the values for a 26 inch (3A 1F hex) monitor finally because with the 23,4 inch values, I had lost the HDMI sound (even after reboot). Now it's just perfect ! I have been struggling since day one with that huge cursor.
    To me, it's a AMD problem since it never happened with my former card (HD 7970 ghz edition) and the same drivers (At the time 13.11 B6 If I remember).
     
    Last edited: Jan 2, 2014
  3. macVIRII

    macVIRII New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Sapphire R9 290x
    Indeed, I`m upgrading from HD5870 and had never experienced the problem.
    Gonna try the changes when I get home...
    But I think it`s a straight answer for the problem... great job KBDE!!
     
  4. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    Thats another one of those quirks. Here hdmi audio works with the 23,4inch values. There is some black magic going on here lol.

    @macVIRII please let us know if it also fixed it for you!
     

  5. SlowHands

    SlowHands New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI R9 290 4gb
    Hey guys...my first post on Guru3D :D

    Seems I'm having the exact same problem with the random big cursor as well. I noticed this this week when I upgraded from my nvidia GTX 590 to the ATI R9 290. Normal mouse size is fine but when hovering over text select etc the cursor gets way inflated...also oversized in games. Funny thing also when I delete something, it's like that "ping" windows sound that plays with the delete confirmation window is delayed by a couple of seconds, not sure if this has anything to do with something being wrong in the ATI drivers, just something I noticed.

    My problem is that most of the stuff KBDE said I think is too advanced for me to follow, I'm scared due to my lack of knowledge/understanding I might break something and then not get it right again. Any chance of dumbing it down in easy to follow steps so us less clever guys can also get a solution?

    side note...I cannot believe that this is a windows/microsoft problem, as I've been running this screen setup with my current version of windows on nvidia for quite some time now without any problems.

    My specs:

    Windows 7 Ultimate 64
    Catalyst 13.12
    MSI R9 290

    Screens:
    2 x Samsung T260 (side monitors)
    1 x Samsung UA32EH5000R (center main monitor)

    Much appreciated and thanx in advance
     
  6. SlowHands

    SlowHands New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI R9 290 4gb
    on a side note...there is kind of a workaround to get the mouse pointer in windows (7) correct...however this way the mouse pointer is completely invisible in-game...also, there appears to be mouse lag this way...fixes the size at least...not a permanent solution, still hoping you guys can give an easy step by step for dummies solution :D

    Workaround for windows and normal applications...I only tested in a couple of programs:
    Right-click on desktop > Personalize
    Click display
    At the top, click on "Magnifier Tool"
    If your screen zoom in...just find the magnifying glass on your desktop and zoom back out to 100%
    DON'T close this tool, leave it open
    Test your cursor now, should work...although like I said don't know about you guys I see a slight movement lag on my system.
     
  7. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    Guide for creating a fixed monitor driver

    First download the needed tools:
    Monitor Asset Manager 2.7 click here + GetEDID-1.2 (google for "GetEDID-1.2 VLADD")

    Disconnect all displays except the HDTV. It is easier this way.


    Step 1: Dump the original EDID information from the TV

    Run GetEDID.exe, it should create two files: .0.4.bin and .0.4.txt.


    Step 2: Edit the original EDID information

    Start Monitor Asset Manager
    Open -> select .0.4.bin
    Edit -> uncheck Read-only

    Edit the exact fields like in this screenshot
    Make sure the screen size on the right changes accordingly:
    [​IMG]

    Once this is done you can create the new monitor.inf file: (File -> Create INF)


    Step 3: Load the fixed monitor.inf driver
    Start windows with disabled driver signing. Google for howto's.
    Update the monitor driver to the just created monitor.inf file.

    Finally reboot normally and you are done. :)

    You can ofcourse now reconnect all other displays like before.
    Keep the created monitor.inf somewhere safe for future use. It should work on all windows versions.
     
  8. SlowHands

    SlowHands New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI R9 290 4gb
    Yay, problem solved. KBDE you are my new best friend!! :D

    I did however have a problem with my 2 side monitors after applying the new monitor.inf file to them as well. After driver update the mouse size was fixed on all my monitors, but the max resolution on my 2 T260's was only 1920 x 1080, where they are capable of 1920 x 1200. After a quick google, I found (I don't have high enough post count so can't post a link...google "custom resolution utility (cru)" a post with a tool (cru-1.1.zip) to add custom resolutions to any display device...after reboot...all problems solved.

    Once again thank you so much KBDE, couple days of struggling finally over!!
     
  9. Mooby29

    Mooby29 Member Guru

    Messages:
    134
    Likes Received:
    0
    GPU:
    R9 290X@1150/1500mhz
    That dude really made a lot of best friends these last days. KUDOS TO HIM !!!!
     
  10. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    Ok great to hear it worked!

    @SlowHands
    You should only use the created/modified driver for the TV that causes the problem. Using this specific driver for the other displays can result in lost resolutions and/or other problems.
    That said, i wouldn't be surprised if a normal monitor also had wrong EDID info and the ATI/AMD drivers caused problems because of this. But if this is the case just repeat the same procedure for that display asswell. Just don't mix the drivers m'kay. :)
     

  11. TacticalQuit

    TacticalQuit Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    2x R9 290X
    Im afraid that this did not work for me. installing monitor.inf seems to do nothing but prompt a confirmation dialog (in driver signature disabled boot mode) to which i hit confirm and then it does nothing.
     
  12. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    My guess is that either the driver didn't install correctly or the changes where not saved correctly. Then there's the third option; you have another display and this one also causes problems.

    If you want i can take a look at the binairy EDID file(s) for you. Just let me know.
     
  13. TacticalQuit

    TacticalQuit Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    2x R9 290X
    Actually that would be helpful.

    I was looking at and trying to change the registry directly when the above method didn't work
    I changed it back to normal, but now monitor asset manager is giving me a checksum error. Saying it's autocorrecting so the data can be displayed and saved.

    Edit: I restored the system. I'm no longer getting the checksum error. Mouse still big.

    I'll post a screenshot of the error as well if you like.
    Which file is it that you need?
     
    Last edited: Jan 5, 2014
  14. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    I only need the files dumped with GetEDID-1.2.
     
  15. wazer

    wazer Member

    Messages:
    34
    Likes Received:
    3
    GPU:
    1080TI on water
    I got the same on my 2nd monitor :S
     

  16. TacticalQuit

    TacticalQuit Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    2x R9 290X
  17. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    OK, checked the file, nothing strange with it (except for the screen size which is now "fixed")
    I've created the fixed monitor driver for you. Download here.

    If you install this without driver signing and reboot after that the big mouse should be gone. :)
     
  18. TacticalQuit

    TacticalQuit Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    2x R9 290X
    nope, didnt work. i used the file you gave me, nothing changed, i right click install, hit confirm on the dialogue, and seemingly nothing happened, i restarted and the mouse is still big.

    the mouse goes back to normal when im not logged in. and when pointer trails is on.
     
  19. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    Wait what... thats not the correct way to install the monitor driver. No wonder it doesn't work. :nerd:

    First boot windows without driving signing. Then goto the device manager, click on monitors, double click Generic PNP monitor, and click update driver. Browse to the inf you you got from me earlier. Confirm its ok to install. Reboot.
     
    Last edited: Jan 6, 2014
  20. TacticalQuit

    TacticalQuit Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    2x R9 290X
    It was the edid override. It worked! Thank you KBDE!
     
    Last edited: Jan 6, 2014

Share This Page