BF4 - R9 290, DX or Mantle

Discussion in 'Videocards - AMD Radeon Drivers Section' started by deeselcyde, Oct 6, 2014.

  1. deeselcyde

    deeselcyde Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    XFX R9 290 DD 1145/1520
    Well, I've tried 5 different AMD drivers and every time I've uninstalled the right way with DDU. I uninstalled and reinstalled BF4. I played with the overclock (took it down a bit, took it up a bit, and tried it stock). I'm still getting those results on the overlay graph.

    DX11 is better, but like I said with vsync On on every map there is a section of the map where the fps will drop 15 frames due to some reason that is beyond my knowledge. 6950 ran this game on medium settings no problem, 60 fps all the time. 290 is having trouble at high? :gape::3eyes:

    The only thing I haven't tried is a clean install of windows. I really don't feel like going through the effort, though.
     
  2. Noisiv

    Noisiv Ancient Guru

    Messages:
    8,103
    Likes Received:
    1,388
    GPU:
    2070 Super
    How about DX11 Vsync OFF with frame-limiting at 59-60?

    that does not sound too terrible tbh and maybe it's just how it's supposed to be, i.e. no error on anyone's part;
    you might have to learn to live with it
     
  3. deeselcyde

    deeselcyde Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    XFX R9 290 DD 1145/1520
    I have. When limiting my frames to the 59-60 (or 69-70 because my monitor is overclocked a bit) that just promotes a ripple across the middle of the screen. With vsync off I found if I set my max framerate to 5-10 frames above the monitors refresh rate give me the best viewing experience, but nothing close to vsync on.
     
  4. bigbeard86

    bigbeard86 Banned

    Messages:
    28
    Likes Received:
    0
    GPU:
    290 Crossfire 1220/1450
    I have cross fire 290s and I have no issue with mantle, though i used to have the memory leak.

    However, for exactly a year now,i get piss poor performance under direct x. Gpu usage is horrendous for direct x, and this issue has never been fixed. Fps can drop to 60, with two overclocked 290s. AMD Matt was contacted months ago on another forum about this issue. He was supposed to pass the message along, as if the countless threads on bf4 forums was not enough, but, not surprisingly, not a single word from amd. This is pathetic.
     

  5. deeselcyde

    deeselcyde Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    XFX R9 290 DD 1145/1520
    It's funny that it's almost the opposite for me. Almost meaning that my DX performance is good, but not what it should be. You said your Mantle experience was great, not quite like my DX performance. If you look at the perfoverlay graph I quoted, Mantle is completely unplayable.
     
  6. deeselcyde

    deeselcyde Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    XFX R9 290 DD 1145/1520
    Well, I seemed to have fixed the stuttering....

    When in doubt, reformat computer. I reformatted a couple nights ago because I crashed out of Titanfall (which ran very well) and got a blue screen. From then on within 30 seconds of booting into Windows I was getting the black screen crash where my monitors would just go out. I was able to DDU to clean the drivers and re-install which temporarily fixed the black screen problem...unfortunately it came back 3 days later which led me to just say f@ck it and re-install Windows.

    Bf4 runs fairly smooth but I still get frame drops on certain maps. For example at Hilltop on Caspian Border 2014 I can look one way and have my 70 vsynced fps silky smooth and then turn 180 degrees and it goes down to 55. WTF? This was tested last night after the "Winter Patch" so I'm not sure if that patch f@cked some other things up fps wise? I also tried DX11 which feels better to me but the performance(fps) seemed a little better when using Mantle. I only tested for about 20 minutes last night because I was tired.

    Thanks for bearing with me through this. Will continue to update.
     
  7. JonMS

    JonMS Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    2x EVGA 980Ti FTW
    Mantle runs butter smooth, consistently on my rig.

    2x 3GB 280X in crossfire
    2x Xeon X5680 Hex-Core Processors 12C/24T
     
  8. deeselcyde

    deeselcyde Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    XFX R9 290 DD 1145/1520
    What are your in-game settings?

    I should have noted that when I test the game last night I just went into it stock without making any config changes or anything like that. So that may have something to do with the fps drops??? I hope???:wanker:
     
  9. JonMS

    JonMS Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    2x EVGA 980Ti FTW
    I don't have my game library SSD in right now for school exams but I believe its a mixture of High and Ultra

    Also I'm playing at 2560 x 1440
     
  10. Noisiv

    Noisiv Ancient Guru

    Messages:
    8,103
    Likes Received:
    1,388
    GPU:
    2070 Super
    LOL it wasn't your PC.

    It was EA fixing their gdamn Mantle. It took them only a little more than a year :banana:
     

  11. haz_mat

    haz_mat Master Guru

    Messages:
    243
    Likes Received:
    1
    GPU:
    1070 FE
    The latest BF4 patch cleaned up the few stutters I was still getting in Mantle. Its holding 60fps v-sync'd (except under extreme explosions surrounding me), ultra settings, 2xmsaa, 120% resolution scale, 1920x1200.

    However, I've seen a couple instances during the knife-kill animation where the framerate seems to dip to the 30s until the sequence is finished. This particular bug was not present previously if I remember correctly.
     
  12. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    Mantle runs really smoth after the patch.

    The knife kill might be locked at 30 fps by the game engine since animations in the Frostbite engine are processed at 30 fps and then interpolated.

    For me the Frostbite engine titles have always had input lag when running VSync on, I use VSync off with a frame limit set in the config file. I set mine at 90 since it is the lowest I can go and maintain an acceptable level of tearing.
     
  13. DiceAir

    DiceAir Maha Guru

    Messages:
    1,367
    Likes Received:
    15
    GPU:
    Galax 980 ti HOF
    Set vsync on and 1 less than you vsync then you have no input lag
     
  14. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,857
    Likes Received:
    246
    GPU:
    EVGA GTX 1080Ti SC
    You still get input lag, although less, and this causes hitching once every second because you're syncing 59FPS to 60Hz.
     
  15. DiceAir

    DiceAir Maha Guru

    Messages:
    1,367
    Likes Received:
    15
    GPU:
    Galax 980 ti HOF
    Sorry for being rude. read my reply please. I don't care what people say. As long as everyone is happy
     
    Last edited: Mar 5, 2015

  16. Noisiv

    Noisiv Ancient Guru

    Messages:
    8,103
    Likes Received:
    1,388
    GPU:
    2070 Super
  17. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    Well, that video seems to confirm that 60 Hz VSync on has lag.

    Tried various values, including 59 and 59.something (a little bit below the real refresh rate) and I get massive tearing on my monitor, so no go. Therefore the settings I mentioned are the best for me, with both DX11 and Mantle.
     
  18. deeselcyde

    deeselcyde Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    XFX R9 290 DD 1145/1520
    When I was testing I wrote my initial post a couple days ago I wasn't aware that somehow my Resolution Scale was set to 120% which explained for some frame drops. I set it to 100% with everything else on Ultra and 4x and I was solid at 70. I saw one dip to 68 but that's negligible. I bumped it to 110% on Caspian and I was going from 60-70. I turned Ambient Occlusion down to ssbc and turned down effects and lighting a bit and I seemed to be getting solid 70 with res scale at 110. I'll keep messing with it. This is after a reformat so I have been focusing on getting my pc back to the way I had it. Haven't had much time to test (maybe 30 minutes) but will post back.

    I'm current'y only running my mem frequency at 1400 when I used to have it at 1535 so that should hopefully help a bit as well.
     
  19. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,857
    Likes Received:
    246
    GPU:
    EVGA GTX 1080Ti SC
    Had some **** for breakfast lately? Reported for being rude.

    I run at 110Hz and setting an FPS cap anywhere below the refresh rate will cause hitching. Seen it, can't stand it. Your brain must operate at 5Hz I guess.
     
    Last edited: Mar 5, 2015
  20. DiceAir

    DiceAir Maha Guru

    Messages:
    1,367
    Likes Received:
    15
    GPU:
    Galax 980 ti HOF
    Ok whatever. I can endure a bit of input lag rather than having screen tear. The lag is so small. Maybe I will notice it but the screen tear is more of an issue. I use 95FPS cap on my overclock 96hz monitor vsynced and it works just fine for me. You know we all different. Some people don't even see the difference between 60hz and 120hz and for some people it's night and day. Let's say as long as you happy it's all fine. if you like to play at 300fps on 60hz panel and think it's smooth then fine. In the end I don't care what other people might say. I feel this is the best way for me and it fixed my lag even on my old 60hz panel I did run 59FPS capped to eliminate input lag and it worked for me.

    I was running gtx 570 sli at that time. Like I said whatever feels good for you go with that. I can't say hey no this and that is better but for you it's not. You get my point. It's like telling people that a certain game sucks like for example I hate DOTA 2 but is it a bad game, no it's not but I just don't like the game.


    I know I'm saying stuff the exact opposite to what I said earlier but I cleared my mind now


    WOW dude I wasn't being rude in any way. See i even removed my comment or whatever. Have you tried running windows in performance mode and unparking cores? I see no hitching anywhere when I set my fps cap below my refresh rate.
     
    Last edited: Mar 5, 2015

Share This Page