BF3 Stuttering Fix 285.62

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by neckdart, Oct 25, 2011.

  1. kcuestag

    kcuestag Master Guru

    Messages:
    904
    Likes Received:
    0
    GPU:
    Gigabyte GTX980Ti G1
    May I ask what's ProcessLasso? I'm interested, I hate having to disable HT to play the game. :(
     
  2. ThEcLiT

    ThEcLiT Master Guru

    Messages:
    519
    Likes Received:
    47
    GPU:
    Gigabyte 460 1gb OC
    did u know that we can use "user.cfg" in the main folder of game and put there commands? its working for me.


    RenderDevice.TripleBufferingEnable 0
    RenderDevice.ForceRenderAheadLimit 0 <--- or "1" , "0" works for me better.
    WorldRender.SpotLightShadowmapResolution 256
     
  3. kcuestag

    kcuestag Master Guru

    Messages:
    904
    Likes Received:
    0
    GPU:
    Gigabyte GTX980Ti G1
    ^That still does not remove ALL of the stuttering when Hyper-Threading is enabled.
     
  4. jvmagni

    jvmagni Master Guru

    Messages:
    236
    Likes Received:
    0
    GPU:
    GTX 670 OC
    I fixed by turning OFF HT and disabling all nvidia process during startup, including nv cpl and all it's .dll... Now I'm using Inspector to tune the profiles... I also disabling Thread Optimization and turn on VSYNC on Inspector... game runs fine.
     

  5. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    someone a few posts earlier wrote about it.
     
  6. ironhorse86

    ironhorse86 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    BFG 295 GTX
    i just registered to say that out of every forum, nvidia, guru3d, and bf3 to include this one and it's five pages of threads, NOTHING has solved my stuttering that can be seen here:
    http://www.youtube.com/watch?v=akS0BXPggXY
    http://www.youtube.com/watch?v=V6AzvLUESRA
    (First video is mine but second is notable as well)
    (most notable when circle strafing an object)

    64 bit seems to exasperate the problem as well as having more audio looping freezes.
    i have tried:

    reinstalling, clean installing, new OS, 32 bit and 64 bit, "performance mode" and "single display" i have forced vsync on and off, i have tried EVERY setting in bf3 itself. i have tried HT off and on, speed step, downclocking and stock clocks (Both cpu and gpu- tho gpu isnt overclocked) i have tried resetting page file, deleting page file, tried ps2 serial mice, optical mice, laser mice, disabled core parking, disabled windows turbo threaded boost priority, resetting RAM, removing RAM, trying every combo of settings related to mouse and mouse sensitivity in the profile settings, tried DVI instead of HDMI, tried different monitor Hz, tried dxtroxy and other fps limiters, tried single gpu, tried mouse accel, tried removing mouse accel with registry tweak, disabled origin in game overlay, uninstalled realtek audio drivers, reinstalled them and then also tried latest drivers, tried running everything as administrator, tried running things in compatibility mode, tried bcdedit /set increaseuserva 2500, tried reinstalling all physX, D3D, VC


    and have done all this while watching my FPS with render.drawfps and watching render.perfoverlayvisible 1, and as the videos show, there is severe CPU spiking. renderdevice.forceframesaheadlimit 1 with triple buffer at 0 helps slightly but most definitely does not get rid of it, especially since theres a ~25 fps loss when doing so. forcing Vsync on in the NVidia CPL is great because it removes stutter if you can maintain 60fps, but if it drops the stuttering is worse. so its a toss up. (its using swap interval right? because its much better than the in game vsync.)

    rolling back drivers is not an option as its guaranteed in minutes to A) artifact B)crash C)%50 loss in performance
    i have tried:
    285.69 (w/ and w/o modified inf)
    285.62 (the ****ing culprit)
    285.38 (bf3 beta)
    280.26
    280.19 (only one w/o stutter but see issues above)

    surely... someone has discovered SOMETHING in these drivers that is causing this. or has some form of workaround. i know nvidia has emailed a few people that they are aware of it, (without really saying what IT is or whether is the micro stutter or massive stutter they know of) but if any of you have dealt with their live chat / former McDonalds employees you know how comforting this is.

    to reproduce:
    i7 920 @ any setting
    295gtx @ any setting
    285.62 driver
    any bf3 ingame settings but the higher the more prominent the effect
    circle strafe an object / character.

    thank you for anyone who has anything to contribute.
     
    Last edited: Nov 5, 2011
  7. andressergio

    andressergio Master Guru

    Messages:
    895
    Likes Received:
    0
    GPU:
    GALAX GTX 1080Ti HOF SLI
    really weird mate cauz HT OFF solves it
     
  8. ironhorse86

    ironhorse86 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    BFG 295 GTX
    "it" as in micro stutter irregardless of mouselook OR
    "it" as in massive stutter due to movement + mouse movement?

    also, 200 series and below so far have been the ones experiencing this symptom the most that i can see.
     
  9. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    Well for me disabling HT only solves the constant stutter you get.
    But the random stutters only go away when i disable vsync.
     
  10. ironhorse86

    ironhorse86 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    BFG 295 GTX
    ingame vysnc is terrible and worsens the stuttering exponentially. (i should show you the vids)

    nvidia CPL force on vsync is better.. but like i said above if it dips below 60 fps the stutter comes back.

    i should mention that on auto settings (everything high and everything on) or high settings, i maintain ~40 to 60fps.
    this obviously changes when using render.forcerenderaheadlimit to 0 or 1.
     

  11. ironhorse86

    ironhorse86 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    BFG 295 GTX
  12. Mozgus

    Mozgus Active Member

    Messages:
    99
    Likes Received:
    8
    GPU:
    Radeon 7950 3GB
    I'm in the exact same situation. I have tried everything. Its truly pathetic.
     
  13. Sacrife

    Sacrife New Member

    Messages:
    8
    Likes Received:
    0
    If you are like me and bought a new computer for BF3 and have a Mouse running at 1000hz polling rate the cause might be the polling rate.

    I had massive fps stuttering with my new computer, after hours of testing I finally found out that it was the usb ports being overloaded or something because my mouse ran at 1000hz. Put it back to 500hz and it's been smooth ever since.
     
  14. Jonnyboy

    Jonnyboy Ancient Guru

    Messages:
    3,598
    Likes Received:
    9
    GPU:
    EVGA SC GTX 1070
    I seem to have fixed my stuttering problem by enabling v-sync in the nvidia control panel.
     
  15. yosef019

    yosef019 Ancient Guru

    Messages:
    2,142
    Likes Received:
    9
    GPU:
    EVGA 1080 ti
    its also perfomance stuter
    like see the guys who have dual gtx 580 have no stuter
    we need lower to high medium settings
    but drivers need to kick in too
     

  16. ironhorse86

    ironhorse86 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    BFG 295 GTX
    just tried:
    125
    500
    1000

    made no difference. verified using mouserate.exe
     
  17. ironhorse86

    ironhorse86 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    BFG 295 GTX
    see my video above? 60 to sometimes 85 fps..
    and it still exists. its not performance.
     
  18. Colt M4

    Colt M4 Master Guru

    Messages:
    855
    Likes Received:
    0
    GPU:
    Evga GTX 970 SC Sli
    Nothing works. I have changed drivers to the .38 the 280, low settings turned off HPET played with mouse settings nothing works. I get it once a day and it is just obnoxious. Nvidia needs to get its act together and fix this. It was in the beta and now the game unacceptable.
     
  19. CrayonMirZ

    CrayonMirZ Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    SLi GTX 680
    Mine stuttering like crazy as well, disable HT, disable overclocking, all newest bios/driver.
    Re-install punkbuster, still stuttering.
     
  20. CrayonMirZ

    CrayonMirZ Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    SLi GTX 680
    Yea me too tried lower settings but stuttering even got worse.
     

Share This Page