BF3 Stuttering Fix 285.62

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by neckdart, Oct 25, 2011.

  1. Ade 1

    Ade 1 Master Guru

    Messages:
    600
    Likes Received:
    0
    GPU:
    Gigabyte GTX 690
    Since I started playing Friday night I too have had no issues at all in both SP and MP. Everything is set to auto (which is high with some AA options enabled). Everything is just running very smoothly @ 1920x1080. I'll be very interested to try it in 3D when they finally enable it (even though BF3 is classed as a '3D Vision Ready' game! Go figure!).
     
  2. kcuestag

    kcuestag Master Guru

    Messages:
    904
    Likes Received:
    0
    GPU:
    Gigabyte GTX980Ti G1
    I had 2x HD6970 2GB, I went to 2x GTX580 1.5GB, I can't compare them because I was not able to try the HD6970's in the final game. But I can assure you, unless I disable HT, I get lots of stuttering on my system, once disabled, it plays smooth as silk.

    I play 1920x1080 @ Ultra + MSAA OFF (Stupid to use two AA's) + AA Post HIGH + Ambient Oclusion + SSAO

    I get +100fps all the time, it only drops below 100fps when the gpu usage also drops, and I can only feel it smooth with HT off.
     
  3. CrayonMirZ

    CrayonMirZ Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    SLi GTX 680
    Just did some testing on 3 similar setups,
    I7 920 @3.8
    I7 960 @ 3.8
    I7 960 @ stock

    Other setups are similar. The one with oc'ed cpu need disabling ht in bios to get rid stuttering. While the one running stock clocks have ht enabled and no stuttering at all. Dice probably dont really like overclockers lol.
     
  4. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    9,201
    Likes Received:
    1,450
    GPU:
    6800XT Nitro+ SE
    Funny.... My CPU is OC'd and I get no stuttering + HT is still enabled too. Oh and my GPU is OC'd too and still no stutter. Going to add a second 480 in soon so I can run surround. Just waiting for Nvidia to fix the damn drivers.
     

  5. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    I tried all the options here in threads, but i'm still getting the stutter.
    The stutter just appears for about 5 seconds, and the game returns to normal afterwards.

    Only way i got rid of it, is by turning off vsync.

    Are you guys getting this stutter with vsync on or off? Because if have no problems at all when using HT + fullscreen, with vsync off.
     
  6. drackonos10

    drackonos10 Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    Single HD 6970
    OMG, Thank you so much for this info on Hyperthreading. I couldn't understand why the game kept stuttering and trying to fly a jet with it doing this is almost impossible. At first I thought the devs had built in turbulence for the jets as its extremely noticeable in the cockpit...but it does it everywhere else as well when I'm not trying to fly. Quick bios switch and now its gone =D. Now my only problem is the game closing itself on me with no error or anything. It just did it while I was typing this message even. Does it give any message for an afk boot? It seems to mostly do it while waiting between matches...no error or anything, just me looking at my desktop all of a sudden heh. Either way, thanks again...you very well may have saved this game from me throwing it out the window lol.
     
  7. CrayonMirZ

    CrayonMirZ Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    SLi GTX 680
    i turned off HT and still got the same stuttering..
     
  8. Bohi2_OGU

    Bohi2_OGU Member Guru

    Messages:
    143
    Likes Received:
    0
    GPU:
    MSI GTX690
    ^^Try this its maybe helping you too;
    Goto Origin > Properties > Tab section IN-GAME > Untick (blanc box) 'Origin ingame enabled' other words disable that function.

    Set the Nvidia CP BF3 profile and use this settings;
    http://i42.tinypic.com/72zu6p.jpg

    It helps me anyway even i dont want to disable HT its almost gone with those settings..
     
  9. Quad4Life

    Quad4Life Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    gtx570 1.075v 870/2040
    Deleting and resetting the pagefile worked for me. Hopefully it helps others
     
  10. Hav0q

    Hav0q Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    nVIDIA Titan X
    I fixed this issue two ways;

    1.) If you have an i7, disabling HyperThreading does fix the issue.
    2.) If you go to your task manager while in game and set the Priority to "Realtime" that also fixes the issue.
     

  11. Penal Stingray

    Penal Stingray Banned

    Messages:
    957
    Likes Received:
    0
    GPU:
    GTX 680 Tri-Sli-S27A950
    Why Dont You Peeps Download This Program Processor Lasso Link: http://bitsum.com/prolasso.php install then when BF3 loads look for BF3.EXE on processor Lasso Windows and go to Set Current Cpu Affinity and Click Avoid Non Physical Cores and it will only use all real cores and disable hyperthreading it works well on mine and i dont have to turn off Hyperthreading all the time. Hopes this works for u. Also these program is amazing u can set priority to realtime, high, normal and ETC. Theres also I/o priority which u can set to critical, high, normal and low for better performance and not but not the least it has an option called Game Mode which focuses all resources only on games but beware turn this off after gaming.

    [​IMG]
     
    Last edited: Nov 3, 2011
  12. Hav0q

    Hav0q Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    nVIDIA Titan X
    Process Lasso, never even heard of it, but it does work, but only if I set priority of BF3 from Below Normal -> Normal and enable Gaming Mode.
     
  13. hirmak

    hirmak Master Guru

    Messages:
    321
    Likes Received:
    0
    GPU:
    GTX285
    These 2 are the solutions for Dx10-Dx9 GraCards.I hope Nvidia can solve it with the new drivers
     
  14. Hav0q

    Hav0q Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    nVIDIA Titan X
    I'm having issues with Process Lasso, the only way I can get it to fix the stuttering is actually not by disabling hyperthreading (non-real cores, w/e) but by:

    1.) Enabling Gaming Mode
    2.) Disabling ProBalance
    3.) Disabling Windows Dynamic Thread Priority Boosts Enabled (*)

    My gripe is that Windows Dynamic Thread Priority Boosts re-enables itself every single launch and I have to alt+tab to disable it, then the game runs buttery perfect.
     
  15. ShadowDuke

    ShadowDuke Ancient Guru

    Messages:
    4,279
    Likes Received:
    638
    GPU:
    XFX Radeon RX 6600
    not.
     

  16. Bohi2_OGU

    Bohi2_OGU Member Guru

    Messages:
    143
    Likes Received:
    0
    GPU:
    MSI GTX690
    Process Lasso is for me personally the worst application ever. What ever setting i used i got not stuttering but worse frame skipping of seconds also the sound was broken and got distortion and stuttering in Bf3. The fps drop to 30 and stays there when its normally 60 with Vsync enabled so the result was i deinstalled this one and all went 'normally' again...
     
  17. Jonnyboy

    Jonnyboy Ancient Guru

    Messages:
    3,598
    Likes Received:
    9
    GPU:
    EVGA SC GTX 1070
    when I 1st started playing bf3 I had bad stuttering and found out it was a memory dim slot that was bad so switched em,and I seen 97% of the stuttering gone.I still see some stuttering in the game when I play the sp in offline mode or online in origin.
     
  18. awesom-o

    awesom-o New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Asus GTX 560 Ti
    Got the stutterig yesterday after some hours of playing.
    Checked resource monitor under task manager, turned out I had 40Mb (!) of free memory. 6Gb was marked as "in use", 2Gb was in "Standby".
    I just shut down a couple of background programs, fixed it right up.
    Note, BF3 used only about 1.5Gb, the rest was used by windows and mostly firefox.
     
  19. dnottis

    dnottis Master Guru

    Messages:
    695
    Likes Received:
    0
    GPU:
    EVGA SSC 970 GTX 4GB
    Maybe this is a clue... I use Chrome as my main browser and dont get any stutter.
     
  20. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti
    There are 2 kinds of stutter i got with this game.

    One is the constant stutter you get when walking around, this is fixed by disabling HT, or using the ProcessLasso.

    The second problem i CANT fix, is a random stutter that appears after 3 mins of playing. And only happens when looking in a certain direction, the rest is super smooth. Anyone else have this?

    I do play at low, with post AA also on low.
     

Share This Page