BF3 big stuttering after playing for several minutes

Discussion in 'Videocards - AMD Radeon Drivers Section' started by mao5, Dec 14, 2011.

  1. mao5

    mao5 Guest

    after several updates, now I found BF3 MP almost unplayable on my 5870CF, no matter what drivers I used, I always got big stuttering after playing the game for several minutes, I can see the HDD LED lighting heavily, means my hard disk had heavily read and write operations, at the same time, I can barely do any movement in the game, no matter on foot, or in any vehicles. Any suggestion? thx.
     
  2. screwtech02

    screwtech02 Member Guru

    Messages:
    196
    Likes Received:
    25
    GPU:
    EVGA RTX 2070 Super
    Getting the same issues on my setup with 3 5830's... Run in game settings on med, with no aa/af, use command line for renderahead limit, and triple buffering. Always start decent with say 60fps @ 5280x1080 bezel corrected eyefinity. Then the fps just drops to 12-19 tops. Using 8.93 drivers. Will look into new 12.1 preview drivers, but I'm not hopefull @ all...
     
  3. adams222

    adams222 Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    2x Sapphire 5850 (Xfire)
    Same here. I've given up to be honest.

    I'm back to 11.11a with 11.11 CAP 2 because no other combination works.

    I still have problems with this combo and the stuttering is still there.
     
  4. mentalpeace

    mentalpeace Active Member

    Messages:
    78
    Likes Received:
    0
    GPU:
    MSI GTX 670 Oc edition
    I will give you one simple solution, put Textures in High, if you have it on Ultra it will stutter after several minutes as you say.

    The game has some kind of memory and Video-memory Leak, so if you play in massive resolutions or if you put textures on ultra it will stutter.
     

  5. krishnarama108

    krishnarama108 Master Guru

    Messages:
    288
    Likes Received:
    0
    GPU:
    asus ati 5850 1gb 850mhz
    lagy servers
     
  6. Mufflore

    Mufflore Ancient Guru

    Messages:
    12,074
    Likes Received:
    949
    GPU:
    1080Ti + Xtreme III
    His machine isnt a server though :rolleyes:
     
  7. krishnarama108

    krishnarama108 Master Guru

    Messages:
    288
    Likes Received:
    0
    GPU:
    asus ati 5850 1gb 850mhz
    but if he has problem suddenly i doubt its SF or HW...
     
  8. Sprecker

    Sprecker Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    Zotech 680 4g
    I never had this problem until yesturday. All of a sudden I couldn't play a game without it stuttering and totaly ruinning the game for me. I would start playing get a few kills etc. then I would engage an enamy and the screen would freeze as soon as a shot is fired and then I find my self looking somewhere and getting shot. After the first instance it just seems to keep happening.
    Frustrated the hell out of me.
     
  9. Nato.dbnz

    Nato.dbnz Ancient Guru

    Messages:
    3,264
    Likes Received:
    0
    GPU:
    5870 Crossfire
    I have the same GPU setup as you. I definitely need to run textures on high rather than Ultra and a few other settings on high or else I get the same unplayable framerate issues. It is the 1Gb frame buffer running out I think.
     
  10. Mufflore

    Mufflore Ancient Guru

    Messages:
    12,074
    Likes Received:
    949
    GPU:
    1080Ti + Xtreme III
    The first post is usually a clue.
    Reading the posts after helps as well ;)

    His hard drive LED starts running constantly.
    This is either down to a hard drive fault (no other problems highlighted with it) or he has run out of memory and the page file is in heavy use.

    Do you propose that a laggy server can make his hard drive go wild?
     

  11. Clouseau

    Clouseau Ancient Guru

    Messages:
    2,574
    Likes Received:
    338
    GPU:
    ASUS STRIX GTX 1080
    What helped for me was uninstalling catalyst and then reinstalling it.

    1. Stopped all services relating to amd/ati that was not associated with raid
    2. Uninstalled CIM using the express option
    3. Used CCLeaner to delete all registry entries associated with amd/ati not associated with raid
    4. Changed option in windows to see hidden files
    5. Deleted all files and folders left after uninstall associated with ACE, FUEL, and catalyst
    6. CCleaner again to remove resulting restry entries associated with what was just deleted in 5 above
    7. Ran regedit and removed all remaining registry entries associated with amd/ati (there are alot left behind)
    8. Changed Prefetch and Superfetch settings from 3 (caches everything) to 1 (caches only applications)
    9. Hard booted the rig
    10. Installed Catalyst

    No problems ever since

    ***(Back up registry before any editing)***
     
  12. screwtech02

    screwtech02 Member Guru

    Messages:
    196
    Likes Received:
    25
    GPU:
    EVGA RTX 2070 Super
    You realize that CCC allocates system memory for the vid cards too right??? Or am I mistaken on that?? Cause when I open CCC, i see that there is like 6gb of "hyper" memory allocated to each of my vid cards...

    If the game suffres from a "memory" leak, you'd think that having 24gb would rule that out, unless its gonna use ALL of my system memory....
     
  13. geeunit

    geeunit Master Guru

    Messages:
    375
    Likes Received:
    0
    GPU:
    intel 4500mhd
    get GPU-Z
    start logging temperatures and gpu usage
    if you have 2 vcards then start TWO gpu-z and start logging for each vcard (select the proper vcard in the drop down box)

    usually its temps
     
  14. screwtech02

    screwtech02 Member Guru

    Messages:
    196
    Likes Received:
    25
    GPU:
    EVGA RTX 2070 Super
    Def not temps in my case. Full system is liquid cooled. Card temps never go above 30c, if that....
     
  15. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    If you are running textures on ultra, you are running out of Vid memory and it is trashing your pagefile instead.
     

  16. geeunit

    geeunit Master Guru

    Messages:
    375
    Likes Received:
    0
    GPU:
    intel 4500mhd
    gpu-z also reports VRAM temps not just gpu temps

    also gpu-z logs gpu frequency

    you can tell alot by running gpu-z (mainly you want to see if THERMAL THROTTLING is kicking in when it should not be)
     
  17. krishnarama108

    krishnarama108 Master Guru

    Messages:
    288
    Likes Received:
    0
    GPU:
    asus ati 5850 1gb 850mhz
    iam tellin yu its the game patch / server issues... not yur hw or driver...
    i played until now and it goes ok...
    just wait until it settles down
     
  18. BlueDream

    BlueDream Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI 5970
    I have had the same issue off and on. What is weird is that it is not consistent and can start up and end at any time without warning. I am running 11.11c with no CAP and have textures set to medium and that seems to work best for me at the moment. It definitely seems to be related to the textures somehow as it happens more frequently with textures on high.
     
  19. rongtw

    rongtw Member Guru

    Messages:
    116
    Likes Received:
    0
    GPU:
    asus 1060 strix
    i play BF3 all on high , Xfire 6870,s i have no probs with 11.12 and caps 3
     
  20. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    Yes it is my gut feeling that the root of all BF3 stuttering is running out of VRAM for whatever reason.


    BF3 starts to use system ram if VRAM runs out, which causes the stuttering
     

Share This Page