Battlefield 3 Massive Stuttering

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Ryoazza, Mar 4, 2012.

  1. Ryoazza

    Ryoazza New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Crossfire XFX 6850 2GB
    So I've just bought Battlefield 3 and I'm having a hell of a hard time with it. No matter what settings I put the game on it stutters like mad. It will be running smooth at like 90FPS but then plummet but then go back up. It;s impossible for me to get a smooth framerate.

    I'm using an 4.7Ghz OC i5 with 6850s in Crossfire
    Using Catalyst 12.1 with CAP1 and I'm not sure if it's these drivers or some other problem such as overheating. Anyone got any experience with these drivers and crossfire so I can eliminate it as the problem?
     
  2. DeFade

    DeFade Active Member

    Messages:
    90
    Likes Received:
    0
    GPU:
    SapphireToxic R9 280X 3GB
  3. k3vst3r

    k3vst3r Ancient Guru

    Messages:
    3,371
    Likes Received:
    21
    GPU:
    Zotac 1070 Amp
    your system ram amount? pagefile enabled? window managed pagefile? settings in game like high? ultra? using AA? resolution?
     
  4. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    try checking out your in game temps by with a hwmonitor (free app)
     

  5. Brandon_34

    Brandon_34 Master Guru

    Messages:
    320
    Likes Received:
    0
    GPU:
    EVGA 690GTX
    I am running driver feb 14th 8.96 http://downloads.guru3d.com/download.php?det=2865 no application caps installed.

    In game settings are 1920x1080
    Texture=high
    shawdows=med
    effects=ultra
    mesh=ultra
    terrain=ultra
    terrain dec=ultra
    anti def=off
    anti post=off
    motion blur=on
    af=16x
    ao= hbao
    fov=90
    I get insane frames with smooth gameplay with a 2500k@4.5 and a single 5970 900/1200. ( which the video card is only 1gb vram).
     
  6. iFRAC7UR3

    iFRAC7UR3 Master Guru

    Messages:
    357
    Likes Received:
    0
    GPU:
    Zotac GeForce GTX 680 2Gb
    i got some of the same problems with my setup.. the crazy thing is it ran smooth earlier.. only thing i could think of was gpu driver.. but that was not the case.. and then the other only thing was my bios update that god changedd.. could that be a problem of yours aswell ?
     
  7. k3vst3r

    k3vst3r Ancient Guru

    Messages:
    3,371
    Likes Received:
    21
    GPU:
    Zotac 1070 Amp
    enable vsync?
     
  8. PolishTechGuy

    PolishTechGuy Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    Gigabyte GTX 780GHz
    Your problem = CrossFire. I had two 6950's and the game was more enjoyable on a single card tbh, with cf enabled 80fps felt like 30.

    Right now im playing on a single 6950 med/high settings, smoothly.
    I'll be picking up my new 7970 tomorrow though and test it out on Ultra :)

    Enable vsync and tripple buffering and see if it helps. You'll get some bad input lag though.
     

Share This Page