Battlefield 3 CrossFire Tweaks

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ipredator, Apr 8, 2012.

  1. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    Yep same here , doesn't matter what i do, its the same stuttering even if my FPS is like 100 or whatever, I thought i fixed but then a change of map and its back again. Last time i'm going SLI OR CFX . Oh and now i have just started to play skrim and i get the worst stuttering like all hell. 2 great games i cant play , Guess i'll just have to move on....
     
  2. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    I'll try using the hint of BenchAndGames and install the game on my HDD, lets see if it really improves magically!
     
  3. NiColaoS

    NiColaoS Master Guru

    Messages:
    655
    Likes Received:
    47
    GPU:
    GTX 1660 SUPER
    On modern graphic cards, what could be the difference turning the Aero on/off? Is the performance hit noticeable or it might be in certain situations?

    I'm really wondering 'cause supposedly the Windows getting better, our cards too, each year we pay more and more and still something like the Aero could be drawback? Or just as precaution?
     
  4. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,627
    GPU:
    ROG Strix 1080 OC
    I found a tweak that cures BF3 CFX problems, at least for me.

    Not an ideal tweak because it effects the system negatively in other areas and other games I have tried playing with this tweak enabled have been worse performance

    But its easy to disable again when you're done with BF3:

    Open Elevated Command Prompt and type the following:

    bcdedit /set useplatformclock true

    Now reboot. This enables HPET


    To disable, open command prompt and type:

    bcdedit /deletevalue useplatformclock

    Now reboot. This disables HPET again.


    These commands tell Windows to only use the HPET timer and not a combination of timers as is does as default.

    Worked 100% for me with CFX and BF3, without this tweak I can not even load BF3 with CFX enabled.

    Like I say, not ideal, it makes some games better and some worse, but easy enough to disable again.
     

  5. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    i've heard of that, have a few year old thread bookmarked somewhere, certain games/situations/multigpus had issues with timing, sometimes when overclocked
     
  6. roli7710

    roli7710 Guest

    Its a mess....

    The best driver to run BF3 on my crossfire setup is with 12.2 (still have it installed), framelimited 59, vsync ON, rendering ahead 0, but had lock ups playing Crysis 2 :( . With 12.3 did not downclock the second card on idle and 12.4 caused microstuttering even on COD4. At least could play Crysis 2 smoothly with the latest one. Its a mess....
     
  7. SpdyRobi

    SpdyRobi Active Member

    Messages:
    93
    Likes Received:
    0
    GPU:
    GTX 1070 SLI
    I know this is an old thread but I just installed another 7970 with 12.8 and I can only run BF3 with vsync turned on or else it crashes after a couples minutes
     
  8. bc_tileguy

    bc_tileguy Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    xfx 7970 crossfire
    yeah that is odd !! i'm with ya , I just use Vsync in game and Crossfire is fine with BF3. (actually ever since bf3 was released , i never had any issue with crossfire (and i've had 5970+5870 (tri-fire) + 6990 . then 6990+6970 (tri-fire) then 7970 crossfire :) and now a single 7970, cause the performance increased so much (awesome drivers ) i no longer need 2 to run at max settings/4x aa 2560x1600
    but i'm using the 12.8 / 12.8cap2
     
  9. Alph4Dawg

    Alph4Dawg Member Guru

    Messages:
    108
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor OC
    So, you're telling me VSync ON in-game doesn't gives you mouse lag?!
     
  10. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    people can handle input lag differently

    & depending on how the engine works, it could be very little lag (plus there are ways to reduce it yourself while keeping vsync on)
     

  11. main_shoby

    main_shoby Maha Guru

    Messages:
    1,045
    Likes Received:
    1
    GPU:
    980Ti Qnix 2710 96Hz
    i wanted to write the same thing :p but i dont have 120hz display. my game is not 100% smooth even at 190-200 frames lol... may be my eye's refresh rate is 3000hz :p
     
  12. bc_tileguy

    bc_tileguy Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    xfx 7970 crossfire
    yup i guess i am :) i don't notice any
     
  13. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Then your FPS stays under your monitors refresh rate most of the time.

    Guys I can't test it right now myself because I'm on a travel, but the new 9.00 driver seems to be great for BF3. Use RadeonPro to force TripleBuffering on while disabling BF3's own fake triplebuffering by opening the console and type "RenderDevice.TripleBufferingEnable 0" or write it in your user.cfg.
    While the TripleBuffering without Vsync will not get rid of all the screen tearing in BF3, it will smooth the gameplay out and reduce the screen tearing to a very slight amount.

    As soon as I am back I'll try the driver and update the first post.
     
  14. rogue221979

    rogue221979 Master Guru

    Messages:
    643
    Likes Received:
    7
    GPU:
    Gigabyte 3090 GTX
    I get too much tearing with vsync off. Tried the other tweaks so I leave it on. I get no mouse lag though.

    Of course I'm on 2 5870s with no AA @1920x1080. So with it off my FPS don't climb about 70 or on a 64 MP server.

    First few minutes of the game is stuttery until everything loads after a minute the game smooths out.
     
  15. bouuman

    bouuman Active Member

    Messages:
    81
    Likes Received:
    0
    GPU:
    6650m + 6620G
    This bouth advices really helped me a lot! Thank you ipredator, bf3 running much smoother now!
     
    Last edited: Sep 25, 2012

  16. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Pleased to hear that mate!

    Yeah real TripleBuffering sure is a nice thing. It works more reliably with RadeonPro for me, though.
     
  17. somemadcaaant

    somemadcaaant Master Guru

    Messages:
    379
    Likes Received:
    14
    GPU:
    Red Devil 6900XT LE
    Silly advise to disable pagefiling and hyperthreading, just looking for trouble disabling those. Gamebooster is an ads program with toolbars and spyware and the 9660 profile is blurry so can't view it.

    12.3 - 8.96 14 February are the best driver for BF3 for a 6990, any cap version.
     
  18. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    You couldn't be more wrong about HT. Pagefiling is pretty obsolete for 8gb+ RAM, too. Gamebooster a spyware? Wake up man. It's now even officially supported by Razer. Not sure about the toolbar, but you can always untick those in the installation.
     
  19. xwl

    xwl Member

    Messages:
    11
    Likes Received:
    0
    I have a 6990 and to make buttersmooth with VSYNC:

    • UNPLUG all other monitors from the back of the card. (disabling them doesn't work)
    • Restart (optional)
    • Still can't believe how smooth it is.

    I'm using default 12.8 drivers with 12.7 CAP3.

    I don't any other way around it...:confused:
     
  20. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    The goal of this thread is to make BF3 smooth WITHOUT having to put up with vsync. It sure makes your game smooth but it comes with massive input lag and it locks your framerate to 60 or 120, depending on the hz of your monitor.
     

Share This Page