Battlefield 1 Open Beta on HD7670m

Discussion in 'Videocards - AMD Radeon Drivers Section' started by spectatorx, Sep 4, 2016.

  1. spectatorx

    spectatorx Master Guru

    Messages:
    735
    Likes Received:
    93
    GPU:
    Radeon RX580 8GB
    Is there any way to make it work? Currently latest driver available for this gpu is 16.2.1 a.k.a 15.301.1901 and when i try to launch the game i receive an error telling that required version is at least 16.20.1025.

    In situation like this there are two solutions to the problem:
    1. somehow make any of newer drivers to work on this gpu which is considered to be legacy gpu.
    2. somehow make the game to skip driver version check and just run it.

    Anyone knows how to do any of these?

    I know the whole idea might sound crazy but i just want to try beta and as i recently moved this laptop is the only "gameable" thing i own at the moment and i would like to start the game even if i would need to go with all settings to low.
     
  2. s0x

    s0x Member Guru

    Messages:
    136
    Likes Received:
    1
    GPU:
    MSI RX 480 Gaming X 8G
    The latest 16.8.3 should install.

    On the display driver .inf:

    "%AMD6840.1%" = ati2mtag_Legacy, PCI\VEN_1002&DEV_6840
    AMD6840.1 = "AMD Radeon HD 7600M Series"

    "%AMD6841.1%" = ati2mtag_Legacy, PCI\VEN_1002&DEV_6841
    AMD6841.1 = "AMD Radeon HD 7500M/7600M Series"

    "%AMD6843.1%" = ati2mtag_Legacy, PCI\VEN_1002&DEV_6843
    AMD6843.1 = "AMD Radeon HD 7670M"

    -edit-

    Or not. Nvm.
    It has nothing on the ati2mtag_Legacy section.

    - edit 2 -

    Over at reddit:
    https://www.reddit.com/r/Battlefield/comments/50jctw/how_to_fix_amd_update_error/

    Some guy changed the driver version info on regedit.. But it's a hackish way of doing so.
    But also keep in mind that that GPU is well below the recommended minimum specs https://www.battlefield.com/games/battlefield-1/tech
     
    Last edited: Sep 4, 2016

Share This Page