Awful benchmark score: something wrong with my GTX1080?

Discussion in 'Videocards - NVIDIA GeForce' started by annoluce, Nov 19, 2017.

  1. annoluce

    annoluce New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    XFire AMD HD6870 1Gb
    Hi Gurus,
    I recently upgraded from MSI gtx 970 to INNO3D gtx 1080 FE.
    I expected much more punch.
    Some low end games are stuttering for no reason (slyrim/enderal and Farming sim 2017), whilst with my 970 were smooth like butter..
    What is more yesterday I ran the heaven benchmark (below the settings and results) and honestly the outcome is really upsetting.
    Don't even know why the tool is showing 4 Gb RAM instead of 8 on the 1080 (GPU-Z shows it correctly though).
    And why, for the sake of heaven, the GPU is showing as integrated/dedicated?
    Is there a way to avoid that the integrated card is used instead of dedicated?

    Is there something wrong with the new 1080? Should I return it?
    Or, I'm just concerning for nothing?

    Thanks a lot.

    Unigine Heaven Benchmark 4.0
    FPS:
    43.1
    Score:
    1085
    Min FPS:
    23.4
    Max FPS:
    62.4
    System
    Platform:
    Windows NT 6.2 (build 9200) 64bit
    CPU model:
    Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz (3392MHz) x4
    GPU model:
    Intel(R) HD Graphics 3000 9.17.10.4459/NVIDIA GeForce GTX 1080 23.21.13.8831 (4095MB) x1
    Settings
    Render:
    Direct3D11
    Mode:
    2560x1440 8xAA fullscreen
    Preset
    Custom
    Quality
    Ultra
    Tessellation:
    Extreme
     
  2. Marco Borsato

    Marco Borsato Member Guru

    Messages:
    150
    Likes Received:
    0
    GPU:
    GTX 980 Ti (1450/4000)
    You should hit at least 60 fps or higher in Heaven 4.0 with those settings from what I can tell after googling some results, GPU-Z should also be able to report GPU usage, temperature and Core Clock, post their maximum values, that should give us some useful information. I'm assuming you did a clean driver installation before benching your new card? What power supply are you using? A GTX 1080 isn't crazy power hungry but just in case.

    As Kastriot suggest, go into your BIOS settings and see if you can disable your integrated GPU entirely.
     
  3. jbscotchman

    jbscotchman Maha Guru

    Messages:
    1,315
    Likes Received:
    47
    GPU:
    EVGA 1060 6gb /770
    Did you do a clean driver uninstall?
     
  4. annoluce

    annoluce New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    XFire AMD HD6870 1Gb
    Thanks guys for replies.
    Yes I did a clean driver install. And yes I set up pci-e as the only GPU source in BIOS.
    Well I realized that I left v-sync active during the benchmark. Repeating benchmark with v-sync deactivated gave me better results, I hit 60 fps average and 120 max (I don't have my results at hand now).
    I thought that the GTX 1080 even founder could bring some more punch, but maybe my expectations were misled.
    Question is, I need v-sync for my monitor. But I tried the last driver feature (fast sync) and it works quite well.
     

Share This Page