ATI HD 5970 Problem

Discussion in 'Videocards - AMD Radeon' started by Enzo250, Sep 4, 2012.

  1. learners permit

    learners permit Master Guru

    Messages:
    309
    Likes Received:
    3
    GPU:
    6900xt
    Sounds like vram issue. Use catalyst control center to underdrive you ram by say 50Mhz and run the game that artifacts the worst to see if that's the issue. BTW be sure to clock both cards the same using select GPU drop down menu.
     
    Last edited: Sep 12, 2012
  2. Basquedude

    Basquedude Member Guru

    Messages:
    135
    Likes Received:
    0
    GPU:
    Diamond 5970 2GB
    rma time
     
  3. rogue221979

    rogue221979 Master Guru

    Messages:
    644
    Likes Received:
    7
    GPU:
    Gigabyte 3090 GTX
    Have you tried setting your fans to 100%?

    70 at idle is odd. My cards idle at 40c and I get up too 65c during BF3.
     
  4. srpanj13

    srpanj13 Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    R9 290@1150/1600 AccEx IV
    Friend i've had XFX5970 for 3 years and then it started to malfunction like leaking textures , i'm afraid same scenario as in your case i can play a game after a while a texture leak happens across the image for example some pistol leaks across the image you can still play the game but it's very anoying and it randomly happened not in all games but yes one of the GPU'S is dying you should get a replacement i got gtx580 can't say i'm sorry in any case but i'll put my money that it's dying i've had same problem's no its not PSU not it's not CPU / Mobo or drivers its GPU Itself.. hope you fix it
     

  5. orion24

    orion24 Master Guru

    Messages:
    836
    Likes Received:
    0
    GPU:
    GTX 680 @ 1254/1703
    That card is of some age. I suggest you remove it and clean the dust from the cooler
     
  6. toadhammer

    toadhammer New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Radeon 5970
    I have the same issue, and I'm pretty sure it's some sort of driver or card bios issue. It's not temperature and I dust periodically. My system passes memcheck and prime95 with flying colors. My 5970 passes furmark with no issues, all the way up to 99% GPU and temps way higher than my games ever see. And all this at stock speeds.

    But with most games, and afterwords with windows itself, I get artifact pixels and lines everywhere, pixelated textures or flashing problems in games, and sporadic display driver crashes. I've been seeing this for a long time, from at least catalyst 12.11 - 13.4. When I get some time, I think I'll try putting older ones on....I know it wasn't happening when I first built the rig.
     
  7. Portuogral

    Portuogral Master Guru

    Messages:
    205
    Likes Received:
    1
    GPU:
    MSI GTX 1070 Gaming X
    I was a proud HD5970 owner since it came out until June, 12th and i used latest Catalyst drivers available so, I can tell you with high degree of certainty the drivers are OK.
    If you run the card at stock, maybe you need to sweep clean the drivers before installing the latest ones.
    I don't know if is a BIOS issue. If it was, I don't think the card would stand in Furmark like you said it does.
    It's an odd issue alright but, I would start from cleaning up the drivers. There are several tools that can do it for you. Driver Sweeper is one of them.
     

Share This Page