1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ATI HD 4870 @ ATI FirePro v8700 does work for me..?

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by blu0xi, Feb 22, 2009.

  1. fricoberto

    fricoberto Member

    Messages:
    15
    Likes Received:
    0
    Test

    Well, I tried 38xx Softmod but ... is only for 32 bits, I have Xp64 :(.
     
  2. NormanBates

    NormanBates Master Guru

    Messages:
    376
    Likes Received:
    0
    GPU:
    ATI HD3870 / ATI HD4670
    there's an xp64 patchscript too, but it's a different one

    search this forum and you'll find it (I've posted links to it many many times)
     
  3. fricoberto

    fricoberto Member

    Messages:
    15
    Likes Received:
    0
    Thks NormanBates, Yes I can softmod Radeon 3850 on 32&64 bits, for 8.453 drivers with Gellmar's patch.

    But Ignis ask for latest 8.543 drivers.
     
  4. ignis

    ignis New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    HD3870 512Mb
    Thank you for answare,
    now I read many posts and all is clear..
    My problem is, what buy?
    3870 with patch 8.4x driver?
    or 4870 with original driver? (futur investment)
     

  5. NormanBates

    NormanBates Master Guru

    Messages:
    376
    Likes Received:
    0
    GPU:
    ATI HD3870 / ATI HD4670
    to fricoberto: sorry, my fault, the patchscript I was talking about is, as you said, for older drivers only

    to ignis: right now I'd get a quadro FX580: it's a real quadro (no mod issues and less driver glitches), it's nearly as fast as a modded 3870 (or a modded 4870 if that ever comes to be), and for a change it's affordable
    the only problem it has is that it's brand new and availability is an issue
     
  6. furikake

    furikake New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire HD4870 512Mb
    I tried it and had a nice blue screen.

    Im a newbie in this softmod thing so I just uninstalled 4800 drivers, installed the chinese driver, reboot. (did I do anything wrong?)

    Windows started and everything seems fine...
    30 seconds later boom!
    blue screen.

    Sapphire ATI HD4870 512Mb (Do I need 1Gb version?)
    Windows XP SP3 32bits.
    Athlon 64x2 3800 (939) | 4Gb RAM
     
    Last edited: Apr 12, 2009
  7. tulifaiv

    tulifaiv New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATi HD4870@FirePro v8700
    Hi, I got a Sapphire HD4870 512mb "softmodded" to v8700. I simply installed these drivers (I have WinXP SP3 32bits too) after uninstalling Radeon ones, rebooted and everything seems working fine (no blue screens).

    GPU-Z correctly recognizes my card as FirePro:

    [​IMG]

    After running some benchmarks, though, I realize that the softmodding process has not gone very well...

    These are my results (SPECViewPerf 10 @ 1600x1200, dunno why it says 1280x1024):

    [​IMG]

    And these are the expected ones:

    http://www.deskeng.com/pics/0409/amd_atiFirePro4_800.jpg

    As you can easily see, performances are very far from v8700 ones...


    As my card is correctly recognized as a v8700, I think that those drivers are the correct way to softmodding, but probably we have something to flash, but... what?
     
    Last edited: Apr 15, 2009
  8. CADCAT

    CADCAT Master Guru

    Messages:
    232
    Likes Received:
    0
    GPU:
    Mobility HD5870 1GB GDDR5
    This is very poor, I have the following CATIA scores:

    C2D@2Ghz, HD2700 256MB GDDR3 - 30
    C2D@3,3Ghz HD3870 1GB - 49
    C2D@3,83Ghz HD3870 OC 512MB - 52

    So with 4870 it should be something like 60 and maya score much higher..
     
  9. szymanero

    szymanero New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Gigabyte 4870x2
    Yup, poor, mine are also that way but I have managed to do the same mod (well, after some patch modyfication it allowed me to run CCC with all options, before it was just with info tab and display tab which had all options turned off) with the same effects on Vista 64 with SP (Used driver FirePro_8.583_Vista64_77160).

    PatchScript is a bit different from Gellars, I have done it just using 6th sense, but it worked better in this way (altough no effects in performance) :) So genius people - do it finally, maybe this will help :)

    [Common]
    SrcFile = ati2mtag.sys
    BakFile = ati2mtag.old
    HlpFile = newbietechFireGLX2000.rth
    MakeCRC = 1
    Packed = 1

    ;common script for 669x+
    DstVar0 = force ATI FireGL V8650 capabilities
    DstVar1 = force ATI FireGL V8600 capabilities
    DstVar2 = force ATI FireGL V7600 capabilities
    DstVar3 = force ATI FireGL V5600 capabilities
    DstVar4 = force ATI FireGL V3600 capabilities
    DstVar5 = force AMD FirePro V3700 capabilities
    DstVar6 = force AMD FirePro V3750 capabilities
    DstVar7 = force AMD FirePro V5700 capabilities
    DstVar8 = force AMD FirePro V7770 capabilities
    DstVar9 = force AMD FirePro V7760 capabilities
    DstVar10 = force AMD FirePro V8700 Duo capabilities
    DstVar11 = force AMD FirePro V8750 capabilities
    DstVar12 = force AMD FireGL V7700 capabilities

    Src0 = 41 B9 03 00 00 00 41 B8 94 00 00 00 E8 06 9F 00 00 85 C0 74 32 33 C0 EB 45
    SCM0 = FF FF FF FF 00 00 00 00 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    Dst0 = FF 75 08 E8 79 60 00 00 85 C0 74 2E 33 C0 EB 38 08 85 C0 74 32 33 C0 EB 40
    DCM0 = 00 00 00 00 FF FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

    Src1 = 83 F8 40 75 1D 66 81 BD 00 00 FF FF 02 10 75 00 0F B7 85 FE FE FF FF
    SCM1 = FF FF FF FF 00 FF FF FF 00 00 FF FF FF FF FF 00 FF FF FF FF FF FF FF
    Dst1_0 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 0A 94 66 89 85 FE FE FF FF 90
    Dst1_1 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 0B 94 66 89 85 FE FE FF FF 90
    Dst1_2 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 0F 94 66 89 85 FE FE FF FF 90
    Dst1_3 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 8C 95 66 89 85 FE FE FF FF 90
    Dst1_4 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 8D 95 66 89 85 FE FE FF FF 90
    Dst1_5 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D CC 95 66 89 85 FE FE FF FF 90
    Dst1_6 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 9F 94 66 89 85 FE FE FF FF 90
    Dst1_7 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 9E 94 66 89 85 FE FE FF FF 90
    Dst1_8 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 46 94 66 89 85 FE FE FF FF 90
    Dst1_9 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 56 94 66 89 85 FE FE FF FF 90
    Dst1_10 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 47 94 66 89 85 FE FE FF FF 90
    Dst1_11 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 44 94 66 89 85 FE FE FF FF 90
    Dst1_12 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 11 95 66 89 85 FE FE FF FF 90
     
  10. szymanero

    szymanero New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Gigabyte 4870x2
    Forgot to add: in RivaTuner (while using Vista64) You have to modyfy the atikmdag.sy_ file, just to be precise
     

  11. partyboy

    partyboy Member

    Messages:
    14
    Likes Received:
    0
    Not working stably

    I modded my cards

    saphire 3870 modded
    firepro 9170 on xp32 (8.44)FULLY WORKING
    and v7700 xp64 (8.4X.1)FULLY WORKING

    1 or 2 hours later system immidiately restarting.always doing this XP32 AND XP64


    and i just bought

    xfx 4870 1gb moded v8700 (only work %90 fine in x32 DRIVER 8.603 MODDED DRIVER DOWNLOADED INTERNET)
    this restarting too (LIKE 3870)

    BOTH CARD RESTARTING IN 2 HOUR
    (LEAVE COMPUTER IDLE AND INTERNET DOWNLOAD ----OR---- FULL 3D BENCH ALWAYS RESTARTING IN 2 HOUR)
    I LOWER GPU MHZ AND RAM MHZ AND DONE IT AGAIN

    is there any fully stable card...for long usage
    3870 fully works
    4870 neraly fully some scpec test not working bur solidworks work fine.


    SPEASE HELP ME I REALLY NEED A STABLE CARD.
     
    Last edited: Jun 7, 2009
  12. casebuyer

    casebuyer Active Member

    Messages:
    89
    Likes Received:
    0
    GPU:
    HIS 3870 IceQ 3 DDR4 512
    so did you softmod 4870
    can you try softmod with a clean xp installation to be sure it is not because a conflicting driver
     
  13. airo

    airo New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    HD 4870
    Anything new here?
    I'm looking for softmod script for windows 7 x64 for HD4870. Can someone please
    post it here?
    Or you can set "compability mode" for driver to work like in XP?
    Thanks for any response.
     
  14. CADCAT

    CADCAT Master Guru

    Messages:
    232
    Likes Received:
    0
    GPU:
    Mobility HD5870 1GB GDDR5

Share This Page