ATI Catalyst 9.4 driver Download and Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Decane, Apr 8, 2009.

  1. ForgedReality

    ForgedReality Master Guru

    Messages:
    216
    Likes Received:
    0
    GPU:
    HD4870x2OC + 9600GT PhysX
    Can somebody hack the ****ing sideport already? :(
     
  2. Cobrass2

    Cobrass2 Member Guru

    Messages:
    151
    Likes Received:
    0
    GPU:
    RTX 3080 Suprim X
    Do u really need that?
     
  3. ReDi

    ReDi Member Guru

    Messages:
    111
    Likes Received:
    0
    GPU:
    2x Sapphire HD4870 CF
    Installed 9.4 yesterday to replace 8.12 as well. Having read the above I also just started the 9.4 installer without having uninstalled 8.12. The installer popped up in Task Manager, but nothing happened afterwards. Waited for a minute or so without anything happening, then killed the process, restarted the PC, then set to the usual routine I always apply: uninstall, reboot, Driver Cleaner Pro in safe mode, reboot, install new driver. Went smoothly, everything works like it should. So apparently the easy-does-it way doesn't work for every configuration...
    This was all on Vista Home Premium 64-bit.
     
  4. RayderR6

    RayderR6 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Sapphire 4870x2
    Bummer, then again, if the same thing happened to all of us, we would have consoles :biggun:
     

  5. The General

    The General Ancient Guru

    Messages:
    3,108
    Likes Received:
    5
    GPU:
    FirePro W5000 2GB
    The 9.4 drivers are so good, i don't mind waiting for WHQL drivers now and skipping the betas. Way to go ATI :)
     
  6. ForgedReality

    ForgedReality Master Guru

    Messages:
    216
    Likes Received:
    0
    GPU:
    HD4870x2OC + 9600GT PhysX
    You don't know YOU don't need it either. Or I guess I should say 'want' instead of 'need.' Nobody knows what kinds of performance increases we'd see with the sideport, and I'm curious to know what would change.
     
  7. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
    None, Ati have stated it makes no difference, hence they've not enabled it.
     
  8. darrenj

    darrenj Ancient Guru

    Messages:
    1,735
    Likes Received:
    91
    GPU:
    EVGA 3080
    Just update to Win 7 RC (7100, clean install) and installed ATI/CCC 9.4. But when I start CCC either by left clicking or programs menu CCC does not open but runs in the background (windows task manager) can I get some help with this.
     
  9. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,974
    Likes Received:
    1,833
    GPU:
    GTX1070 iChillx4
    can you check in device manager if the drivers are installed ?
    if not, you have to manually install them from there
     
  10. darrenj

    darrenj Ancient Guru

    Messages:
    1,735
    Likes Received:
    91
    GPU:
    EVGA 3080
    Thanks for the quick response.
    In device manager it says
    ATI Radeon HD 4800 Series( Microsoft Corporation WDDM1.1)

    When I try to update driver and direct it to the ATI folder it says the best, latest driver is already installed. Basically I cannot get CCC up. Its running in the back ground.
     

  11. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,974
    Likes Received:
    1,833
    GPU:
    GTX1070 iChillx4
    thats the problem , the driver that came with win7 is installed.
    you have to update, search for a location, and choose have disk, then navigate to the ati folder. give it a try, if it dont work, ill make screenshots for you tonight when i get home.
     
  12. UncleGuito

    UncleGuito Active Member

    Messages:
    90
    Likes Received:
    0
    GPU:
    Radeon HD 4850
    I can't get these to install in Windows 7 7100 either. Just reinstalled x64 yesterday and it won't install over the default drivers.
     

Share This Page