ATI Catalyst 12.11 Beta 11 Modded driver For Legacy GPU

Discussion in 'Videocards - AMD Radeon Drivers Section' started by dellon132, Dec 27, 2012.

?

ATI Catalyst 12.11 B11 HotFix 11.01 Thoughts

  1. AMD HD 5000 and 6000 Users (GOOD)

    9.6%
  2. AMD Legacy GPU Users (HD 2000-4000) (GOOD)

    41.1%
  3. AMD Previous Legacy Mobility Users (Old GPU's) (GOOD)

    8.9%
  4. AMD Switchable Graphic Users (GOOD)

    6.2%
  5. AMD HD 5000-6000 Mobility Users (GOOD)

    8.2%
  6. AMD Legacy Mobility Users (HD 2000-4000) (GOOD)

    16.4%
  7. AMD HD 5000 and 6000 Users (BAD)

    0.7%
  8. AMD Legacy GPU Users (HD 2000-4000) (BAD)

    6.8%
  9. AMD Previous Legacy Mobility Users (Old GPU's) (BAD)

    4.1%
  10. AMD Switchable Graphic Users (BAD)

    6.2%
  11. AMD HD 5000-6000 Mobility Users (BAD)

    1.4%
  12. AMD Legacy Mobility Users (HD 2000-4000) (BAD)

    6.2%
Multiple votes are allowed.
  1. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Try taking the aticfx32 and aticfx64 from previous driver then drop it in the folder of the current driver.

    EDITED
    Use these.
    http://www.mediafire.com/download/6nr3uburbank99b/Crossifire_CFX.7z
     
    Last edited: Aug 12, 2013
  2. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
    Tried, CF still disabled.
     
  3. Menpower

    Menpower Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire R9 290 TRI-X OC
  4. Menpower

    Menpower Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire R9 290 TRI-X OC
    Crossfire worked for me, can you try Furmark on fullscreen and monitor your gpu usages with rivatuner?
     

  5. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
    Yes, only the 1st GPU gets maxed.
     
  6. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    UPDATE For x64Bit Users
    This Update attempts to resolve
    Crossfire related bugs in which application
    profiles appear missing and multi Gpu appears
    to be non functional for some Users.

    Here is the Download Link:

    AMD Catalyst 13.8 Beta Modded x64Bit Legacy Driver V4.3.1
     
    Last edited: Aug 12, 2013
  7. masterchan777

    masterchan777 Master Guru

    Messages:
    261
    Likes Received:
    0
    GPU:
    GTX 1070 OC
    Hi Dellon, I will test your latest drivers and report back

    I have one more suggestion for you to consider, can you replace the old xcode package in your drivers with AVIVO v11.7.0.11109 which is more recent and works much better with GPGPU applications, I will include a link to that package so you can take a look at and hopefully include in your next release:

    http://www.mediafire.com/download/k7icwn7yi4ya7cs/AVIVO64.rar


    Thank you once again for your great work.
     
  8. Menpower

    Menpower Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire R9 290 TRI-X OC
  9. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    The Avivo package included in this driver actually uses the 12.4 Avivo. Did you have problems using that one then decided to downgrade to 11.7?

    Other Thoughts
    Previously you mentioned that you were missing your mobility power tab for HD 5000 series or am I confusing you with someone else?

    Did you use the driver cleaner in the Dx9 Switcher folder before re-installing the driver?
     
    Last edited: Aug 12, 2013
  10. masterchan777

    masterchan777 Master Guru

    Messages:
    261
    Likes Received:
    0
    GPU:
    GTX 1070 OC
    The package included with your drivers is XCode version 10.0.0.31111, I am using the newer AVIVO package as it seems to be better than the previous ones in terms of perfomance and compatibility with legacy cards, please check it out and see if you can replace the older XCode with this one, and on the other subject, yes you might be confusing me with someone else :)
     

  11. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
    Getting a BSOD regarding atikmdag.sys at boot, going back to 12.11 V10.2.
     
  12. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3

    Ahh you are looking at the version of the installer, you need to look at the version of the actual files as I never did Update the version of the installer. Also if it's like you said then it means the Avivo package from 12.4 is actually slower than the one shipped with the 11.7 package.

    Another Thought
    Ohh, sorry for confusing you with someone else.

    No changes were made to the atikmdag.sys. Was the Bsod consistent in which it happened more than one time? Also did this update resolve the crossfire not working bug?
     
    Last edited: Aug 12, 2013
  13. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
    BSOD happened just when entering Windows, so I had no chance to check if CF was on or off.
     
  14. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Hmm, so after the first Bsod you decided to enter safe mode and perform full driver cleanup?
     
  15. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
    First I tried to boot again, but the same BSOD happened, so I did a complete cleanup and went back to 12.11 V10.2, which works perfectly.
     

  16. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Ahh, thanks for clarifying. I will look into the Bsod.

    Can you tell the steps you normally take when installing a new driver? May help when attempting to replicate the bug.
     
  17. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
    1) Uninstall the driver using Catalyst Install Manager, reboot.
    2) Boot into Safe Mode.
    3) Use Display Driver Uninstaller.
    4) Use both aSimple CleanUP Utility and Driver Cleaner.
    5) Use Driver Fusion, reboot.
    6) Install the driver, reboot.
     
  18. fLuXuS

    fLuXuS Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    Sapphire HD 4870X2 WC
    Hi Dellon,

    Crossfire is disabled by default.
    CFX Switcher need to be run to activate both GPU after a full restart.
    CFX Switcher won't revert to single GPU, run w/ admin privileges and restart.
    Clock bug still present after exiting 3d app.

    Normal install without any bsod.

    best regards,
     
    Last edited: Aug 12, 2013
  19. Menpower

    Menpower Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire R9 290 TRI-X OC
    Yes i used driver cleaner.
     
  20. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Ok, The next Update will be for the 12.11 V10.2 Driver to integrate x32Bit Support into the driver and Update the Dx9 Switcher to the most recent while also including the latest Crossfire profiles. The 13.8 Series will continue on as it did before as an attempt to get the driver working correctly.

    Reason for integrating Support for x32Bit Users would
    be to provide both x64Bit Users and x32Bit Users with an Updated version of the driver without any delays.
     

Share This Page