ATI Catalyst 12.11 Beta 11 Modded driver For Legacy GPU

Discussion in 'Videocards - AMD Radeon Drivers Section' started by dellon132, Dec 27, 2012.

?

ATI Catalyst 12.11 B11 HotFix 11.01 Thoughts

  1. AMD HD 5000 and 6000 Users (GOOD)

    9.7%
  2. AMD Legacy GPU Users (HD 2000-4000) (GOOD)

    41.4%
  3. AMD Previous Legacy Mobility Users (Old GPU's) (GOOD)

    8.3%
  4. AMD Switchable Graphic Users (GOOD)

    6.2%
  5. AMD HD 5000-6000 Mobility Users (GOOD)

    8.3%
  6. AMD Legacy Mobility Users (HD 2000-4000) (GOOD)

    16.6%
  7. AMD HD 5000 and 6000 Users (BAD)

    0.7%
  8. AMD Legacy GPU Users (HD 2000-4000) (BAD)

    6.9%
  9. AMD Previous Legacy Mobility Users (Old GPU's) (BAD)

    4.1%
  10. AMD Switchable Graphic Users (BAD)

    6.2%
  11. AMD HD 5000-6000 Mobility Users (BAD)

    1.4%
  12. AMD Legacy Mobility Users (HD 2000-4000) (BAD)

    6.2%
Multiple votes are allowed.
  1. pilonull

    pilonull New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Sapphire HD4870X2
    Hey Dellon132

    I wanna say that I love your work, I've been using your drivers since day 1.

    With your latest drivers (13.8 v1), for some reason it is not allowing me to install the drivers for my HD4870X2.

    this is the relevant info from the install log:

    Thanks for any input you can give me and I look forward to using the latest and greatest from you!
     
  2. masterchan777

    masterchan777 Master Guru

    Messages:
    261
    Likes Received:
    0
    GPU:
    GTX 1070 OC
    Fan control is fine here, Win 8 X64 with AMD Catalyst 13.8 Beta Modded x64Bit Legacy Driver V1


    [​IMG]
     
  3. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    13.8 Modded Legacy Driver
    This Update intends to resolve the following bugs

    Notes
    -Catalyst Control Center being partially installed
    -Updated aSimple CleanUP Utility to resolve a bug
    causing explorer to not restart.
    -Updated the Driver Cleaner to CleanUP more Third Party Drivers.
    More Info on the Driver Cleaner.
    The Driver Cleaner attempts to Uninstall all Third Party Driver as
    an attempt to revert the System back to it's previous State when
    the OS is First Installed.

    Here is the Download Link:
    AMD Catalyst 13.8 Beta Modded x64Bit Legacy Driver V2

    Note: This Update will be the last Update For x64Bit Users
    as I still Need to Work on the x32Bit Driver. Therefore there will be no
    Updates until the x32Bit Driver is Updated.
     
  4. IFPMaximus34

    IFPMaximus34 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Ati mobility radeom 4300
    hi dellon i got the same problem as pilonull it only skips the drivers install other like ccc etc install fine also i tried from device manager same problem.The problem from my knowledge seems to be to your inf whitch something is missing like a string or something else .im using ati mobility radeon 4300 with win7-64x using AMD Catalyst 13.8 Beta Modded x64Bit Legacy Driver V1.Any solution?
     

  5. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    It's an error on my side I will provide another Update.

    AMD 13.8 Modded Legacy Driver

    This Update is meant to make the following changes

    Notes
    -Resolve a Bug causing Driver to not install for
    x64Bit Windows 7 Users.
    -Resolve a Bug causing explorer to display icons
    incorrectly for x64Bit Users using Windows 8.
    -Updated all cleaners to allow users to run them without
    the use of the "Run as administrator" option.

    Still Existing Bug
    aSimple CleanUP Utility sometimes fail to restart
    explorer after the cleaning process is over.

    The Workaround
    would be using ctrl alt and delete to start
    task manager or get a menu that allows you to start task
    manager. Next look for the File menu and click on run new task
    then type in explorer and hit enter.

    Here is the Download Link:
    AMD Catalyst 13.8 Beta Modded x64Bit Legacy Driver V3.1
     
    Last edited: Aug 6, 2013
  6. cnckane

    cnckane Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    Mobility 4650
    Lag

    With 13.8MOD I have strange FPS, drops and 1-2 sec freezes in Mass Effect 3.
    I have a mobility radeon 4670 and win8 x64, with 12.6 and 13.4 was fine.
     
  7. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Are you playing mass effect 3 in Dx9 or Dx10?
     
  8. cnckane

    cnckane Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    Mobility 4650
    DirectX9.
     
  9. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Ok, Try using the Dx9 Switchers as an attempt to resolve your performance problem.
     
  10. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,672
    Likes Received:
    355
    GPU:
    MSI Geforce GTX 1080
    @Dellon132
    May I suggest on your cleaner B instead of using :
    devcon32 remove =display *
    to:
    devcon32 remove =display "@*ven_1002*"

    this will be more focus to remove AMD display driver only and not anything else like Intel HD ...

    And instead of going straight to C:\windows .... use %WINDIR% variable as not everyone install their O.S on C:\

    just my 2 cents

    EDIT: Forgot the most important and critical one.
    With PNPUTIL the -F force the removal of the oem even when in-use. and this is super bad imo as you are annihilating the "Driver Store" since you delete oem0 to oem 150 even if they are in-use! Remove the F parameter and only the drivers not in-use(the one you removed) will be deleted.
     
    Last edited: Aug 6, 2013

  11. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Thanks for the input Wagnard. The remove display command you mentioned above will allow Intel Switchable Graphics Users to use the driver without conflict when using the Cleaner. But I'm a bit unsure about %WINDIR% does this command focuses only on the Windows directory currently in use or does it also affects other Windows directory? For example, launching the cleaner in a partition installed with a different version of Windows.

    Other Thoughts
    The cleaner in the driver package uses the manual method of cleaning to get
    rid of all third party drivers. Would this not also conflict with intel graphics if the driver is not removed using the Remove Display command already implemented in the cleaner?

    EDITED
    Ok, you seem to have answered the question in the post above.
     
    Last edited: Aug 6, 2013
  12. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,672
    Likes Received:
    355
    GPU:
    MSI Geforce GTX 1080
    %windir% return the current active windows installation directory.
    If you are browsing on d:\ and windows is on c:\windows and you use %windir% , it will return the correct c:\windows

    %windir% will return C:\windows on normal system. from there you can add \system32 or anything else needed. Its the sure way to get to the working windows folders.

    Like if you do CD %windir%\system32 it would get you to c:\windows\system32 (for normal installation on c:\)
     
    Last edited: Aug 6, 2013
  13. antdes45

    antdes45 Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    Asus R7260X-DC2OC-2GD5
    Hello, I have just tried to install the "AMD Catalyst 13.8 Beta Modded x64Bit Legacy Driver V3.1" under Windows 8.1 and the Catalyst Install Manager doesn't suggest any packages to install, unlike the latest 12.11 legacy package. If I use the Windows 7 compatibility mode, the packages show up but the installation freezes on AMD package manager.
     
  14. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,672
    Likes Received:
    355
    GPU:
    MSI Geforce GTX 1080
    From what I know even the official 13.8 beta doesn't support Win 8.1 without modification.
     
  15. JohnHas

    JohnHas New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Ati Mobility Radeon 4650
    Amazing job with the latest set of drivers (13.8 Beta Modded x64Bit Legacy Driver V3.1) !! Install and working flawlessly!
    Keep up the good work dellon132!
    p.s. 13.8 Beta Modded x64Bit Legacy Driver V2 could not be installed on my system! (Radeon 4650)
     

  16. antdes45

    antdes45 Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    Asus R7260X-DC2OC-2GD5
    Sounds right. Anyways, it worked flawlessly with the Windows 8 compatibility mode this time.
     
  17. IFPMaximus34

    IFPMaximus34 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Ati mobility radeom 4300
    the ccc doesn't show correctly when I click on it it opens but it dosent have nothing on it all white,while moving it its get blurry.
    using 13.8 Beta Modded x64Bit Legacy Driver V3.1 .Any solution on my computer or a ccc bug or something like that?
     
  18. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Try the build below. Before installing the package run both cleaners located in the dx9 Switcher folder.

    13.8 Modded Legacy Driver

    Notes
    -Officially added support for Windows 8.1
    -Updated Cleaners base on Wagnard Suggestions
    -Changed the way the Cleaners work.

    Here is the Download Link:
    AMD Catalyst 13.8 Beta Modded x64Bit Legacy Driver V3.2
     
  19. SabotageX

    SabotageX Active Member

    Messages:
    75
    Likes Received:
    11
    GPU:
    Gigabyte RTX 3080
    Same thing happened to me when i first installed the 13.8.

    Now i'm getting "Application Install: install source package not found" error with any driver i try to install. Seriously, this is the 3rd time Catalyst drivers ruin my system, how can i thanks ATI for such amazing software?
     
  20. trocio2

    trocio2 Master Guru

    Messages:
    484
    Likes Received:
    0
    GPU:
    GT 630 1GB DDR3 GK208 Kep
    Official Catalyst drivers? ATI doesn't exist anymore. Even if AMD really ruined your system (which I find hard to believe) they don't care about legacy products.
     

Share This Page