ATI Catalyst 12.11 Beta 11 Modded driver For Legacy GPU

Discussion in 'Videocards - AMD Radeon Drivers Section' started by dellon132, Dec 27, 2012.

?

ATI Catalyst 12.11 B11 HotFix 11.01 Thoughts

  1. AMD HD 5000 and 6000 Users (GOOD)

    9.7%
  2. AMD Legacy GPU Users (HD 2000-4000) (GOOD)

    41.7%
  3. AMD Previous Legacy Mobility Users (Old GPU's) (GOOD)

    8.3%
  4. AMD Switchable Graphic Users (GOOD)

    6.3%
  5. AMD HD 5000-6000 Mobility Users (GOOD)

    8.3%
  6. AMD Legacy Mobility Users (HD 2000-4000) (GOOD)

    16.0%
  7. AMD HD 5000 and 6000 Users (BAD)

    0.7%
  8. AMD Legacy GPU Users (HD 2000-4000) (BAD)

    6.9%
  9. AMD Previous Legacy Mobility Users (Old GPU's) (BAD)

    4.2%
  10. AMD Switchable Graphic Users (BAD)

    6.3%
  11. AMD HD 5000-6000 Mobility Users (BAD)

    1.4%
  12. AMD Legacy Mobility Users (HD 2000-4000) (BAD)

    6.3%
Multiple votes are allowed.
  1. giuli1993

    giuli1993 Member Guru

    Messages:
    119
    Likes Received:
    0
    GPU:
    ATI HD 4250/6650m
    Ok i will try this. What about the stable release?
     
  2. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    I will make a decision base on the results of this driver.
     
  3. Andrw0830

    Andrw0830 Master Guru

    Messages:
    352
    Likes Received:
    0
    GPU:
    Nvidia 740M/ Intel 4600
    Pretty good, one thing with Intel I have noticed in my laptop is that it doesn't heat up as much as AMD when in a pre-boot situation. With the Nvidia card, so far I am able to run current games at High settings with pretty good fps. My SSD though is having trouble so it looks like I have to RMA it.
     
  4. giuli1993

    giuli1993 Member Guru

    Messages:
    119
    Likes Received:
    0
    GPU:
    ATI HD 4250/6650m
    This one seems to install both cards correctly but during installation the screen turns black.... to solve this i have to remove drivers on safe mode
     

  5. Avaddon

    Avaddon Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Radeon HD3850 512mb
    I am install 9.8.2:
    Flash/Apps W8, DX9 (GTA4) / DX10 (Metro Last Light) - drivers operating normally. Radeon 3850.
    Thank Dellon, keep up the good work!

    Is there a sense of installed CAP (Catalyst Application Profile)?
     
  6. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    UPDATE For x64Bit Driver.
    This update intends to make the following changes

    Notes:
    -Attempts to Fix Black Screen When installing Driver
    for Switchable Graphics
    -Updated the OpenGL Driver for HD 5000 and 6000 Users

    Here is the Download Link:
    ATI Catalyst 12.11 B11 HotFix 10 P6 V9.8.3 Legacy Driver x64Bit

    This driver already uses Updated Application Profiles. So you should not have to install application profiles alongside the driver.
     
    Last edited: Jul 17, 2013
  7. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
    Are you planning to release a stable release soon as the current one is still V3?
     
  8. Avaddon

    Avaddon Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Radeon HD3850 512mb
    Very good :)
     
  9. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    I'm not quite sure yet as I still have a few changes I would like to make before releasing a Stable Release.
     
  10. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    The laptop you bought seems very powerful. So I'm guessing you did not get it as a replacement but as an Upgrade in which you had to pay the difference. Correct?
     

  11. chleb

    chleb Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    AMD 4250 + 5470
    9.8.2 on switchable amd

    Sorry for the delay,

    Tried 9.8.2 last night, went through all setup process without any trouble, got 2 black screen phase while 2 drivers got installed, but no definitive black screen at the end.

    But, only one card is ok:

    [​IMG]

    [​IMG]

    error details on 4200:
    [​IMG]

    [​IMG]

    PowerXpress switching is uneffective.

    I see you uploaded 9.8.3, I'll download it and try.
     
  12. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Did you finish Testing yet? I may have fix for the HD 4200 not start even though the driver gets installed. BTW can you translate the error code 43 message?
     
    Last edited: Jul 19, 2013
  13. SamLab

    SamLab Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    nVidia 640M + Intel 4000
    V9.8.3:
    CH150272 - %ATI% = ATI.Mfg, NTamd64.6.0 - good
    C8150272 - %ATI% = ATI.Mfg, NTamd64.6.2 - good
    C7150272 - %ATI% = ATI.Mfg, NTamd64.6.0, NTamd64.6.2 - why not NTamd64.6.1?
     
  14. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    That inf is left behind for the Previous Legacy Graphic Cards.
     
  15. chleb

    chleb Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    AMD 4250 + 5470
    I just checked again in device manager after clean reboot, same state, drivers looks correctly installed, 4200 stays down.
    Nothing more done, didn't had spare time to spend on it yesterday.

    Is there a testing procedure you want me to follow ?

    Didn't tried yet 9.8.3, gonna try it, or more recent if any, today/tonight.

    Error 43 is: Windows has stopped this device because it has reported problems.

    EDIT:
    previously when having one yellow marked 'error 43' gpu and trying to switch; I got BSOD.
    This time it hasn't done anything, no forced switch to a non working gpu ending on a bsod, just non effective "switch" button in PowerXpress settings.

    Thanks.
     
    Last edited: Jul 19, 2013

  16. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    UPDATE For x64Bit Users
    This Update intends to make the following changes.

    Notes
    -Attempts to resolve HD 4000 Series Driver Conflict
    with the HD 5000 and 6000 Graphic Cards
    -Attempts to resolve Switchable Graphics not Functioning
    correctly after installation
    -Enable 2D Acceleration in Firefox for Windows 8 Users
    2D Acceleration BENCHMARK
    -Updated the Driver Components
    -Continued Support for installing Driver without Disabling Driver Enforcement
    Signature or Enabling Test-Mode.

    Note:

    When Uninstalling this Driver it's recommended to Uninstall
    using the Default AMD Uninstaller or Device Manager.

    Here is the Download Link:
    ATI Catalyst 12.11 B11 HotFix 10 P6 V9.8.5 Legacy Driver x64Bit
     
    Last edited: Jul 20, 2013
  17. chleb

    chleb Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    AMD 4250 + 5470
    Downloading then testing
     
  18. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Did you finish testing yet?
     
  19. chleb

    chleb Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    AMD 4250 + 5470
    ok, so:

    booted in 7) driver signature enforcement mode
    uninstalled all amd drivers with amd utility 1.2.1.0
    reboot in 7) mode
    install your 9.8.4 version via setup.exe

    Install without any error.
    reboot in normal mode
    Got the following error message "Catalyst Control Center isn't supported by this graphic card driver version. Please update your driver or activate your gpu thanks to Display manager"

    In device manager, same yellow mark on 4200 series.
    5400 series looks ok.
    Both are 13.10.0.0 version, 07/19/2013.

    rebooted again, nothing changed.

    Catalyst Control center doesn't show any GPU related options.
    only useless menu about CPU power consumption, performance.
     
  20. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Ok, in the next Update I will change the install order of the graphic card as an attempt to get both Graphic Cards Working. I will also take a look at the Catalyst Control Center issue.


    EDITED
    What was the last driver you installed that had a working Catalyst Control Center? Never mind it should be P6 V9.8.2
     
    Last edited: Jul 19, 2013

Share This Page