ATI Catalyst 12.11 Beta 11 Modded driver For Legacy GPU

Discussion in 'Videocards - AMD Radeon Drivers Section' started by dellon132, Dec 27, 2012.

?

ATI Catalyst 12.11 B11 HotFix 11.01 Thoughts

  1. AMD HD 5000 and 6000 Users (GOOD)

    9.7%
  2. AMD Legacy GPU Users (HD 2000-4000) (GOOD)

    41.7%
  3. AMD Previous Legacy Mobility Users (Old GPU's) (GOOD)

    8.3%
  4. AMD Switchable Graphic Users (GOOD)

    6.3%
  5. AMD HD 5000-6000 Mobility Users (GOOD)

    8.3%
  6. AMD Legacy Mobility Users (HD 2000-4000) (GOOD)

    16.0%
  7. AMD HD 5000 and 6000 Users (BAD)

    0.7%
  8. AMD Legacy GPU Users (HD 2000-4000) (BAD)

    6.9%
  9. AMD Previous Legacy Mobility Users (Old GPU's) (BAD)

    4.2%
  10. AMD Switchable Graphic Users (BAD)

    6.3%
  11. AMD HD 5000-6000 Mobility Users (BAD)

    1.4%
  12. AMD Legacy Mobility Users (HD 2000-4000) (BAD)

    6.3%
Multiple votes are allowed.
  1. leontin

    leontin Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    Sapphire HD4870
    And about the latest "ATI Catalyst 12.11 B11 HotFix 10 P6 V11.10.6.7.7.2All Supported OS"

    Still not working :( now when I install over the WDDM (1.1) I got this message:

    [​IMG]

    I chosed "Install anyway" but still don't work.
    When I installed without WDDM this message didn't appeared anymore but Display Driver Failed.
    I'm still using that app with which is working.

    P.S:
    The shortcuts now are working but when I click "G" still only the DISABLED message appears...
     
  2. andybozy

    andybozy New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Mobility Radeon HD 4670
    Code:
    And about the latest "ATI Catalyst 12.11 B11 HotFix 10 P6 V11.10.6.7.7.2All Supported OS"
    
    Still not working  now when I install over the WDDM (1.1) I got this message:
    
    
    
    I chosed "Install anyway" but still don't work.
    When I installed without WDDM this message didn't appeared anymore but Display Driver Failed.
    I'm still using that app with which is working. 
    
    P.S:
    The shortcuts now are working but when I click "G" still only the DISABLED message appears...

    I can't install the driver because of the driver not signed
    I chose install anyway but same problem. I can not install the driver
     
  3. geowizard

    geowizard Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    GigaByte HD4890 1GB
    I still can't install the sriver through the Setup.exe. Also, the installation through the Device Manager does not seem to work, because after the reboot I get the message that I have no AMD drivers installed. Moreover I get a driver signature error after the finish of the installation.
     
  4. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    The patch currently does not support the Standalone build. It only works with default google installer.


    Currently Uploading another build for Testing.

    UPDATE FOR ALL SUPPORTED OS 11/20/2013

    Installation Guide
    See Here for UPD Build Install Guide
    -Download and Extract
    -Run both aSimple Cleanup Utility
    and aSimple Driver Cleanup.
    -Install the Driver Through AMD Setup
    -Installation Complete.

    This Update intends to make the following changes.

    Notes:
    -Re-uploaded the driver to allow Windows Vista/7 x32Bit Users to install the driver.
    -----------------------------------------------------------------------
    -Attempts to resolve a signature bug.
    -----------------------------------------------------------------------
    -Updated the Flash GPU Acceleration Switcher to Support Chrome For
    HD 2000 to HD 4000 Users. This should help Legacy Users achieve working Hardware Acceleration for Google Chrome on Windows 8 and 8.1.
    -Updated Avivo to the Latest Version
    -Updated the installer as an attempt to resolve a bug in which the
    Display Driver and HDMI Driver gets skipped.
    -Added Two levels of Cleaning for the Package Cleaner.
    The First is called Full Software Uninstall which basically Cleans ALL (Most) Installed Software from Windows Programs and Features.
    The Second is AMD Normal Uninstall which only CleansUp AMD Related Packages.
    -Attempts to Resolve a bug in Which Visual C++ 2010 may not have been automatically re-installed after Uninstalling drivers.
    -Added Support for Cleaning Visual C++ 2012
    -Continued Attempt to resolve the 4K Video Bsod bug (UltraHD Video)

    Note:
    -Users can use the iAMD Version Changer to change there Catalyst version
    from 12.11 to AMD Catalyst 13.11.
    -Switchable Graphics Users should provide a detail feedback stating how the latest driver functions on their setup.

    Pending Changes
    -Adding a Low Powered Switcher for Mobility HD 4000 Users and Below.
    -Adding a Switcher Capable of allowing Users to revert to a Previously
    Working\Stable Build. (For HD 2000 Series - HD 4000 Series)

    (NON UPD Build)
    Link:ATI Catalyst 12.11 B11 HotFix 10 P6 V11.10.6.7.7.4 All Supported OS
     
    Last edited: Nov 21, 2013

  5. liquidfox12

    liquidfox12 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    ati x1400
    Hey dellon been a bit busy with exams , tested your latest build , its a no go same error as before in the pm's i have sent you , I am guessing the x1400 card cant support anything beyond 10.2 , the upd build fare's a little better as in i upgrade from 10.2 to it but none of the games run , catalyst does not open , dxdiag refuses to open , no windows aero either , so reverted back to 10.2
    The x series wasn't even in the last 13.1 legacy i guess , 10.2 is the last for us, was anyone else running the x series card able to get it to work ?
     
  6. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    The bug seems to only affect Mobility x1000 Users and below. But it does not seem to exist for Desktop Graphic Cards. (Previous Legacy Desktop GPU)
     
  7. geowizard

    geowizard Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    GigaByte HD4890 1GB
    The Setup.exe does not install the Display Driver (actually it tries but it fails), but through the Device Manager the installation is completed with 100% success.
     
  8. Lelouch

    Lelouch New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Radeon Xpress 1200 series
    I did (it's only working if I disable driver enforcement in Windows 8.1 x64 pro with wmc). Using v11.10.6.7.5.1 version with Ati Xpress 1200 (onboard). Catalyst control center is working as it should, of course only when driver enforcement is disabled.

    When installing the driver it mentioned that ati radeon kernel mode driver isn't signed properly (also amd (dual) display crap) and refused to install it - used driver enforcement enabled.

    P.s: As mentioned before it only works as it should if driver enforcement is enabled, otherwise it won't. CCC nahs driver not found, control panel says driver not loaded code 52.

    Maybe a bug, but when I shutdown a computer when driver enforcement is still active, after turning it on I'm welcomed by a black screen with a mouse pointer only. Solution is to restart PC without driver enforcement and then shutdown.
     
  9. antdes45

    antdes45 Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    Asus R7260X-DC2OC-2GD5
    OK people with the signature problem.

    Try Display Driver Uninstaller first, then change the date back one month, then try to reinstall.
     
  10. Dennismc1974

    Dennismc1974 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    ati 4200 HD

  11. Dennismc1974

    Dennismc1974 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    ati 4200 HD
    hey dellion on past 2 drivers now im having uncomression of the zip errors in locked files i use winrar and keeps giving errors of corruption
     
  12. andybozy

    andybozy New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Mobility Radeon HD 4670
  13. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Try 7zip it should have a higher compatibility rate with files compressed as 7z.

    You can try using Boot UI For Windows 8
    http://winaero.com/comment.php?comment.news.191

    Hmm, did you try installing the display driver without installing any other packages?
     
    Last edited: Nov 21, 2013
  14. ingmacl

    ingmacl New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ATI HD 3650 AGP 512mb
    Hi folks!

    I'm trying to use this driver "ATI Catalyst 12.11 B11 HotFix 10 P6 V11.10.6.7.7.3All Supported OS" for my old HD 3650 AGP under Win 7 32 bits , but when CMI install don't show the display driver, I'm try to manually install the driver, but only see vista and win8 on the driver folder.

    It's ok to use the vista driver? Maybe Win 7 32 is not supported in this relase? is that so... what relase do you recommend?


    thanx for your help in advance!
     
  15. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Re-uploaded the driver.
     

  16. ingmacl

    ingmacl New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ATI HD 3650 AGP 512mb
    Great! thanx Dellon! I'm trying now to download the file but this error is show : "This file is currently set to private."

    probably is upload the file in this momment, i'm triyng later to report results.
     
  17. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Sorry about that, the file was accidentally set to private.
     
  18. ingmacl

    ingmacl New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ATI HD 3650 AGP 512mb
    re-download the file, but CIM not show display drivers for Win 7 x32, going to app folder and i found this drivers:

    C7150272 = amd display driver for vista
    C8150272 = amd display driver for windows 8
    CE15952 = amd display driver for windows 8
    and CW15952 = amd display driver for vista
     
  19. geowizard

    geowizard Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    GigaByte HD4890 1GB


    It still doesn't install the Display Driver. They only way I have managed to install it, is through the Device Manager.
     
  20. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    You found those files in the App Folder or the driver folder?


    Other Thoughts
    Tested the driver on Windows 7 x32Bit and it installed correctly. No missing driver. (Test was Performed on a HD 5450)

    Try, uninstalling all packages and drivers using the included cleaner then delete all previous versions of the 12.11 modded legacy driver along with all AMD/ATI Official Drivers.

    Hmm, did you try installing the display driver without installing any other packages? Are you using the included Cleaners?
     
    Last edited: Nov 21, 2013

Share This Page