ATi Catalyst 10.6

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Jun 16, 2010.

Tags:
  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    @Kohlendioxidus - Confirmed.

    H.A.W.X. DX10 only runs on GPU2 on my PC with these drivers, same bug as 10.6 betas.

    Here's a couple of screenshots taken from the game, the first with the 10.4 drivers from April 2010 and then another with the 10.6 drivers taken today.

    H.A.W.X. DX10 Screenshot (Catalyst 10.4)

    H.A.W.X. DX10 Screenshot (Catalyst 10.6)

    Sorry that it's hard to read but if you click on them to zoom in you can make out that in the first shot GPU is even at 28% each but in the second only GPU2 is being used (57%). By the way, GPU2 is actually GPU1 and vice versa (a 'quirk' with MSI Afterburner).
     
  2. Sobtanian

    Sobtanian Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    7970 crossfire-1125/1575
    Yup - Triple crossfirex here (5970 + 5870) and BFBC2 is broken - dips to 39-45 FPS vsynced.

    Before this, it was 60fps locked.

    Roll back time!
     
  3. Reciprocity

    Reciprocity Member Guru

    Messages:
    188
    Likes Received:
    6
    GPU:
    MSI RTX 3090 X Trio
    Well, based on what's being said about BC2, the same issue with Crossfire is there as was with the 10.6 beta.

    Honestly, I'm very disappointed to see this. With a game such as BC2, there's absolutely no reason to take two steps back like this after finally having sorted out all of those awful problems that plagued it around it's release.

    I can't particularly complain about the 10.5a's that I'm running right now, so I'm not really losing anything by not installing 10.6 and I'm sure there are plenty of other games that I don't play that probably do see a marked improvement, but ATI's QA really should be better than that. My guess is that we'll see a 10.6a soon...
     
  4. PNeV

    PNeV Ancient Guru

    Messages:
    2,069
    Likes Received:
    2
    GPU:
    MSI GTX 1070 Armor
    Wow, the AMD site is getting hammered at the moment. Are these drivers available for us we Mobility users, I can't get on the site.
     

  5. Cronik

    Cronik Maha Guru

    Messages:
    1,268
    Likes Received:
    104
    GPU:
    Nvidia GTX 1080
    NICE gonna give these a shot, theres 180 people viewing this section O_O.
     
  6. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    What are these drivers like for none x-fire users ?

    I'm about to put my 5870 2gb back in my rig and don't know what driver to use
    I'm mainly concerned with BC2 performance.

    10.4/10.5/10.6 ???
     
  7. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    Something that's always confused me, being relatively new to ATI cards, is that I currently have the Video Converter installed in the CCC from an earlier driver set but it has never been updated. I see that ATI offer a separate Hydravision and Avivo Video Converter download but the latter states it's for HD 2000, HD 3000 and HD 4000 cards only.

    My question is does Avivo Video Converter work on the HD 5870 or not? Is it just that ATI haven't updated the text?
     
  8. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    10.6 will be good, it is just the BC2 profile broken wont effect single setups.
     
  9. mmsandi

    mmsandi Master Guru

    Messages:
    356
    Likes Received:
    0
    GPU:
    5850
    something is wrong with windows 7 x 64 link on the amd site
     
  10. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    It does work, I downloaded the updated one and it detected the old one I had installed and updated it.
     

  11. BrainDedd

    BrainDedd Master Guru

    Messages:
    210
    Likes Received:
    7
    GPU:
    ASUS Strix 1070 OC
    Gained 0.1 in my Windows 7 Graphics and Gaming Graphics score with these :)

    Avivo works with 5870, but doesn't run any faster than the 4000 series.
     
  12. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    Thanks for the replies.

    I've just updated the Avivo Video Converter. I think I'll have to tell ATI to update the text description to include 'HD 5000 series' too as the current one is misleading.

    Has anyone noticed that the Application Profiles, now the site is back up and running, are dated 7th June? I'm pretty sure they were 16th June when I downloaded them originally, before the site was totally messed up. :3eyes:
     
  13. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    Just to add that the 10.6 beta fixes for Red Faction Guerrilla (CrossFireX flickering gone but nasty grass slowdown bug in Oasis is still there alas) and Just Cause 2 (the game no longer refuses to start fullscreen) are present and correct in the WHQL drivers. I was worried that they'd be missing.
     
  14. Covert

    Covert Maha Guru

    Messages:
    1,187
    Likes Received:
    0
    GPU:
    Asus HD 5770 1000/1300
    OMG non of my video settings seem to work, ive tried em with gom player and Media Player Classic - Home Cinema the only seetting thats does anything is gamma.

    do i need to update Avivo or is that nothing to do with it ?
     
  15. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,590
    Likes Received:
    422
    GPU:
    MSI 5600XT G. MX
    Yes, they never updated the description. Lol

    And yes again, they where dated 16th June and now 7 xD
    What a mess, lol

    On Gom Player, those will never work, because it doesn't use Ati Stream.
    In Media Player Classic, you have to configure it to work on DXVA
     

  16. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    You guys are right, CrossFire not working correctly in Bad Company 2.

    My X2 is showing 80% load in GPU1 and 40% load on GPU2. And I'm getting crappy framerates in the game.
     
  17. Pey

    Pey Master Guru

    Messages:
    710
    Likes Received:
    11
    GPU:
    ASUS GTX 980 STRIX @ SLI
    "Grass and crops are no longer rendered ramdoly at unusual locations in bad company 2 game scenes"

    Finally!
     
  18. Kohlendioxidus

    Kohlendioxidus Maha Guru

    Messages:
    1,398
    Likes Received:
    12
    GPU:
    Sapphire Vega 56 Pu
    here you go:) (1920x1200, AA8x,All on High, DOF, Dx10.1)

    in menu:
    [​IMG]
    in game:
    [​IMG]
     
  19. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    What a star! Thanks, Kohlendioxidus. So something is wrong on my system?

    Re: the new application profiles. I'm not 100% sure but I think ATI have taken down the new ones and replaced them with the 10.5 ones from May with a new date. The reason I suspect this is that I redownloaded them and uninstalled the one that was dated 6/16/2010. However, when I check the Program and Features control panel they have the older version number from last month, v2.0.3790, whereas I'm positive the ones posted on the ATI site earlier this evening were v2.0.38xx.

    Can anyone else confirm this?
     
  20. cowman

    cowman Guest

    Anyone tried these with a 5770 with BC2?? I'm currently running the 10.4a drivers and was curious if these give performance increases with the 5770!
     

Share This Page