ATi Catalyst 10.6

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Jun 16, 2010.

Tags:
  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,016
    Likes Received:
    531
    GPU:
    EVGA GTX 1080 Ti SC2
    CrossFireX is not broken here though... it seems to be working fine for all my games bar Saints Row 2 and Blur so I suspect it has been disabled for those as both games have serious issues when using both cards. I tested Star Wars: The Force Unleashed, Mass Effect 2, Batman: Arkham Asylum, GTA: Episodes from Liberty City, Just Cause 2, Oblivion, Red Faction Guerrilla and Battlefield: Bad Company 2 and all of them work fine with CrossFireX (although the latter has weird framerate drops in the menus for some reason).

    *EDIT*
    There's definitely something a bit not-quite-right about these drivers. Just loaded up Call of Duty: Modern Warfare 2, which has v-sync on, and I noticed that just before the game starts there's the same weird framerate drop to 1 fps in the loading screen just before the game starts that BFBC2 had. Then when the game starts it shows 40 fps before jumping to 60 fps and staying there. I tested without v-sync and the framerate on the same level (oil rig) was 330 fps (and 1,000 fps in the menus!!!) so there's no way it should ever have been as low as 40 fps. Maybe it has always been like that and I've just never noticed it before (i.e. I'm getting paranoid because of all the negativity towards these drivers)?

    Is this what people mean by CrossFireX not working, i.e. it *is* working but just not as smoothly as before?
     
    Last edited: Jun 23, 2010
  2. amieneel

    amieneel Master Guru

    Messages:
    896
    Likes Received:
    0
    GPU:
    XFX 5770 + 240 GT PhysX
    With 10.6 ????? :eek: .. R u sure ?? ( at least i found someone who had no problem with 10.6 ) .. !!
     
  3. Kanemura

    Kanemura Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    ATI Radeon HD5770 1GB
    Yes absolutely, even Fallout 3 is working great again now, and I'm back to solid constant 60fps in WoW again (was dipping to 25ish fps with the last set, wtf!). I only have one card, so perhaps all the issues come in with the crossfire users. Not sure. But at least in my personal experience, this set is far better than the last few for me.

    I should mention that I do indeed uninstall and reinstall the proper way, leaving no traces of previous sets behind...so I cannot explain why the last couple of sets worked like crap for me but the 10.6 is working great.
     
  4. asder00

    asder00 Don Di Driver Staff Member

    Messages:
    1,193
    Likes Received:
    2
    GPU:
    RX VEGA 64 Liquid
    New application profiles released:

    ATI Catalyst 10.6 Application Profiles June 23

    BF:BC2 Crossfire Fixes:

    "Thanks to Rage3D and its members we were notified that some maps were not being optimized for best performance in our previous CAP.
    As such we are updating it today.
    We will monitor your feedback for any further areas of improvement”
    -Terry Makedon
     

  5. Ourasi

    Ourasi Master Guru

    Messages:
    294
    Likes Received:
    7
    GPU:
    MSI RX 480 Gaming X 8GB
    Link to new Application Profile: http://www.rage3d.com/xmp/

    Here are my findings with this new 23. of June Application Profile on BF:BC2 using FRAPS:

    1. The InGame FPS: (I have pretty good knoweledge about previous drivers and their performance, so they do reflect the ~truth) They have now managed to pull out the same or even a tad better performance compared to 10.4a/10.5a on my HD5970. My short walkthru on Isla Innocentes scored 152 FPS on 10.6 with this profile, and scored 115 FPS with Approfile from the 18th. and a meager 46 FPS with the Approfile we first was presented with, this final result at 152 FPS compared to 146 FPS using 10.4/10.5, ends it on a positive note for ATI's driverteam. Well done and way to go ATI and at the same time proving the significanse of the approfiles and the seperation from the driver..

    2. The Menu FPS: Double or even tripple the performance here, again cudos for the tremeduos work ATI...

    3. The LoadTimes: Here we see no change, and still abit behind 10.4a/10.5a, tested on SLC Enterprice SSD's in Raid0, so what I can measure and notice, might not be detected on mere common storage setups.

    4. LoadScreen FPS: No change, still down to single digits FPS, and far, oh so far behind 10.4a/10.5a that it is hard to count that high this late, certainly related to LoadTimes, and seems to follow each other, and is a minor annoyance..

    5. HardCore Grey SpawnScreen FPS: No change, still single digit or low teens FPS, related to #3 and #4, and still a drag to select squad and change weap when grey spawnscreen is present..

    Conclution: Still a bit to sort out, but InGame FPS and Menu FPS or combined, is as good as or even better then before on the best drivers for BF:BC2 espesially the InGame FPS, and 10.6 with Application Profile released 23. of June sertainly is looking better, and now rank among the best drivers for this game. If you can live with the #3-5 annoyances, you are in for a treat FPS wise..
     
    Last edited: Jun 24, 2010
  6. psychok9

    psychok9 Master Guru

    Messages:
    319
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    Someone know if Catalyst 10.xx releases improve or downgrade DirectX9 performance with game like World of Warcraft?
    Any review to bencharm this games?
     
  7. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    WoW it's very CPU dependant, I don't think drivers will help if any with that game

    Any other DX9 game can or cannot get improvements.
     
  8. ProfBP

    ProfBP Maha Guru

    Messages:
    1,339
    Likes Received:
    5
    GPU:
    EVGA 1080GTX
    Drivers work, YEAH!

    Vsync still stuck on for DirectX games, BOO!
     
  9. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    crap, going back to 10.4
     
  10. jskyg

    jskyg Master Guru

    Messages:
    434
    Likes Received:
    0
    GPU:
    powercolor 5850@775/1125
    I had lock up issues in WoW, no other problems that I noticed,but my pc never gives me trouble so it was definitely the drivers or driver/software conflict.
     

  11. psychok9

    psychok9 Master Guru

    Messages:
    319
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G

    All say this, and maybe it's near the true, but with 8800 GT > 5850@840Mhz change, i get more fps on raiding.

    You get lock up? The game close unexpectedly or... ?
     
    Last edited: Jun 25, 2010
  12. jskyg

    jskyg Master Guru

    Messages:
    434
    Likes Received:
    0
    GPU:
    powercolor 5850@775/1125
    no it just froze, I had to ctrl, alt, delete, out of it.

    BTW the 10.5's own WoW, I get no less than 36 fps in dal when it's packed,
    normally it's in the 80+ range.
    the one setting that screws ATI cards are shadows, in wotlk beta the game ran great with max shadows.
    the last patch before public release neutered ATI performance with shadows, I just set it at the second to lowest notch and everything else maxed.
     
    Last edited: Jun 25, 2010
  13. amarios

    amarios Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD 7970
    Got everything maxed and WoW is running great for me with these drivers. :p
     
  14. psychok9

    psychok9 Master Guru

    Messages:
    319
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    ...and you terminate process? Very strange. Are you sure that isn't cpu overclock problem?

    Blizzard know it? Maybe on wotlk beta the shadows was bugged?
    Usually i set to 4/5, but on raiding i lower some settings because i want max dps (shadow to zero, spell effects to 1/2).
    thank you!
     
  15. wonton1017

    wonton1017 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    2x Galaxy GTX670 SLI
    For some reason, these drivers keep failing on me.
    Everything successfully installs, but display driver keeps on failing no matter what i do:
    - restart
    - uninstall -> driver sweeper -> ccleaner -> repeat in safe mode
    - enable/disable auto driver install after reboot

    All other drivers install perfectly fine:
    10.1 -> 10.5
     

  16. DaShoota

    DaShoota Master Guru

    Messages:
    470
    Likes Received:
    0
    GPU:
    ATi Radeon HD4850
    Can someone help me? I installed these new drivers and they changed some of the colors of my programs. See before and after pics below:

    Windows Photo Viewer: (the white parts turned into light brown)
    http://img64.imageshack.us/slideshow/webplayer.php?id=colorsafter.png

    Notice the light blues become darker.

    This is also messing up the colors in photoshop when I try to do some work.

    Anyone know how I can fix this?

    NVM fixed it
    http://social.technet.microsoft.com/Forums/en/w7itproui/thread/77a6c9ab-3411-44f4-9c30-85cbe8e694fe
     
    Last edited: Jun 25, 2010
  17. jskyg

    jskyg Master Guru

    Messages:
    434
    Likes Received:
    0
    GPU:
    powercolor 5850@775/1125
    I may have jumped the gun before the driver could reset, but it happened twice, never happened before 10.6 so that's all I needed to go back to 10.5.
    10.5's are good solid drivers, I don't mind waiting until 10.7.


    I can run max shadows no problem but the performance impact is not worth the minor difference it makes, but in the beta max shadows barely had any impact on performance and this with with a hd4870.
     
    Last edited: Jun 25, 2010
  18. Svein_Skogen

    Svein_Skogen Maha Guru

    Messages:
    1,230
    Likes Received:
    0
    GPU:
    2x GTX570, ASUS+eVGA
    After some extensive testing, it seems that the 10.6 drivers (as opposed to the 10.5 ones) do some stupid cache-trashing on my Q9400 cpu (basically adding latency for all memory transfers), giving a cpu choke-point for "stuff" (with taskmanager seeming to say "but no cores are above 50% utilized"). I'll examine this a little more to see if it's just address-randomization that messes up, or if it's the drivers that are doing something odd.

    It means severe choking in games like UT3, btw.

    //Svein
     
  19. SureFireT1000

    SureFireT1000 Member Guru

    Messages:
    162
    Likes Received:
    0
    GPU:
    TRI-FIRE 5970+5870
    Ok so After finally hanging in with these drivers for about 1 more week, I have decided to let them go and now back at 10.5.

    I got so tired and annoyed of black screens while playing battlefield badcompany 2. I mean come on, seriously !!!!! If the screen is black you will get $%^#%$^ because you have no idea what is going on. I got knifed many times because of this...


    Moving on... Positive note vantage scores went up... but i do not stare at vantage all day...

    So final verdict these drives have problems as many have mentioned. 10.5 is much more stable for BFBC2 !!! At least for me that is.

    Anyone test Metro 2033 how was the FPS on that with 10.6 ? any change for better or worse ?
     
  20. olapaulakoski

    olapaulakoski Master Guru

    Messages:
    280
    Likes Received:
    0
    GPU:
    msi hawk 5770 1 gb
    Great driver

    Best ati driver since last year. Damn, im going to put these on a cd if i loose them. Performance and lots of other improvements no more flickering textures i Fallout 3. Seems to work perfect with my card.:)

    /Ola
     

Share This Page