1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ATi Catalyst 10.4 Official

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Apr 28, 2010.

Tags:
  1. nospec

    nospec New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    ATI GeCube 4770 512MB
    help, i play cabal with 10.3 driver and everything is normal
    today, i try 10.4 driver and all of my interface in that game is gone...
    what's wrong ???
     
  2. _REAPER_

    _REAPER_ Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    EVGA 580 Classified Ultra
    10.4 CCC not showing 5870

    I had issues with Trifire on the 10.4 ati release I dont know why but CCC would not recognize my 5870 just my 5970 any suggestions
     
  3. Rootax

    Rootax Member Guru

    Messages:
    129
    Likes Received:
    9
    GPU:
    Vega FE 1.6ghz /WC
    They say 2d performances are fixed. Can somebody confirm this ?

    Thx.
     
  4. ezodagrom

    ezodagrom Master Guru

    Messages:
    587
    Likes Received:
    43
    GPU:
    MSI GTX 1660 Ti 6GB
    Only the 2nd 10.4 preview fixed the load times for the HD4000 series. The 1st 10.4 preview and 10.4 WHQL only fixed the load times for the HD5000 series.
     

  5. Dublin_Gunner

    Dublin_Gunner Ancient Guru

    Messages:
    4,642
    Likes Received:
    0
    GPU:
    Gigabyte Rx 460 4GB
    It was the second 10.4 preview I had installed.
     
  6. Phalkon30

    Phalkon30 Ancient Guru

    Messages:
    1,529
    Likes Received:
    0
    GPU:
    Leadtek 6800 GT @ 420x1175 /water
    As someone who mainly uses an ATI card for media playback, I have a question. The release notes mention that there is hardware playback support for H.264, what does this include? From what I remember .mkv files generally contain H.264 (or was that x.264?).

    Either way, what files will this new hardware playback support?
     
  7. scorpeeon

    scorpeeon Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    ATI Mobility/HD 4670/1 GB
    there's hw support for h.264 since many years (L4.1 and below). the addition in this driver is the L5.1 support which is part of the h.264 videos.. yeah, mkv's are usually x264 which contain h.264.
    read here
     
  8. Phalkon30

    Phalkon30 Ancient Guru

    Messages:
    1,529
    Likes Received:
    0
    GPU:
    Leadtek 6800 GT @ 420x1175 /water
    Thanks for the good guide and the concise answer, will have to try that!
     
  9. steelcowboy

    steelcowboy Member Guru

    Messages:
    132
    Likes Received:
    0
    GPU:
    EVGA GTX 570's SLI
    Getting 2 d crashes black screen and white screen after going to 10.4 went back to 10.3 and all is well?5970 btw
     
  10. stormy

    stormy Ancient Guru

    Messages:
    2,579
    Likes Received:
    16
    GPU:
    Gigabyte RX 570
    Same here with my 4830 until I installed the last Profile update,

    http://www.rage3d.com/xmp/

    Doesn't say it there, but took both for my load times to be fixed.
     

  11. ross

    ross Master Guru

    Messages:
    718
    Likes Received:
    0
    GPU:
    Diamond R9 290X 4GB
    Oh and steve-,

    I guess I do read much. I did try the 10.4 preview when it was released for the HD 4000 series... but performance is worse than 10.3 even though load times are faster in Bad Company 2.

    So steve- You are god and I will never be able to have the wisdom you do. It would be one thing to simply be friendly and tell me to give the 10.4 preview drivers a shot but instead you choose to make a comment like that.

    ^^^^^ - From BFBC 2 fix for HD4000 series TODAY on 4-21-10
     
  12. saif

    saif Master Guru

    Messages:
    656
    Likes Received:
    1
    GPU:
    Sapphire R9 280X DualX OC
    wait, you say the current official 10.4 doesnt fix it for 4000 series? can you please point me to the 2nd Preview drivers? as I dont know which of the available ones is.

    Thanks
     
  13. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,245
    Likes Received:
    423
    GPU:
    MSI 2070S X-Trio
  14. saif

    saif Master Guru

    Messages:
    656
    Likes Received:
    1
    GPU:
    Sapphire R9 280X DualX OC
    Oh, I tried those, they were the ones didnt load the CCC for me, and threw me some errors during installation. Gonna try again I guess

    edit: it seems they work now, perhaps they required 10.4 installed before, and not over the 10.3 or clean installation (also, I just read that they have "hotfix" word on them, so was it a patch?)

    doesnt matter, gonna try them
     
    Last edited: Apr 29, 2010
  15. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,245
    Likes Received:
    423
    GPU:
    MSI 2070S X-Trio
    Just noticed thats another updated set, as they are dated the 27th (2 days ago), and have some Splinter Cell Conviction fixes.
     

  16. Usl

    Usl Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    Gigabyte HD5870
    With me work's fine.
     
  17. saif

    saif Master Guru

    Messages:
    656
    Likes Received:
    1
    GPU:
    Sapphire R9 280X DualX OC
    true, and they have the exact same name. I had a hotfix downloaded april 25, and these date 27, so gonna redownload
     
    Last edited: Apr 29, 2010
  18. geogan

    geogan Master Guru

    Messages:
    371
    Likes Received:
    14
    GPU:
    Gigabyte GTX 1070
    Toms2D v1.04 - Radeon 5970 (i920)

    Direct
    10.3 - 2422
    10.4 - 2437

    DIB buffered
    10.3 - 2826
    10.4 - 2789

    For comparison - 9800GX2 in same machine:

    Direct - 1964
    DIB - 2444

    Doesn't look like any improvement to me according to those tests...in fact the buffered drawing is worse overall?!? Also can't understand why the buffered is not much better than the direct compared to the diffferences for the GX2...
     
  19. ermasta

    ermasta New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire/5750/1 g
    Well loading times are not fixed with this set of drivers.....


    damn 5750 !!!!
     
  20. DarkQuark

    DarkQuark Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    AMD RX480 8GB
    WTF is this?

    Anyone notice this after going to these? Windows 3d experience dropped to 6.0 from 7.5.

    Does not mean much really just annoying. Never saw this with Nvidia.
     

Share This Page