ATI Catalyst™ 8.12 Display Drivers officially out

Discussion in 'Videocards - AMD Radeon Drivers Section' started by BitStream, Dec 10, 2008.

  1. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
    Can't force AA in what games? There are some engines that simply cannot have AA applied to them as it breaks something else. The drivers will struggle to pass WHQL certification if they are known to cause problems with games, so forcing AA is disabled at driver level for that particular game. This is a Microsoft requirement and its not exclusive to ATI.......GTA 4 is a good example as neither Nvidia and ATI can force AA in that title.

    I'm confused as whether that could be described as gay or not, so I'll leave that to you.
     
  2. Stukov

    Stukov Ancient Guru

    Messages:
    4,899
    Likes Received:
    0
    GPU:
    6970/4870X2 (both dead)
    I don't know if you thought I was doing this, but I only responded to those who claimed CF was broken, as in for everyone. I also believe I included a list of what worked for me for others to test.
     
  3. reggis

    reggis Active Member

    Messages:
    63
    Likes Received:
    0
    GPU:
    4870x2 and 4870 crossfire
    I have two crossfire systems -- Here is my experience w/8.12:

    d975xbx - c2s 6800 2x3870s in crossfire - vista x64
    8.12 install over 8.11 - no issues, no reboot. It just works :).

    asus x58 i7 940 - 4870x2 + 4870 in crossfire - vista x64
    8.12 install over 8.11 -- one core install, two cores with ! (code 43)- no crossfire
    8.12 install over 8.11 hotfix -- same as above
    clean install (image of vista before gpu driver install) - same as above
    Install 8.12 - manual install of drivers -- ccc report four cores instead of 3 - no crossfire
    Install 8.12 - manual install of drivers in safe mode -- same as above

    So ... uninstalled 8.12 - rebooted - install 8.11 hotfix - all three cores - crossfire goodness

    Will try any reasonable suggestions for getting 8.12 to work on my x58 :)

    Score for me on 8.12 -- 1 for 2
     
  4. chispy

    chispy Ancient Guru

    Messages:
    9,027
    Likes Received:
    1,273
    GPU:
    RX 6900xt / RTX3090
    Yeah , seems that the problems are directly related to X58 chispset :(
     

  5. Korvin77

    Korvin77 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    4850 Palit Sonic 512
    catalyst_812_release_notes:
    Known Issues Under the Windows XP
    The following section provides a summary of open issues that may be experienced
    under the Windows XP operating system in the latest version of Catalyst™. These
    include:
    • Catalyst Control Center, the deinterlacing option under AVIVO video is not
    available after returning from VPU recovery
    • Video corruption may be noticed during certain MPEG-2 file playback
    • Playing some Blu-ray HD titles on multi head displays may cause the system
    to stop responding
    • Previous transcoders may cause the ATI AVIVO Video Converter to not use
    the GPU for trancodiing
    • Transcoding multiple times may cause the ATI AVIVO Converter to not use
    the GPU :puke2:
     
  6. Bornakiller

    Bornakiller Master Guru

    Messages:
    418
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SLI
    After installing the latest driver fallout 3 gets worse!!

    WTF!!!


    [​IMG]
     
  7. Knutselmaaster

    Knutselmaaster Active Member

    Messages:
    76
    Likes Received:
    0
    GPU:
    AMD6870 xfire
    I believe some people have misinterpreted my previous post.
    What i said (or ment to say, when i read back it does but maybe for other people it doesn't):
    Try installing drivers the "normal" way, especially if you don't know exactly what all driversweeper & co programs are for.
    If you have problems after that, and you never messed with your system, yes then there is a problem with the driver, it should work like that because it was designed to do so.
    Now in case of problems you should try the same thing again, for example when installing 8.11 on my system, the driver worked but the ccc wouldn't open. I redid the normal uninstall, reboot, install, reboot and all problems where gone.
    If there are still problems, and only then, use one of the driver cleanup programs to try getting rid of leftovers that cause troubles.
    People who use driver cleanup programs from the beginning, are often ignorant of the function of such programs and their proper usage. (like use them even without uninstalling the old driver first, or without reboot, or not sweeping in safe mode etc)
    Those people, who don't know why and what they are doing but just see a post here or there on the net with a downloadlink and some text like "it did wonders for me" and thus use programs they don't need or don't know or don't understand etc, and then have troubles afterwards and come flaming an entire enterprise in a forum, i call noobs and ignorant.
    Because there are so many different hardware and software combinations possible in pc's, it's impossible for a driver programmer to test their driver on all possible combinations and so there will allways be posibilities of problems, that's inevitable (wow i used "possible" a lot there)
    So no, all people with problems aren't noobs, and yes it can be that the 8.12 is a buggy driver and i'm just lucky to have it working.
    But please, don't blame ATI (or any other manufacturer that releases drivers) of producing bad products if you haven't at least used their stuff the way it is ment to be used.

    I hope to be more clear and less offensive, my apologies for all unnessesairy rise of bloodpreasure i caused,

    Knutsel
     
  8. sykozis

    sykozis Ancient Guru

    Messages:
    21,870
    Likes Received:
    1,081
    GPU:
    MSI RX5700
    Some people have had to install the drivers more than once to get them working. Seems to be a lot of complaints from X58 chipset users as well. Guess everyone will have to wait for 9.1 to see if that problem gets fixed....or try to the patch that was released for the X58 chipset users...
     
  9. G-lad21

    G-lad21 Master Guru

    Messages:
    270
    Likes Received:
    0
    GPU:
    EVGA 1070@ACX3.0
    i got issues with nba2k9..black curves and vibrations...and fps with gtaiv...post your scores
     
  10. Im2bad

    Im2bad Master Guru

    Messages:
    791
    Likes Received:
    0
    GPU:
    3080 Gaming X Trio
    I haven't used driversweeper to clean my computer of old ATI drivers, I just let the installer install the new drivers on top of the old ones and everything has always worked okay. Well, there was that one time the install froze but I think it was because I uninstalled the old drivers before installing the new ones.

    8.12 installed okay too, no problems, didn't even have to reboot(I think it's become standard since 8.11?) and it also kept my overlock. :D
     

  11. kalispimenta

    kalispimenta Member Guru

    Messages:
    121
    Likes Received:
    0
    GPU:
    EVGA 8800GTX @680X1030MHZ
    Just trowing ideas out there ,do the people with no problems run xp or vista 32 or 64 bit? Does anyone have have sp2 installed in vista?
    X58 owners what bios do you have?
    Mobo drivers?
     
  12. TDurden

    TDurden Ancient Guru

    Messages:
    1,981
    Likes Received:
    3
    GPU:
    Sapphire R9 390 Nitro
    any news on the device manager error 43 and not working card yet?
    vista 64 sp1
    asus p5e with x38(same as x48 actually; driver version 9.0.0.1008 - the newest from intel.com; asus site has older version <- have not tried it); bios version 1003(the newest, also tried with 0702)
    8gb ram
    x-fi
    e8200

    maybe we could find some commonalities
     
  13. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,739
    Likes Received:
    1,022
    GPU:
    6800XT Nitro+ SE
    All good here. X58 chipset, the drivers installed perfectly with a quick driver sweeper in safe mode which cleaned out RC3 drivers. Crossfire works, All my games seem smoother and Far Cry 2 is amazing, it doesn't stutter in DX10 mode anymore. Great Drivers!! Keepers for me :D
     
  14. Khan

    Khan Master Guru

    Messages:
    276
    Likes Received:
    0
    GPU:
    HIS ATI 4870 X2
    Incidentally, these have been the most solid drivers for me yet. Uninstall Cat 8.11, reboot, install 8.12, reboot, done.

    Got rid of some PoP / 3dMark vantage issues as well.
     
  15. MMXMMX

    MMXMMX Member Guru

    Messages:
    175
    Likes Received:
    21
    GPU:
    Asus Tuf RTX 3090
    Not whql ?????
     

  16. InfDaMarvel

    InfDaMarvel Ancient Guru

    Messages:
    3,218
    Likes Received:
    0
    GPU:
    HD3850 256mb
    1.ATI Uninstall Utility
    2.Do no reboot
    3.Driver Sweeper
    4.Reboot
    5.Install 8.12

    With those steps it has been working fine for me.
     
  17. Adalwar

    Adalwar Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    Powerc HD3850 AGP DDR3
    So far the tests I have done , the 8.12 are very stable and no problems at all.
    I see there some people with Install issues and I would like to share here how I install ATI Drivers.
    1- Control Panel> Add/Remove programs
    2- Reboot in Safe Mode
    3- Driver Cleaner- Clean all ATI Stuff
    4- Reboot and
    PRESS F8, THEN FROM WINDOWS BOOT MENU, CHOICE
    - VGA MODE
    5- Install ATI normal.
    I never had issues with ATI, only at a time there was a error "MOM.Implementation" but that is solved since long time now.
    I use ATI since the time of 9800Pro and I am quite satisfied with their Drivers.
     
  18. B.B.

    B.B. Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Asus 1060 6gb
    Running 8.12 on vista64 and I can't seem to enable ATI overdriver, it's always grayed out. Is this a known problem or done by design in the latest driver?

    I never used the overdrive feature before, but I'm just a little worried that this might not be all and this might be the result of something else... anyone can help me?

    ...and one other little thing, how to I check that both gpus are working and not just one? Thanks.
     
    Last edited: Dec 11, 2008
  19. Pura.

    Pura. Active Member

    Messages:
    76
    Likes Received:
    0
    GPU:
    EVGA 780ti
    Well installed 8.12 yesterday ... on vista 64 played Crysis, COD5, Dead Space , Far Cry 2 without problems !

    as for performance... i cant really see any diference....only in COD5 there is a little more image quality ...

    Best thing about these drivers is , that i got a bit cooling performance ....my MSI 4870 x2 got about -5c in IDLE ... dont know how... but checked it with 8.11 and 8.12 and its really -5c :)

    as for me.. im staying with 8.12 ...
     
  20. bretware

    bretware Master Guru

    Messages:
    297
    Likes Received:
    0
    GPU:
    Two ATI 6850's
    I have seen all the install issues with CCC listed here in almost every version, everytime I have run the update it has kicked the driver upon restart. It shouldn't be ATI's driver, too many people can install it without problems.
    It's been a fight to get the system stable again but here's what works for me.

    1. Unstall the driver from device manager, I use have vista and I check the box "delete driver software" box
    2. Run the CCC unstall program.
    3. Run Regedit, delete both of ATI's folders under "local machine/software"
    4. Restart
    5. Manualy install video driver
    6. Run CCC install program
    7. Restart
    8. Cross fingers, toes and anything else you can find

    Good Luck
    Bretware
     

Share This Page