ATI/AMD's new Morphological Anti-aliasing

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Darren Hodgson, Oct 22, 2010.

  1. Olorin

    Olorin Maha Guru

    Messages:
    1,076
    Likes Received:
    3
    GPU:
    MSI Armour OC GTX1060 6GB
    Sorry, read the thread, nevermind. :)
     
  2. Olorin

    Olorin Maha Guru

    Messages:
    1,076
    Likes Received:
    3
    GPU:
    MSI Armour OC GTX1060 6GB
    I see that MLAA does give noticeable improvements on games without AA support but there are still quite a bit jaggies present. In NFS Hot Pursuit, it's still pretty bad.
     
  3. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    No if you've already got 10.12 installed do this

    Just tested and works 100%
     
  4. Olorin

    Olorin Maha Guru

    Messages:
    1,076
    Likes Received:
    3
    GPU:
    MSI Armour OC GTX1060 6GB
    Thanks for testing ! Appreciate it. Sorry again for not reading the thread first before asking questions.
     

  5. Dmented

    Dmented Master Guru

    Messages:
    391
    Likes Received:
    0
    GPU:
    ASUS GTX 1080 ROG Strix
    How do you find out if it's working or not? I haven't used MLAA yet.
     
  6. ajkmetiuk

    ajkmetiuk Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    XFX HD5830 1GB
    help guys, i try to enable the mlaa here, but no works :(
    i tried clean the registry with driver sweeper and use the modded 10.12 + ccc2 but the option don't show
    tried modify the reg key MLF_NA to 0, but no works...
    anyone tried anything else?
    thx
     
  7. maco07

    maco07 Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    7970 3GB Boost
    I think registry trick is just to activate or deactivate MLAA. Not to add MLAA option inside CCC.
     
  8. ajkmetiuk

    ajkmetiuk Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    XFX HD5830 1GB
    ok, but how do I know if it is activated?

    -- forget it, I got :) --
    i put in advanced quality and works
    thx
    (mlaa + aa8x is a great filter)
    [​IMG]
     
    Last edited: Dec 15, 2010
  9. gx-x

    gx-x Maha Guru

    Messages:
    1,482
    Likes Received:
    149
    GPU:
    1070Ti Phoenix
    download RadeonPro, uninstall ccc/ccc2 and you are good to go. You have all options unlocked there. :p
     
  10. chanw4

    chanw4 Ancient Guru

    Messages:
    2,356
    Likes Received:
    26
    GPU:
    Sapphire R9 280
    last time I check, RadeonPro doesn't deal with monitor, video AVIVO?, Eyefinity etc. setiing
     

  11. Kohlendioxidus

    Kohlendioxidus Maha Guru

    Messages:
    1,398
    Likes Received:
    12
    GPU:
    Sapphire Vega 56 Pu
    I still cannot activate MFAA. I made the reg trick, restart, but nothing changed: ANY IDEAS:bang:??

    [​IMG]
     
  12. SkelNonch

    SkelNonch Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    Vega 56
    Same here :bang:
     
  13. gx-x

    gx-x Maha Guru

    Messages:
    1,482
    Likes Received:
    149
    GPU:
    1070Ti Phoenix
    Sadly, you are correct. It just leaves default registry values for those things.

    Well, I have one monitor and sometimes TV and that works without CCC, it can be set in windows 7 CP.
    AVIVO used to mean VideoIn/VideoOut controls. I haven't seen video in for ages on any GPU, therefore I fail to see what it's function is since video out can be set via windows.

    monitor controls...best left alone otherwise you may get issues with pink and bad gamma ramps. I did at least.

    eyefinity...nice idea, works well for multi monitor setup, but then again, windows CP can do that also (on ATI). As for gaming, to each his own but I can't stand monitor borders all over the place. I'd rather buy HD LCD projector or 42" LCDTV than fiddle with 3/6 monitors. Not only it's cheaper, it is more pleasurable for me regarding viewing experience, power consumption, size and connectivity. Oh, and it's cheaper than 6 IPS monitors. MUCH cheaper. ;)

    but like I said, to each his own. Everyone has some individual preference.

    :wave:
     
  14. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,465
    Likes Received:
    2,855
    GPU:
    MSI 6800 "Vanilla"
    Strange results, based on the above screen perhaps try EQAA_NA to 0 and see if that appears at least, should be one of the new "enhanced" AA modes (Enhanced Quality AA.) for the 6000 series (Other being MLAA but that's also functional for ATI 5000 series though strangely not enabled by default even now after all those 10.10 hotfixes about it.) but basically works like MSAA with double the coverages or how it was described.

    Would give something to go on if that has some effect or it might be a more restrictive driver thing as that's the other way to make it compatible but needs a re-install to function.
    (Setting the registry entry and restarting CCC should be enough though but it's possible this might have been "tightened" a bit.)
     
  15. xXx_Fess_xXx

    xXx_Fess_xXx Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Hd5850
    SkelNonch and Kohlendioxidus just install RadeonPro. It will ask you to enable MLAA at 1st start. Then you can uninstall it
     

  16. gx-x

    gx-x Maha Guru

    Messages:
    1,482
    Likes Received:
    149
    GPU:
    1070Ti Phoenix
    you MUST restart your computer after installing modded drivers or doing reg hacks. It won't work until you restart.
     
  17. Olorin

    Olorin Maha Guru

    Messages:
    1,076
    Likes Received:
    3
    GPU:
    MSI Armour OC GTX1060 6GB
    Okay guys, please help me out. I just installed the latest 10.12 drivers. Rebooted. I ran regedit and modified MLF_NA value to 0. Rebooted again.

    Ran Catalyst menu and found no MLAA option in the 3D options. Have I done something wrong ? Why I am not able to see MLAA ?
     
  18. kazama

    kazama Master Guru

    Messages:
    309
    Likes Received:
    0
    GPU:
    MSI GTX 1080 X
    Can get the mlaa work with star craft 2, how you do it with radeon pro?
     
  19. gx-x

    gx-x Maha Guru

    Messages:
    1,482
    Likes Received:
    149
    GPU:
    1070Ti Phoenix
    just make a profile for the starcraft2.exe and check MLAA in the right pane.
     
  20. chanw4

    chanw4 Ancient Guru

    Messages:
    2,356
    Likes Received:
    26
    GPU:
    Sapphire R9 280
    There are more setting to change other than the MLAA_NA (for MLAA and surface texture optimization thinggie) if I remember correctly and you need to restart the services (or simply reboot) after change to take effect.

    Check the von-modded script via notepad and see what he changed and change it yourself. I used his script once (that is when they first introduce MLAA) but it end up not compatible with my computer somehow, then I just tweak the registry setting using his setting manually.
     

Share This Page