ATI/AMD's new Morphological Anti-aliasing

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Darren Hodgson, Oct 22, 2010.

  1. FDisk

    FDisk Master Guru

    Messages:
    766
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX970 OC 4GB
    I KNOW! This is the stupidest thing ever. CCC does not give you an option to turn Regular AA modes off. The slider starts with 2xAA and higher.
    Only way to turn it off is if you have the OFF option in game.
    But for some weird reason setting "Application Control" kills Triple buffering. :(
     
  2. pedropaulo

    pedropaulo Ancient Guru

    Messages:
    2,266
    Likes Received:
    79
    GPU:
    HD5850
    Meh i always use SSAA+Edge Detect and so far this seems to add bloom to the image, which is something i really hate.
    I like my games crisp and clear.

    And whats with MSAA, isĀ“nt it a worst IQ solution then SSAA?
     
  3. TheCapulet

    TheCapulet New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Sapphire 4850x2 512mb
    Pics please!
     
  4. Kinfa

    Kinfa Master Guru

    Messages:
    403
    Likes Received:
    1
    GPU:
    XFX RX580 8GB
    I can't get this to work! Did you modify two inf files and add registry entries or what? Can you explain whole procedure, please!
     

  5. kasper93

    kasper93 Member

    Messages:
    46
    Likes Received:
    1
    GPU:
    Radeon R9 390
    @Kinfa
    copy and save it in.txt or .reg and import to register.
    It modify reg values, same that are modified in .inf file.
    File should looks like this:
    Code:
    Windows Registry Editor Version 5.00
    ; MLAA for 5xxx 
    ; Made by Kasper93
    
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000]
    "MLF_NA"="0"
    "EnableUlps_NA"="0"
    "SurfaceFormatReplacements_NA"="0"
    "TFQ_NA"="0"
    "TextureLod_NA"="1"
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000\UMD]
    "MLF_DEF"="0"
    "EnableUlps_DEF"="0"
    "SurfaceFormatReplacements_DEF"="0"
    "TFQ_DEF"="1"
    "AntiAliasSamples_SET"= "0,2,4,8"
    "AntiAlias_DEF"="1"
    "AntiAliasSamples_DEF"="0"
    "AntiAliasMapping_SET"="0(0:0,1:0) 2(0:2,1:2) 4(0:4,1:4) 8(0:8,1:8,2:16)"
    
    also you can download that file http://www.mediafire.com/?jcatj2ld9cvpzip
     
  6. Mineria

    Mineria Ancient Guru

    Messages:
    4,323
    Likes Received:
    162
    GPU:
    Asus RTX 2080 Super
    {4D36E968-E325-11CE-BFC1-08002BE10318}
    That value might differ in your registry.
    Registry entry you quoted seems wrong too..
    Open regedit and find: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video
    You should see some keys look like
    {4D36E968-E325-11CE-BFC1-08002BE10318}, the numbers might differ.
    Expand them and look under Video, until you find one with Service value 'amdkmdap'
    Expand the '0000' section of that key and locate the string MLF_NA
    Edit it and set it to 0.
    Restart your CCC Runtime, option for that can be found in the shortcuts ATI added to start menu.
     
    Last edited: Oct 24, 2010
  7. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    I have 10.10Hotfix + MLAA setting

    So how do i activate Morph AA ,

    Do i need to put AA on 2x and not Application Control ? and in-game AA is off ofcourse.

    Thanks xD
     
    Last edited: Oct 24, 2010
  8. Bogdy2160

    Bogdy2160 Active Member

    Messages:
    52
    Likes Received:
    0
    GPU:
    MSI R9 380 Armor 2X
    its not working for me :( i tried everything,the drivers are 10.10a hotfix,if i modify MSF_AA to 0 on the two inf files it won't work,if i replace the inf files im geting an error ,:( can someone help me ,with team view ?
     
  9. perosmct

    perosmct Banned

    Messages:
    1,072
    Likes Received:
    0
    GPU:
    unknown
    attention to all of you...: new catalyst AI(texture filtering quality) with the three options, is intented/built for the stronger 68XX...the performance option is the best for 5XXX, because, it is the same with the previous catalyst AI(normal/advanced=no difference)...forget the catalyst ai quality and high quality it will blow up you performance...with not better quality, because, hd5xxx has lower quality AI and filters than 68xx...i benchmarked them...and the most stable and allround performer was "performance ai" and near it is "quality" option, get away from "high quality setting on AI"...
     
    Last edited: Oct 24, 2010
  10. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    You sure Performance and not only Quality ?
     

  11. Jakshi

    Jakshi Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    PoV GTX680@1300/3700
    To activate MLAA go to the all tab of the 3d settings, on the TOP theres the Anti-Aliasing part, both 'Use Application Settings' and 'Morphological Filtering' should be checked.

    @FDisk: MLAA alone doesn't kill Triple Buffering at all. As I said earlier it must be something on your side because I'm using MLAA alone in GTA IV and it works perfect vsynced with TB
     
  12. zeroeden

    zeroeden Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    HD5850 / XFX Black ed.
    well after some testing it seems that under some configurations the 10.10a hotfix simply refuses to install the display driver which in turn makes the "mod" impossible to implement...

    so far i think it has to do with the vista 64 + HD 5000 series combination but iam still not completely sure so... if anybody manages to get it working on vista 64 + HD 5000 series please say so.

    PS: There is no error message or anything like that you simply dont get the option to install the driver and manual installations are also not possible...
     
  13. perosmct

    perosmct Banned

    Messages:
    1,072
    Likes Received:
    0
    GPU:
    unknown
    yeap...i benchmarked...previous drivers and this new options...quality and high quality...were eating my fps...then on performance i had the same fps as with previous releases...:)
     
  14. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    And image , nothing Wrong or less about it ? cause image is terribly important, it gives at the right moment the best feel about specific times which you feel like In-The-Game i call it ITG fun xD

    EDIT: Guild Wars looks weird using A.I -Performance with MLAA alot jaggies. AAx2 looks better just alone.
     
    Last edited: Oct 24, 2010
  15. perosmct

    perosmct Banned

    Messages:
    1,072
    Likes Received:
    0
    GPU:
    unknown
    ok...even quality is ok near performance...just every 5xxx user should not touch high quality...
     

  16. german24

    german24 Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    MSI R9 270X GAMING
    Last edited: Oct 24, 2010
  17. zeroeden

    zeroeden Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    HD5850 / XFX Black ed.
    please do not forget that most of us are either using a workaround hacked driver or an offline postprocessing tool i expect the catalyst team to fully implement official MLAA by christmas on both 5000 and 6000 series...

    at the moment i think we should be happy that some at least got it "working" but as far as i know this is only a preview since its not even working under DX 10 and 11...

    EDIT:

    @german24 : well thanks for the help but your modded driver doesent seem to work either did you test it under vista 64?
     
    Last edited: Oct 24, 2010
  18. Kinfa

    Kinfa Master Guru

    Messages:
    403
    Likes Received:
    1
    GPU:
    XFX RX580 8GB
    OK,thanks, but I have already manualy changed all relevant registry values from 1 to 0 and now it works. Thanks to all of you guys.:)
     
  19. Kariddi

    Kariddi Active Member

    Messages:
    74
    Likes Received:
    0
    GPU:
    2x ATI 5850 Sapphire
    I made some tests on my system with Crysis (island benchmark @ 1920x1080 AA4x).

    With AF disabled with a Cross of 5850 @ 950/1300 I got the exact same results I had with 10.9a drivers (I gained 1 FPS to be honest)

    With AF forced at 16x in CCC and CatAI filtering at Quality I lose 2 FPS (from 61 FPS Average to 59), with CatAI filtering at High Quality I lose another 1.5 FPS (57.5 FPS).

    Nothing ground breaking here.
     
  20. zeroeden

    zeroeden Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    HD5850 / XFX Black ed.
    does anybody have some ingame screens on gta IV with mlaa? i heard you can use the standard print screen method as long as the game is running on a window (not really sure about this though)

    EDIT:

    @Kariddi have you alredy compared the AF IQ prior to 10.10a installation with the AF IQ high quality on 10.10a hotfix?
    If so.. do you have any screens? they would be very welcome :)
     
    Last edited: Oct 24, 2010

Share This Page