ATI 5870 - Only DirectX10 games NOT working

Discussion in 'Videocards - AMD Radeon' started by stojo, Dec 28, 2009.

  1. stojo

    stojo Active Member

    Messages:
    71
    Likes Received:
    0
    GPU:
    Asus Strix GTX 980 Ti
    Hello,

    first sorry for my bad english. I am from Germany.
    In October i bought a ATI Asus 5870 and since there i cant play games in Directx10 Modus.

    I had a GTX280 before and it worked perfect.

    So with my ATI 5870 my dx10 games are crashing.

    Crysis for example: When starting in dx9 mode no problems. can play fine.

    Crysis in dx10 freezes and crahses to desktop with flickering screens and artifacts.

    I tried a clean win7 os but nothing worked.
    Even tried hundreds of drivers, but nothing worked.

    Here are some examples with unigine benchmarks problems in dx11 mode:

    http://www.youtube.com/watch?v=vD-2voj6IjU

    http://www.youtube.com/watch?v=19KGHbsKw2I

    http://www.youtube.com/watch?v=2MRmO5PwgKc

    http://www.youtube.com/watch?v=6gIduUpyiJA


    So the thing is, only dx10 and dx11 don´t work.

    Anybody has the same problem or perhaps a solution for this?

    I even changed my CPU and RAM with new one, but nothing worked.

    Is my graphic card broken?

    My System:

    Win7 32 bit
    Intel Quad 9550 @ 3,4GhZ
    Gigabyte Mainboard P35-DS4
    ATI Asus 5870
    4 GB DDR2 OCZ-Reapers
    Creative Extreme Music x-fi
    PSU: Tagan 650 W

    I even tried to downclock the card with amdgputool, but it just helped making me playing some seconds longer before crashing again.

    I even set my bios cpu etc to standard, same probs.

    Hoping for help :)

    thx
     
  2. SaberJ2X

    SaberJ2X Ancient Guru

    Messages:
    2,538
    Likes Received:
    43
    GPU:
    Zotac 3080 OC
    RMA time!
     
  3. Chris Chiu

    Chris Chiu Active Member

    Messages:
    85
    Likes Received:
    0
    GPU:
    ATI 5970
    Driver version ? Have you installed DirectX August runtime/distribution ? I don't think your card needs RMA as it's run fine in DX9. Also all DX10 games with this problem ?
     
  4. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,559
    Likes Received:
    0
    GPU:
    XFire 7950 1200/1850
    I can't think of a hardware situation in which DX10 would fail but not DX9.

    This is definitely software.

    Update your DX to the Aug 2009 version.
     

  5. Squall Leonhart

    Squall Leonhart Banned

    Messages:
    1,331
    Likes Received:
    0
    GPU:
    Geforce GTX 275 896
    obtain the latest hotfix anduninstall the current drivers
    Run driver sweeper (with "run as admin" on Win7) and select the nvidia video and physx boxes, and clean these entirely.

    reboot, then install the downloaded ATI Hotfix drivers.
    if issues persist, make note of any overclocks on the system and reduce them to stock. a new video card may be more senstive to system overclocks then the previous nvidia card for instance.

    Also verify the XFI's drivers are upt to date.
     
  6. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    3,343
    Likes Received:
    764
    GPU:
    R9 290 Crossfire
    WEll he mentioned he did a clean install of windows seven.If this is correct,then all he needs to install is below to get games working proper,
    I do this all the time ,format main drive,have all games on usb drive
    dx 11 aug is fine
    openal
    gfwl
    physx

    This covers all games I have that are on usb drive.If I do not do it,games do not work.Thats what works for me.

    Now with only DX9 working and not DX10.Clean install was not done correctly,
    DX9,DX10,DX11 games should work,except Dirt 2 cause its messed up.

    Crysis is a game that is solid,until you start using some ****ed up CFG files that people make.
    Also for Crysis any OC that is not stable can cause it to crash.This includes CPU,GPU.
    My 2 cents.
     
  7. luv2increase

    luv2increase Master Guru

    Messages:
    236
    Likes Received:
    0
    GPU:
    GTX 480 - 800/1600/1900
    Agree with everything that you had said except for you saying Dirt 2 wouldn't work because it is messed up. I play Dirt 2 everyday on its very highest settings just fine. What did you mean?
     
  8. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    3,343
    Likes Received:
    764
    GPU:
    R9 290 Crossfire
    Last edited: Dec 28, 2009
  9. lenehan

    lenehan Member Guru

    Messages:
    119
    Likes Received:
    0
    GPU:
    Asus 7970 DirectCUII TOP
    gerardfraser, the link aint working.
     
  10. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    3,343
    Likes Received:
    764
    GPU:
    R9 290 Crossfire
    Fixed link,try it now
     

  11. stojo

    stojo Active Member

    Messages:
    71
    Likes Received:
    0
    GPU:
    Asus Strix GTX 980 Ti

    I tried every existing driver include hotfixes. Newest DirectX August Runtime is installed.

    I even made clean os three times.

    yes ALL dx9 games are running, but ALL dx10 games are crashing.

    i tried

    far cry 2 dx10 - crash

    anno1404 dx10 - crash

    crysis dx10 - crash

    hawx dx10 - crash

    dirt 2 dx11 - crash

    i did a clean os install again and let the games on usb drive, but same problems.

    in another forum i read about some guys, get it just running fine under vista. they had the same dx10 crashes like me with win7. but changing my os back to vista is not acceptable for me.

    but thank you very much for your answers.
     
    Last edited: Dec 28, 2009
  12. klanjsek

    klanjsek Active Member

    Messages:
    74
    Likes Received:
    0
    GPU:
    SAPPHIRE HD 5870 900/1250
    maybe i am completely of the bat, but how about calls to the HW that are dx10/11 specific...what if those were not functioning? just speculating....:newb:

    anyway, RMA your card...at least then you will know whether the card is to blame.
     
  13. stojo

    stojo Active Member

    Messages:
    71
    Likes Received:
    0
    GPU:
    Asus Strix GTX 980 Ti
    thank you all very much for posting your opinions.

    i will rma my card soon, so i will see what happen with the new one.

    but its really a strange problem, never heared before that dx9 is running fine in all games and dx10 and dx11 is defect and crashing. strange.

    i called the asus support hotline in germany and they told me they never heared about this problem before. hmmm....

    don´t know if i can believe that, but no one in any forum could help me yet.

    i´m really ****** angry :(
     
  14. Zareph

    Zareph Ancient Guru

    Messages:
    2,626
    Likes Received:
    0
    GPU:
    Sapphire NITRO+ RX480 4GB
    No. My HD5850 does not work in DX11. And it's a hardware issue; my friend's identical Sapphire HD5850 does work in DX11 in my PC, with the same drivers, etc. And I have tried everything.

    So his card not working in both DX10 and DX11 can indeed be a hardware fault.
     
  15. DSK

    DSK Banned

    Messages:
    17,917
    Likes Received:
    1
    GPU:
    HD5770/BenQ G2220HD
    My friend has 5850 is would run dx 9 and 10 but not 11.....

    Nvm ^^
     

  16. Memorian

    Memorian Ancient Guru

    Messages:
    3,293
    Likes Received:
    344
    GPU:
    RTX 3080 Ti
    Have you tried dx10 games without overclocking the cpu?
     
  17. Zareph

    Zareph Ancient Guru

    Messages:
    2,626
    Likes Received:
    0
    GPU:
    Sapphire NITRO+ RX480 4GB
    If it's in any way related to my issue, it's hardware related. No overclocking issue or anything similar. He'll need to RMA if that is the case; I'm about to RMA my own card as well.
    Gonna do it after new year, but already got the RMA form :)

    Well, actually just posted here to tell the OP that it may indeed be the card itself that's fubar, and also to diss any non-believers. Subscribers to my whine threads would know how much I tried just to get it working xD
     
  18. stojo

    stojo Active Member

    Messages:
    71
    Likes Received:
    0
    GPU:
    Asus Strix GTX 980 Ti
    yes i tried. i set the cpu clock and ram clock etc to standard, default.

    but same problems again.

    i think its really a hardware issue.

    and downclocking the gpu is giving me less issues(artefacting) but still crashes. and crashes. and crashes... only dx10 and dx11 for sure.
     
  19. Memorian

    Memorian Ancient Guru

    Messages:
    3,293
    Likes Received:
    344
    GPU:
    RTX 3080 Ti
    Then RMA that sh!t :)
     
  20. deaffob

    deaffob Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    XFX 5870 @ 900/1200
    those are artifacts. try these

    1. If you OCed, try @ stock
    2. If it still happens @ stock, use MSI afterburner to give more voltage to the stock
    3. Check your temps

    if these don't work, i guess it's RMA time.
     

Share This Page