Assassins Creed IV: Black Flags

Discussion in 'Games, Gaming & Game-demos' started by TirolokoRD, Feb 28, 2013.

  1. Carfax

    Carfax Ancient Guru

    Messages:
    2,913
    Likes Received:
    465
    GPU:
    NVidia Titan Xp
    Why do people keep repeating this fallacy? The game definitely uses multiple cores, I've verified this myself, as have multiple review sites.

    [​IMG]

    Personally I think the game is fairly well optimized, with the exception of the PhysX component, which was basically "glued" onto the game. I have it turned off and I love PhysX. The PhysX quality in this game is subpar however, because it wasn't planned from the inception and was obviously rushed. PhysX is always best when the game is built with it in mind, but AC IV already uses Havok for Physics.

    But if I can run the game with all settings maxed (PhysX turned off) at 2560x1440 and achieve 60 FPS with regularity, then it's not badly optimized..
     
  2. Redemption80

    Redemption80 Ancient Guru

    Messages:
    18,495
    Likes Received:
    266
    GPU:
    GALAX 970/ASUS 970
    My mate has been complaining about the exact same thing, although he has a 120hz screen though, so I imagine if it's "smoother" for him than you.

    Hoping they open up the framerate again with future games, reinstalled all these games recently and just noticed the first game was running at several hundred fps but AC2 was capped at 62.
     
  3. Carfax

    Carfax Ancient Guru

    Messages:
    2,913
    Likes Received:
    465
    GPU:
    NVidia Titan Xp
    I have GTX 770 4GB SLI and I use a GTX 650 Ti for PhysX, and I never had those dips you're talking about.....except when I turned PhysX on, but I already covered that.

    If you have a high end rig and you're still experiencing a lot of performance issues in this game, it's probably because:

    1) You have the game's V-sync option enabled. Disable it, and use the driver control panel version instead if you want V-sync enabled.

    2) You have PhysX enabled. The PhysX in this game performs poorly because it was tacked on to another physics engine, Havok. Probably was rushed as well.

    One thing that helped performance significantly in AC IV (and many other games) was disabling HPET in the BIOS. I HIGHLY recommend turning it off, especially if you have SLI.
     
  4. Loophole35

    Loophole35 Ancient Guru

    Messages:
    9,800
    Likes Received:
    1,160
    GPU:
    EVGA 1080ti SC
    Your own chart you posted proves you wrong it hogs core 0 end of discution if you think one core having 85% average usage and the other three or seven having anywhere from 5-55% usage is optimized I have some swamp land to sell you.
     

  5. Carfax

    Carfax Ancient Guru

    Messages:
    2,913
    Likes Received:
    465
    GPU:
    NVidia Titan Xp
    Oh yeah, they should all be 100% even at all times.. :giggle2: You must live in PerfectVille or something..

    If one core was at 99% and the others were at 2-5%, then maybe your point would be valid. But that's obviously not the case. The AnvilNext engine likely uses a lead thread, which is why you see one thread having such high usage..

    That does not mean however that the other cores are just idling or doing nothing. The other threads are doing stuff too, otherwise there wouldn't be such high activity. The more cores or threads you have, the more distributed your CPU usage will be....to a point of course.

    If GameGPU had tested a 2500K non hyperthreaded CPU, then all four threads would have had high activity relative to the 2600K. Anyway, game engines have dynamic workloads for the most part, so it's foolish to expect the CPU to be constantly load balanced.
     
  6. Baronofdecency

    Baronofdecency Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    This
    Perhaps the greatest action adventure game of the 2013 that game puted my old school gear to its limit up to its neck.Thats what i always like to see everything on its limit.99% of the GPU and 1018 MB of the onboard memory utilized.BTW i believe pc gamers as the world most advance gamers deserve more and more optimazition and customization and its just a faulty console port that even doesnt support any aspect ratio except 16:9.Those black bars are a pain in the ass.
     
  7. rflair

    rflair Don Coleus Staff Member

    Messages:
    4,314
    Likes Received:
    795
    GPU:
    5700XT
    Its good to see it runs on a PC of your specs, what resolution and settings?
     
  8. Angantyr

    Angantyr Master Guru

    Messages:
    827
    Likes Received:
    275
    GPU:
    MSI 2070 Super X
    Can't say I've made use of the fix, but you aren't the only one annoyed by the black bars, so the fix is already there. http://forums.ubi.com/showthread.php/812181-1920x1200-FULLSCREEN-NO-BLACK-BARS-Working-solution-for-AC4-and-AC3-Yeah
     
  9. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,421
    Likes Received:
    2,095
    GPU:
    Zotac GTX980Ti OC

    Its a 240GT no wonder he sees max gpu usage, that's barely faster then my intel 4600 igpu if not slower.. :)
     
    Last edited: Jan 4, 2014
  10. Baronofdecency

    Baronofdecency Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    This
    Actually its the GDDR5 version and with my insane overclock it runs up to 27% faster than the reference and now it perfrom faster than both 6800K and HD 4600.Yeah i know its not kick ass at all but its all i can do man :)
     

  11. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,421
    Likes Received:
    2,095
    GPU:
    Zotac GTX980Ti OC
    I mean it has enough work to do since its not that strong, that's why it stays at max gpu usage all the time.

    Sorry for any misunderstandings, enjoy it and have fun :)
     
  12. Baronofdecency

    Baronofdecency Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    This
    Lol yeah im just happy that i can play it even at the low settings.Smoothness is my #1 priority so i lower the settings as much as its neccesary to maintain steady 30 FPS all over the game.Here is my settings:

    832x624(I have a LG L1752S monitor which upscales this resolution so it looks 1024x768)
    In game settings all lowest
    God ray on
    FXAA
    In driver settings:
    2X AF
    Adaptive Vsynce
     
    Last edited: Jan 4, 2014
  13. Baronofdecency

    Baronofdecency Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    This
  14. Baronofdecency

    Baronofdecency Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    This
    No misunderstandings at all.Very humble of you. :)
     
  15. milamber

    milamber Maha Guru

    Messages:
    1,261
    Likes Received:
    50
    GPU:
    MSI 1080 Gaming X
    I'm still getting severe stutter as I'm running around and the GPU usage suddenly drops. AC3 was the same for several months after release (until patches and new drivers improved things). Although in AC3 I was able to keep the game somewhat smooth during fps drops by using adaptive vsync (1/2 refresh rate on a 120hz monitor). In AC4 adaptive vsync just gives me really low fps. Not sure if it's something to do with the 60hz/63fps cap or if it's a driver bug.
     

  16. Carfax

    Carfax Ancient Guru

    Messages:
    2,913
    Likes Received:
    465
    GPU:
    NVidia Titan Xp
    Are you using the 331.93 drivers? They have an updated SLI profile, so definitely use those.

    Also, make sure V-Sync is disabled in the game's graphics option. Disable PhysX as well, as it's basically broken in the game and doesn't really add much anyway..

    I would also recommend disabling HPET in your BIOS. That will smooth out not only AC IV, but all your other games.. Or at least that's what it did for me..
     
  17. milamber

    milamber Maha Guru

    Messages:
    1,261
    Likes Received:
    50
    GPU:
    MSI 1080 Gaming X
    I'm using the latest drivers. It stutters way more with in-game vsync disabled. I dropped Physx to Low and that helped a lot.

    Is it safe to disable HPET? Is that a bios only tweak or Windows as well?
     
  18. Carfax

    Carfax Ancient Guru

    Messages:
    2,913
    Likes Received:
    465
    GPU:
    NVidia Titan Xp
    So the game performs better for you with the in game V-sync enabled? That's weird. I'm using the V-sync in the NVidia control panel, and I found that to be far superior to the in game version.

    Yes it's safe, your computer won't blow up or anything I promise :D

    Seriously though, HPET is both a BIOS and Windows function. Likely, it's already disabled in Windows as your system is new and supports Invariant TSC.

    For some reason though, having it enabled in the BIOS can still negatively impact performance. I think it might be due to added latency by having it enabled in hardware, but not being utilized.

    Sort of like having Firewire capability enabled in the BIOS, yet you don't use it so it's just adding more crap to your system.
     
  19. SLI-756

    SLI-756 Banned

    Messages:
    7,604
    Likes Received:
    0
    GPU:
    760 SLI 4gb 1215/ 6800
    imo the gunplay PhysX smoke is great, as is the other PhysX smoke, but yeah especially when quickfiring your chosen pistol.
    after a round with solid gameplay I don't see my gpu go above 92%, if I needed another I'd get one but I don't, but sure if this game ran at my preferred 75fps then yeah, probably need another, point is I indeed would upgrade for this game, perhaps a future dlc will need the exra oomph, here's hoping.
    I can't take on the legendarys yet, shouldn't be long now though. :)
     
  20. Solfaur

    Solfaur Ancient Guru

    Messages:
    7,678
    Likes Received:
    1,136
    GPU:
    GB 3080Ti Gaming OC
    You can get the southern ones even if not fully upgraded, the ones up north are the challenge. :D
     

Share This Page