Aspect Ratio Issues/Black bars

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by s3fr, Jan 13, 2010.

  1. s3fr

    s3fr Active Member

    Messages:
    51
    Likes Received:
    0
    GPU:
    Radeon HD 4770 900/1020
    I have a Samsung Syncmaster P2250 monitor that supports max resolution of 1920x1080p. Its hooked up to a XFX GeForce 9600GT in DVI-D via a HDMI to DVI-D cable (using a HDMI adapter on the card). Also am using Windows 7 (32 bit ). Recently for the past month or so, I have noticed that if I try to shift to lower resolutions in a game, that the screen gets shifted to the lower resolution but there are black bars on the side even on using 16:9 aspect ratio resolutions:bang:. Am on Nvidia driver 195.62 and have been unable to fix this issue.

    When I searched some forums about this issue, some people said its a driver related issue and others said to change the flat panel scaling options under the Display tab( Adjust desktop position).. But I dont even have that option.. I mean talk about a buzzkill.. The 9600 GT is a decent card to play games on but it doesnt give very high fps in some single player games especially not in 1080p.. Cant play Street Fighter 4 totally smoothly any more:wanker:

    Would be really obliged, if I could receive some help with this

    The rig on the left n the one above r different...
     
    Last edited: Jan 13, 2010
  2. Nono06

    Nono06 Master Guru

    Messages:
    875
    Likes Received:
    0
    GPU:
    680 GTX SLI (1215/6884)
    I think there is something wrong with your driver installation.

    Have you look at the official guide?
    http://us.download.nvidia.com/Windows/195.62/195.62_NVIDIA_Control_Panel_Quick_Start_Guide.pdf

    be sure that all options are available select "advanced settings" as described on page 15.

    you can refer to this guide also:
    http://www.tweakguides.com/NVFORCE_7.html

    Did you tried to run in "safe mode" and change the desktop resolution there?
    Are you seeing the same behavior?
    If yes, then your screen may have a problem.
    If not, then I think you should reinstall the video driver.
    Do a clean install (uninstall old driver, use Driver Sweeper, and then install the driver again).

    You can also try to install an older driver version. 195.xx are not working so well on my ring. The 191 series were working better for me.
     
  3. Lord Angsaar

    Lord Angsaar Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    MSI N260GTX Twin Frozr OC
    I had problems getting "Nvidia scaling w/ fixed aspect ratio" to work on Win 7 x64...

    Try using the 186.91 drivers. These seem to be the only ones where aspect ratio scaling is working properly for Win 7, and are generally the most stable/smooth (for me at least).

    http://www.guru3d.com/news/forceware-186-91-whql-windows-7-and-vista-released/
    ^ Link

    NOTE: These do NOT come with Physx bundled, so you will need to install the latest Physx manually.
     
    Last edited: Jan 14, 2010
  4. The Goose

    The Goose Ancient Guru

    Messages:
    2,850
    Likes Received:
    262
    GPU:
    MSIrtx3070 gaming X
    i have simlilar problem with ati,im running samsung 32" series 5 @ 1080p 60mhz,all was fine untill i tried ati 10.6 now i have ablack border in windows and most games but not all ,cant remember off the top of my head which worked ok but its just weird that sometimes it works and sometimes it doesnt,if i lower res in windows to 1770*1000(1000p) i get full screen,until recently i had been running just my gtx285 on hdmi with dvi adapter with no problem,i dont think its my ati drivers because ive installed and reinstalled so many times sorting another problem out ,ati 10.4 gave same result,im thinking its a hdmi scaling prblem but there are no scaling options with ati drivers
     

  5. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,630
    GPU:
    ROG Strix 1080 OC
    Its the scaling option in Catalyst centre, happened to me all the time I used HDMI, just goto here and slide the bar across

    [​IMG]
     
  6. nikavelli

    nikavelli Master Guru

    Messages:
    426
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    Have you tried connecting without the adapter? And since your monitor and video card both have DVI-D input/output, why would you even need an adapter anyways?
     
  7. archaicdude

    archaicdude Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    Zotac 9600GT 512MB
    Same as me

    I have the same card, the same monitor and I connected using the same cable (DVI-D)...the only difference was I was on Win 7 x64.
    I was having the same issues with the monitor, I even complained to the samsung folk, even they couldn't deal with it (but it worked on ONE of their XP systems so no replacement was offered to me :-(
    Anyways, I found the problem and solved it too :-D

    It seems that since Windows Vista, Microsoft decided to read the monitor capabilities from the monitor itself rather than its drivers or the capability of the video card.

    The Monitor stores this info on a EDID (http://en.wikipedia.org/wiki/Extended_display_identification_data)
    Well, Samsung decided to skip this and they put a standard chip on all of their monitors regardless of the models and the features, so when Windows reads the data from the monitor it doesn't show the res 1920x1080 as native but something different.

    We cannot force windows 7 to use that resolution as it thinks that the monitor doesn't support it, whereas in XP, we can !

    Fortunately, for lazy companies such as Samsung, Microsoft gives a workaround to override the EDID information thru what is called an EDID-Override.

    So, I managed to create a driver to override that, I have attached the driver (rename the file to "SMP2250.inf"), download it and update/install the driver using the "have disk" method.

    Since, this is a user-created driver, it's not digitally signed
    so click on yes when it asks for confirmation.

    I have added all the resolutions given in the monitors manual and they all are working fine, even 1680*1050.

    It should work, I'm using it right now !

    Comment after trying it.

    EDIT: No need to change the graphics card drivers, all drivers work fine, it was the problem of EDID only.
     
  8. p0ppa

    p0ppa Master Guru

    Messages:
    307
    Likes Received:
    0
    GPU:
    Strix 3080 OC
    all the drivers after 186.18 dont have the scaling option in nvidia control panel, if u are on a 32bit system, open cmd and type
    Code:
    rundll32.exe NvCpl.dll,dtcfg setscaling 1 DA 3
    and hit enter - this is to enable the no scaling option, eg 1024x768 under 1920x1080 resolution will be centered.

    Code:
    rundll32.exe NvCpl.dll,dtcfg setscaling 1 DA 5
    and hit enter - this is the "scaled to same aspect ratio" which will have black bars on a 16:9 or 16:10 screen with 4:3 or 5:4 aspect ratio
     
  9. TheSarge

    TheSarge Master Guru

    Messages:
    808
    Likes Received:
    14
    GPU:
    EVGA RTX 3080 TI FT
    The card doesn't support HDMI. The monitor doesn't support HDMI. Just DVI. Why are you using HDMI?

    [​IMG]
     
  10. bokah

    bokah Ancient Guru

    Messages:
    2,316
    Likes Received:
    0
    GPU:
    EVGA 670GTX 2G

    very nice, wish i could do the same to my benq
     

Share This Page