Asmedia Performance on MSI z77a-GD80

Discussion in 'SSD and HDD storage' started by dukedave5200, Dec 15, 2012.

  1. dukedave5200

    dukedave5200 Ancient Guru

    Messages:
    3,192
    Likes Received:
    0
    GPU:
    BFG GTX 285 OCX - SLI
    Recently upgraded my main PC with an MSI z77a-GD80 among other things including a couple new 256GB SSD's.

    My basic config is to raid 0 the two 256GB SSD as my games and main programs and audio/video editing space. Then use my current 120GB SSD as my OS drive. All these drives are Sata3.

    This MSI motherboard has 2x Sata3 Intel ports, 4x Sata2 Intel ports and it also has 2x Sata3 Asmedia ASM106x ports. The Asmedia chip doesn't support raid so I have the 256GB SSD's connected to the Intel Sata3 ports and since my Intel 520 drive is Sata3 I have it connected to one of the Asmedia ports.

    The issue I'm having is the performance of the Asmedia Sata3 ports. I'm even getting better performance on the Intel Sata2 ports with my 120G Sata3 drive. I have tried a bunch of things, here's a basic list:

    - Different drivers, including default Microsoft and a few different versions from Asmedia
    - Tried different cables and ports and drives
    - Ensured certain settings and configurations: AHCI, write cache, disk allignment, power management, etc, etc

    Here are a few CrystalDisk benchmarks of my 120G drive on different ports starting with it on the Asmedia port, then it on the Intel Sata2 and lastely the Intel Sata3 port.

    Intel 520 120GB SSD - Asmedia Sata3 Port:
    Intel 520 120GB SSD - Intel Sata2 Port:
    Intel 520 120GB SSD - Intel Sata3 Port:
    As you can see the performance on the Asmedia is horrible - worse than the same drive/cable using one of the Intel Sata2 ports, and of course using the the Intel Sata3 port looks like it's performing as expected using Crystal.

    None of the various things I've tried so far have made any difference but for one odd thing I'll get to in a second. I have another Sata3 SSD drive that belongs to my laptop that I plopped in and it's giving similar results. Really I'm not sure what is going on. It feels like the Asmedia PCIe lane is running at half speed basically (250gb/s vs 500gb/s), but I fiddled with power management settings and stuff like that and really not sure that is the issue or not. Since this Asmedia chip is integrated I'm not even sure how to test the PCIe lane it's using to see if it's only running at 250gb/s.

    Now here's the odd thing mentioned above. I innitially had my OS drive in one of the Intel Sata2 ports the first install of Windows on this build. I thought I connected to the Asmedia but I just didn't. After running some innitial benchmarks and not seeing Sata3 speeds I eventually looked to confirm I was on the correct port and oops, I wasn't, so I shut down and just moved it to the Asmedia port and did one last disk bench and was getting Sata3 speeds (just not as good as the Intel, but this was expected.)

    Now, I'm a minimalist when it comes to software on my pc, and I had a ton (too much) temporary benchmarking, overclocking, monitoring, etc, software installed testing out the new hardware. Long story short, I decided to just rebuild windows and did it on the Asmedia port. Now this is where I'm at. I am planning on giving another fresh install using the Intel Sata2 port just to see if somehow the installation of windows while the drive is on the Asmedia port is causing some strange driver issue or something along those lines. It could also be something I installed while testing and benchmarking that caused this but I can think of what as I have all the driver and other basic software needed and the same.

    Ok, this post got long. But does anyone know what I'm missing, or has run into this particular issue too?
     
  2. harkinsteven

    harkinsteven Ancient Guru

    Messages:
    2,935
    Likes Received:
    111
    GPU:
    RTX 3080
    I had the exact same issue with my asrock board, I just disabled the sata port in the bios and just use the intel sata ports now. I know there are rom updates on station drivers.com for asmedia sata chip but I didn't bother updating. Not worth the effort just stick with intel one.
     
  3. dukedave5200

    dukedave5200 Ancient Guru

    Messages:
    3,192
    Likes Received:
    0
    GPU:
    BFG GTX 285 OCX - SLI
    Yeah I think that's what I'm going to have to do too. Oh well, I wouldn't have been able to tell a difference and the intel sata2 ports are probably more reliable anyway.

    Thanks for the response and confirmation. :)

    For fun though, here is a bench of my raided 256G SSDs which is where I want the most speed anyway:

     
  4. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Just tested the Asmedia controller on my Asrock z77 extreme4.

    The SSD is a 120gb PNY XLR8 Performance (the cheap one), just using it as a temp/download drive.

    Here are the results with driver 1.3.8.0 (note I have upgraded the ROM controller in the bios from .93 to .951 my thread discussing it here)



    Code:
    Sequential Read :   372.231 MB/s
    Sequential Write :   176.587 MB/s
    Random Read 512KB :   341.510 MB/s
    Random Write 512KB :   174.646 MB/s
    Random Read 4KB (QD=1) :    23.885 MB/s [  5831.3 IOPS]
    Random Write 4KB (QD=1) :    61.450 MB/s [ 15002.5 IOPS]
    Random Read 4KB (QD=32) :   114.648 MB/s [ 27990.2 IOPS]
    Random Write 4KB (QD=32) :   170.764 MB/s [ 41690.3 IOPS]
    Cant compare it to my Intel controller as i've got 2 Crucial M4 in Raid 0 on it :)
     

Share This Page