Artifacts/Flashing Textures in Skyrim with AMD Performance Drivers

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Russ369, Dec 2, 2011.

  1. Russ369

    Russ369 Master Guru

    Messages:
    621
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FE
    Im sure most of you guys are getting this too... Apparently with 11.11c the 5000 series had this problem fixed...

    Anyone got some insight, anyone send anything with regards to this to the catalyst maker guy?
     
  2. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    yes ive got some insight. v

    complete wast of time talking about it, there's load of threads about this already and it will be January before amd release another crap driver for it.
    It will be a driver so bad that your rig will blow up and your smoke alarm will go off.

    Mod edit: Please don't use every thread to go off on a rant.

    To Moderator: it was not intended as a rant it was suppose to be comical.
     
    Last edited: Dec 5, 2011
  3. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,477
    Likes Received:
    553
    GPU:
    MSI 2070S X-Trio
    If that drivers coming in January, then id stick to the one thats coming this month :p

    Only Nvidia do drivers that blow yer rig up btw, well, your gfx card, but i guess if your not there at the time it goes, then it could take your rig with it :D
     
    Last edited: Dec 3, 2011
  4. MadelineX

    MadelineX Master Guru

    Messages:
    259
    Likes Received:
    0
    GPU:
    Sapphire 295x2

    I was getting this as well with the mip maps apparently. Leaves would pop in out, moss appear and disappear.

    I noticed by checking MIP MAP QUALITY high and also TEXTURE FILTERING HIGH in Radeon pro seemed to make this issue go away.


    Not certain if that was what fixed it but the problem is gone. Worth a shot anyway.
     

  5. PcChip

    PcChip Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    GTX680 @ 1197 MHz
    Try turning the Decals up to Ultra
     
  6. Russ369

    Russ369 Master Guru

    Messages:
    621
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FE
    Wave ripples are broken with flickering as well as green flashing in caves... :( 8.93 doesn't have these problems but no CFX for those drivers :(
     
  7. rhinohorn

    rhinohorn Member

    Messages:
    13
    Likes Received:
    3
    GPU:
    5700XT
    Disabling AA in the Skyrim Launcher and setting Catalyst AA mode to "Multisample AA" and forcing AA "Box" filter fixed the wonky textures for me.
     
  8. Aph0tic

    Aph0tic Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    Sapphire5770&6770 1GB CFX
    Do not use Adaptive sampling, causes a bunch of issues. I honestly prefer FXAA. I use "Edge-Detect" filter.
     
  9. Russ369

    Russ369 Master Guru

    Messages:
    621
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FE
    Nah I tried all those things... its the drivers I know it... ****in AMD...
     
  10. Russ369

    Russ369 Master Guru

    Messages:
    621
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FE
    Whatever I finished the main quest today... Im uninstalling it untill they fix the problems... Side quests are boring to me anyways so... peace out skyrim
     

  11. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    ive scanned these recent forums and it looks like skyrim crossfire is definitely fixed for 5 series, but problem persists for 6 series.
     

Share This Page