Anybody know if ATI will fix the openGL/steam bug in 10.7s?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by prof72, Jul 1, 2010.

  1. prof72

    prof72 Master Guru

    Messages:
    219
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 OC
    Seems 10.4s+ break openGL so you cannot play some old games in steam (and maybe not in steam).

    re: http://forums.steampowered.com/forums/showthread.php?t=1288578

    Essentially you have to do this:-

    Anyone still receiving this problem it is due to the new 3.3/4.0 OpenGL files.

    Download this and place it in your GameData folder.
    http://www.filefront.com/16696483/atioglxx.rar

    Same thing works for Jedi Outcast and Return to Castle Wolfenstein.

    Rumor is that the new 10.6 will fix this issue with a updated OpenGL but the latest leaked versions still seem to have this issue.

    When the 10.6 drivers do come out, try to move this file out of the folder to see if the problem is fixed or not so you are always running the latest


    It wasn't fixed in 10.6 btw, so anyone know if this will be fixed in 10.7?
     
  2. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,671
    Likes Received:
    1,529
    GPU:
    GTX1070 iChillx4
    i even use 10.1 opengl dll. Damn you ati!!
     
  3. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,570
    Likes Received:
    597
    GPU:
    MSI 2070S X-Trio
    The 10.7s are garbage.
     
  4. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,973
    Likes Received:
    483
    GPU:
    EVGA GTX 1080 Ti SC2
    Placing the 10.4a atioglxx.dll in the game folder seems to do the trick for me with Doom 3 and at least guarantees that I'll get consistent performance no matter which version of the Catalyst drivers I have installed. Yes, the problem is annoying and should not have happened in the first place but considering how few OpenGL games there are I personally don't think it's that big of a deal to use the atioglxx.dll trick.

    Hopefully, ATI will fix it properly though but I won't be holding my breath.
     

  5. prof72

    prof72 Master Guru

    Messages:
    219
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 OC
    what's weird I searched the ATI/AMD forums and I couldn't find this mentioned at all.
    Thought my fresh install of W7 was bust until I did some googling for the error!
     
  6. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,179
    Likes Received:
    566
    GPU:
    Zotac GTX1080Ti AMP
    Oh please do share! If you have an opinion on drivers that are not even released yet then please do share them with us.
     
  7. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,973
    Likes Received:
    483
    GPU:
    EVGA GTX 1080 Ti SC2
    Although I haven't been using ATI cards for very long (since March 2010 actually), it seems to me that the best Catalyst drivers are the odd numbered ones, 10.3 and 10.5, so I expect 10.7 will be good...

    ... before ATI release 10.8 and break at least three things while fixing something else. Isn't that how it goes? :p
     
  8. Kariddi

    Kariddi Active Member

    Messages:
    74
    Likes Received:
    0
    GPU:
    2x ATI 5850 Sapphire
    Strange, I have Half-Life and I run it with the OpenGL renderer without problems and drivers 10.6.

    Maybe this is not related to all OpenGL games, but only those based on the Q3 engine?
     
  9. FearFactory

    FearFactory Master Guru

    Messages:
    815
    Likes Received:
    0
    GPU:
    MSI RX570 X 4GB
    After seeing this thread, i tried Prey and it runs fine (1600x1200, MAX detail). It's based on Quake 4 engine, right...? tomorrow i will try Quake 4. Running CAT 10.5a
     
  10. buddyfriendo

    buddyfriendo Ancient Guru

    Messages:
    3,394
    Likes Received:
    0
    GPU:
    EVGA GTX 480 SC
    Just ignore him, this isn't the first thread where he's said this. He's just trying to troll.
     

  11. FearFactory

    FearFactory Master Guru

    Messages:
    815
    Likes Received:
    0
    GPU:
    MSI RX570 X 4GB
    Prey and Quake 4 are running fine. I even tried the oldest Open GL game i have here.. Heavy Metal FAKKE 2 which is based on Quake 3 engine. I had to set it to XP SP3 compatibility mode, but after that it runs fine. All this on Win 7 64bit with cat 10.5a.
     
  12. Paulo Narciso

    Paulo Narciso Maha Guru

    Messages:
    1,219
    Likes Received:
    32
    GPU:
    ASUS Strix GTX 1080 Ti
    Enable Antialiasing, that's what breaks the games.
     
  13. FearFactory

    FearFactory Master Guru

    Messages:
    815
    Likes Received:
    0
    GPU:
    MSI RX570 X 4GB
    ok going to try it..
     

Share This Page