Anybody Here Use Voodoo2?

Discussion in 'Videocards - 3dfx' started by scrapser, Apr 12, 2013.

  1. scrapser

    scrapser Master Guru

    Messages:
    575
    Likes Received:
    0
    GPU:
    780 ti Kingpin CLFD 3 GB
    I could really use some help. I've tried installing my Voodoo2 cards at least a dozen different times with 4 different sets of drivers and simply cannot get the SLI setup to work. I'm using MicroProse's EAW as a test program.

    Help would be greatly appreciated.

    Thanks
     
  2. Veteran

    Veteran Ancient Guru

    Messages:
    12,089
    Likes Received:
    6
    GPU:
    2xTitan XM@1590Mhz-CH20
    I have a Voodoo 2 in my attic as far as i know it works.
    I used to run mine in sli with a Millenium Matrox G200 2D card.

    Maybe you should go google a proper 3dfx forum or something, How do you know the card is even working?
     
  3. angmar

    angmar Maha Guru

    Messages:
    1,192
    Likes Received:
    0
    GPU:
    Zotac GTX 1070
    Jeez it's been a long time since I had a Voodoo2...that was my first 3d Accelerator and I have never had as much fun in pc gaming since then playing games like quake 1 and 2 and asherons call 1 with glide on omg what a big difference it made back then compared to software 3d.. I will try an do some research for you an see if I can help you. If I figure anything out I will post it. I am assuming you have the ribbon cable connecting the cards together right?



    "SLI requires the following:

    2 VooDoo2 series cards
    1 Regular PCI 2D card
    2 VGA cables - F-M, F-M"


    http://www.mdgx.com/3dfx.htm

    This page has tweaked unofficial drivers for download. Check it out maybe something on there can help you. I couldn't find much else the cards are just so old now. I had some of the best times
     
    Last edited: Apr 12, 2013
  4. scrapser

    scrapser Master Guru

    Messages:
    575
    Likes Received:
    0
    GPU:
    780 ti Kingpin CLFD 3 GB
    I know the cards work because I had them working on a previous motherboard last month. I switched from a socket 473 mobo w/1.8 gHz CPU and 512 RAM (4x128) to a socket 478 mobo w/3.06 gHz CPU and 512 MB RAM (one stick). The same nVidia graphics card is being used (Ti-4600 128 MB 4X AGP).

    All the hardware is brand new except the nVidia card. The 3DFX cards are a matched pair from Diamond (called "MegaMonster" with 8 MB each). One card doesn't have any VGA ports at all and is intended solely as the SLI companion card.

    I don't know of any "proper" 3DFX forums but am still seeking help from other locations. Guru3D is a good site and has a dedicated 3DFX forum so why wouldn't I be able to reach out here?

    I forgot to mention my DirectX version is 7 at the point when I install the cards. They were originally designed to support version 6 according to the documentation.

    I have tried:
    FastVoodoo 4.6
    3DFX Reference 3.02
    3DFX Reference 2.53
    Diamond v2.07
     

  5. Veteran

    Veteran Ancient Guru

    Messages:
    12,089
    Likes Received:
    6
    GPU:
    2xTitan XM@1590Mhz-CH20
    You may get the answer that your looking for here but if you dont you may want to try somewhere else, That is all i was saying.

    Many people used these cards years ago but i dont know how many people are using them now.

    A very very small amount i would think, I only kept mine cause it was first SLI card, I would never ever think of using it as there isnt anypoint with the cards of today but thats just me.

    I hope you get it running, Look at Angmars post above to see the link that was posted.
     
  6. scrapser

    scrapser Master Guru

    Messages:
    575
    Likes Received:
    0
    GPU:
    780 ti Kingpin CLFD 3 GB
    Thanks. I'm working on resurrecting some games that simply will not run on anything else or would be easiest to run providing I have the necessary hardware and because 3DFX was pretty good back then. European Air War, M1 Tank Platoon 2, Battlezone, Quake, MicroProse F15, and Jane's Fleet Command are just some of the titles I want to bring back.

    I will try the suggested link. I found a very early version of official Diamond drivers that I will try tonight (v1.01). When it's running, it looks very nice on my Sony widescreen CRT...especially with the SLI that achieves 1024x768.
     
  7. Veteran

    Veteran Ancient Guru

    Messages:
    12,089
    Likes Received:
    6
    GPU:
    2xTitan XM@1590Mhz-CH20
    You can still play those games now on Windows 7 with the Glide Wrapper.
    http://www.zeus-software.com/downloads/nglide

    I still play M1 Tank 2 and although theres a little colour glitching in the menu's once you fire up the campaign it works flawlessley.

    i would imagine the other games will be the similar.
     
  8. scrapser

    scrapser Master Guru

    Messages:
    575
    Likes Received:
    0
    GPU:
    780 ti Kingpin CLFD 3 GB
    Yes...I'm familiar with the Glide wrapper approach. The only one that doesn't work is EAW from what I've been able to find. So if I need to do this for one game then I may as well play all the others on original equipment, too.

    Meanwhile, I've discovered a clue as to why my 3DFX cards are not working and hope to resolve it this weekend. I'm using CH Products USB HOTAS and the control software is apparently scrambling the enumeration of all the PCI objects when Windows boots up. Since I've been installing the controls and 3DFX at the end of my entire installation (before installing any games), it very well could be that I simply need to find the best way (order) to install both and let the dust settle so to speak. If I can just get past this hurdle, I'll be golden!
     
  9. Veteran

    Veteran Ancient Guru

    Messages:
    12,089
    Likes Received:
    6
    GPU:
    2xTitan XM@1590Mhz-CH20
    Yeah i have a CH HOTAS,( Fighterstick etc) There software is brilliant as your probably aware.

    Why dont you try heading over to the CH forum, Bob church is a very helpful guy and may provide a workaround for you?:)
     
  10. scrapser

    scrapser Master Guru

    Messages:
    575
    Likes Received:
    0
    GPU:
    780 ti Kingpin CLFD 3 GB
    Thanks...it makes me chuckle how close our thinking is. Bob and I have been in dialog about this issue. I finally hit on the problem. It was an external USB hub I was using. It worked fine on my previous Win98 box but the new one doesn't like it. It's okay...I really don't need it anymore.

    I also resolved my 3DFX issue. I can't get the SLI to work but I have a 12 meg Voodoo2 card that works just fine using the Win9X FastVoodoo v4.6 driver. The only game where I wanted higher graphic resolution was EAW. I decided to just use D3D which gives me more resolution options than Glide. I use the 3DFX card for M1TP2 and some of the other less demanding games that are old and really don't have higher resolution selections anyway.

    So now I am happy. I have a nearly new Win98SE computer, strictly for gaming. It will also handle some DOS games (like Silent Hunter). Time to enjoy the fruits of my labor.
     

  11. Veteran

    Veteran Ancient Guru

    Messages:
    12,089
    Likes Received:
    6
    GPU:
    2xTitan XM@1590Mhz-CH20
    Good stuff that you solved the problem.:banana:
     
  12. scrapser

    scrapser Master Guru

    Messages:
    575
    Likes Received:
    0
    GPU:
    780 ti Kingpin CLFD 3 GB
    Thought I would provide a little update.

    This past weekend I played around with my 3DFX Voodoo2 cards and finally got the SLI cards to work. I have a dedicated set of 8 MEG cards that were sold as the MegaMonster by Diamond. I also have two 12 MEG cards that can be used individually or paired in SLI.

    I can't explain the issue but what I did was set up a box with a socket 423 P4 motherboard (Intel D850GB). This board uses RDRAM which is okay I guess. It has a 1.9 gHZ CPU and I am using an nVidia Ti-4600 GPU along with the 3DFX cards mentioned above. The weird part is that I can only get these cards to work in SLI using a driver provided by Diamond (v2.07). Any other driver crashes the system. Conversely, if I only use one card then I can use any driver I want. Strange.
     
    Last edited: Apr 30, 2013
  13. Veteran

    Veteran Ancient Guru

    Messages:
    12,089
    Likes Received:
    6
    GPU:
    2xTitan XM@1590Mhz-CH20
  14. Geoscience

    Geoscience New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 550 Ti
    Actually EAW will run fine in Glide under a wrapper, or with the D3D Windower. I'm using the nGlide wrapper with a GT 440 and it looks awesome (although it's on Win 7 Pro, not XP)!
     
    Last edited: May 7, 2013
  15. scrapser

    scrapser Master Guru

    Messages:
    575
    Likes Received:
    0
    GPU:
    780 ti Kingpin CLFD 3 GB
    That's interesting. I was unable to find any glide sites where EAW was marked as working. Which one are you using? In spite of having a very nice Win98SE box with 2x12meg Voodoo2 in SLI to run EAW, it's always good to have a fall back arrangement.

    Next I will be deciding whether to install Battlezone on the Win98 box or use the new patched version that allows you to run it on Win7. Part of the pull is the monitor I have for Win98 and WinXP. The Sony GDM-FW900 is a gorgeous display for running games...and being a CRT, it helps with pixellation on a large screen with lower resolution.
     

  16. mmx23

    mmx23 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    3Dfx Voodoo 5 5500 AGP 64
    I still use voodoo 2 in sli, on a vintage system.
    Initial config was a pentium !!! at 650 MHz, but, after upgrading AGP card from Banshee, and then Voodoo 3 3000, I decided to go forward and buy a voodoo 5 5500 AGP.

    And, recently upgraded to AMD Athlon Xp 1600+, but I keed the V2 sli inside because I love them.
    And, some early Glide games I was unable to make them run on V5, so, on v2 they work flawlesly.
     
  17. edma3d

    edma3d Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Asus Strix GTX 1080
    Still use it to play Unreal Tournament with glide.
     

Share This Page