1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Any fix for BFBC2 screen flicker with 270.51?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by kershner25, Apr 12, 2011.

  1. kershner25

    kershner25 Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    Nvidia GTX 260 896 MB
    Hey guys, my GTX 260 has been loving the new 270.51 drivers - performance is better in most games and, more importantly, my temps have lowered considerably.

    However, the one game that is experiencing difficulty is Bad Company 2. Now, no matter what I try (changing every graphical setting in the game, enabling triple buffering, alt-entering numerous times) I get a full screen flicker of black against the game's graphics that is continuous. It makes the game unplayable. I've never had this problem with any other drivers, and I've noticed others have had this problem too, both with these particular drivers and the game in general.

    Does anyone know of a fix for this? BF is one of my most played games, and I really don't want to revert drivers!
     
  2. nexus_711

    nexus_711 Master Guru

    Messages:
    221
    Likes Received:
    0
    GPU:
    Inno3D GTX 1080 Twin X2
    Same problem here. I was thinking I'm alone with this problem. It looks like It's driver bug & I haven't found a solution.
     
  3. pstlouis

    pstlouis Master Guru

    Messages:
    401
    Likes Received:
    1
    GPU:
    GTX 1080Ti SC2 2038
    The driver 270.51 doesn't have any problem with that game. My fps went up. Roll back your driver and verified if it is the same situation.
     
  4. DaKamikaz

    DaKamikaz Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    2x Asus 8800 Ultra 768mb
    Correction, it doesn't have a problem with your gfx-card..

    I can confirm having the same problem in BC2 AND CoD4. Had to rollback to 267.24 beta
     

  5. nexus_711

    nexus_711 Master Guru

    Messages:
    221
    Likes Received:
    0
    GPU:
    Inno3D GTX 1080 Twin X2
    Reinstaled back to 267.91 and broblem is gone . All other games work perfectly with 270.5
     
  6. dnottis

    dnottis Master Guru

    Messages:
    699
    Likes Received:
    0
    GPU:
    EVGA SSC 970 GTX 4GB
    Its been a long known issue with the game. This only happens when running DX10.

    In DX10 if Bloom is enabled this happens. Goto the settings.ini in the c: mydocs / BF BC2 and change Bloom=False. Save it and restart the game. That should take care of that.
     
  7. nexus_711

    nexus_711 Master Guru

    Messages:
    221
    Likes Received:
    0
    GPU:
    Inno3D GTX 1080 Twin X2
    Thanks dnottis! I have Bloom disabled since I installed a game, it's not a case. The game changes my refresh rate to what it think is normal like 109.96Hz not 110Hz. That probably is the cause of flickering and I can't force it to 110Hz through settings.ini it just reverts back to 109.96Hz when game starts, forcing settings.ini to read only wont help.
     
  8. Sneakers

    Sneakers Ancient Guru

    Messages:
    2,717
    Likes Received:
    0
    GPU:
    Gigabyte 980Ti Windforce
    I'm using 270.51 and got no issues with it at all. But I don't think it runs as good as say 265.90 drivers did with BC2, not as smooth.

    Running with with dx11, no bloom, no hbao.


    P.S

    I do get good fps in DA2 though.
     
    Last edited: Apr 14, 2011
  9. poo417

    poo417 Master Guru

    Messages:
    247
    Likes Received:
    0
    GPU:
    1080
    No problems with my work machine q9550 @3.8 and 260 gtx. Great performance and smooth.

    My home machine it is very bad. With surround the centre screen is shifted to the right and the gpu use and fps is all over the place. So I rolled back on this system.

    There does seem to be a problem with some set ups and BC2 with these drivers.
     
  10. johnmambo

    johnmambo Master Guru

    Messages:
    261
    Likes Received:
    0
    GPU:
    Gigabyte G1 Gaming GTX980
    Bad Company 2 runs just fine here with 270.51. No problems at all and great performance.
     

  11. Deathspank

    Deathspank Maha Guru

    Messages:
    1,301
    Likes Received:
    0
    GPU:
    Gainward GTX570 1280mb
    isnt it funny how nearly everyone diables bloom but they dont provide the option to disable it in the menu.
     
  12. darth0r

    darth0r New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Palit 460 GTX 1024
    Same problem here with a GTX 460.

    Since I installed this vcard I get less fps and screen flickering than my old GTX 260 card.

    I tried like ten drivers version with same results.

    I'm using now 270.51 and I increased performance with other games like Crysis 2. I know there is something about GTX460 and bad company 2 but haven't find a real solution to this issue...
     
  13. EquaniL

    EquaniL New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    inno3D GTX 460@875/2150
  14. powerspec

    powerspec Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    PNY GTX 580 OC and GT 430
    I have the same problem with my GTX 295 with the 270.51 drivers. Putting everything on low fix's the problem, will have to try turning off bloom with everything on high tonight.

    EDIT: Turning off bloom fix it!
     
    Last edited: Apr 15, 2011
  15. PurpleFish

    PurpleFish Master Guru

    Messages:
    678
    Likes Received:
    0
    GPU:
    XFX GTX260 c216 @ 780core
    Gtx 260 here no probs at all with 270.51
     

  16. HolyLiaison

    HolyLiaison Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    MSi 570 GTX SLI
    You guys having problems with Battlefield: Bad Company 2 with the 270.51 driver can manually set the DirectX version BFBC2 uses in it's config file usually located in C:\Users\[Your Windows Login]\My Documents\BFBC2\settings.ini

    Change the line "DxVersion=" to 9, 10, or 11 to force a set version. See if that gets rid of your problem.
     

Share This Page