Another nvlddmkm.sys fix

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by DirtyDeedz, Jul 17, 2008.

  1. DirtyDeedz

    DirtyDeedz New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    XFX/Nvidia 8800GTX/768MB
    Hello all!!

    I hope this post helps some. I'll try and be short and to the point.

    System Specs: EVGA 680i SLI(latest bios), XFX Geforce 6800GTX x 1(No SLI)(Multiple Driver Versions), E6600, 6GB OCZ RAM, Segate 320GB 7200.10 HDD's X 2 RAID 0, Zion 600w SLI PSU, Vista Business 64 SP1.

    Cause: I had to reformat my HDD to get Vista SP1 to install(long story, another time). My System prior to SP1 was stable and OC'd. After my reinstall I ran head on into the nvlddmkm.sys error. "Your graphics driver has stopped responding.. blah...blah...blah.

    Occurrences:
    Anytime I Alt+tab'd from a 3D full screen game. Anytime, Windows Media Player changed songs while I was playing a 3D game, and Anytime I tried to use FRAPS while playing a 3D game.

    Attempted Fixes:
    After hours of reading on this subject I tried these ideas: No OC'ing, Various Drivers and Driver Cleaners, deleting the nvlddmkm.sys file and reinstall, changing 3D settings from "multi-display performace mode" to "single-display performance mode, turned off windows security settings, changed PSU, and some others I'm sure. There were many! And, None worked!! :bang:

    What Worked for Me
    : Uninstalled Forceware Driver 177.41 and installed 177.66 . On the reboot initiated by windows I decided to look at my bios to see if there was something I was overlooking. Low & Behold I saw the setting "NVIDIA GPU Ex" in the below pic was DISABLED; having nothing to lose, I ENABLED it. "F10" Saved it and continued w/ reboot. I haven't seen the nvlddmkm.sys error since. And, I've tried everything I could think of to repeat the error. :banana:

    [​IMG]
     
  2. stev1456

    stev1456 Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    MSI GTX 285 W/C
    How's the system ?
    Any nvlddmkm.sys errors yet since you enabled GPU Ex in the BIOS ?
     
  3. BoudahXL

    BoudahXL Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    GTX295 BFG
    I have GPUEx enabled and experienced this problem, matter of fact it's always been enabled, what the OP must take into account is that he did two things before testing.Therefore you can't confirm which one worked.

    For me everytime I install clean drivers the system is rock stable for 30-60 days, then the errors pop in, repeat and rinse.

    I tried:
    -Swapping PSU
    -Swapping Motherboard
    -New HD's
    -XP32 & Vista32
    -Change timings
    -Added cooling
    -Plenty drivers
    -Swap cards

    The only thing that really made a difference is the added cooling, I added between the two 8800GTX a PCI fan that blows heat outside, and created a duct from the front of cpmputer to the cards.

    Where I could reproduce crash on auto fan settings, now it's stable with better cooling, till the drivers give up and re-install, it's not that bad every 30-60 days or so, but it's a scary thought to leave my computer on while I'm away for days.
     
  4. masterchiefx2

    masterchiefx2 Banned

    Messages:
    6,258
    Likes Received:
    1
    GPU:
    GTX 280 Sli
    i fixed mine by uninstalling an reinstalling my games
     

  5. awmiscool

    awmiscool Member

    Messages:
    46
    Likes Received:
    0
    GPU:
    BFG Tech 9800 GX2 @680/1625/1100
    Holy hell masterchief, howd you get your GX2 clocks so high?

    Anyways, it seems that 177.66's fixed alot of choppy fps fixes for me also.
     
  6. DirtyDeedz

    DirtyDeedz New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    XFX/Nvidia 8800GTX/768MB
    ROCK SOLID!! FRAPS works! Alt+Tab Works! Windows Media Player works! Photo and Video editing software work! Even when I have a full screen game running in the background! :banana:
     
  7. -ToasT-

    -ToasT- Ancient Guru

    Messages:
    2,528
    Likes Received:
    1
    GPU:
    EVGA GTX 670
    Huh, I'll give it a shot. I don't remember such an option in my BIOS, but I'll check while I'm installing my new hard drive.
     
  8. stev1456

    stev1456 Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    MSI GTX 285 W/C
    Well - tried your idea - enabled GPU Ex in the BIOS
    Sad to say i got the nvlddmkm.sys file BSOD whilst playing GRID for a while
    Thanks for the idea - back to the drawing board :-(
     
  9. DirtyDeedz

    DirtyDeedz New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    XFX/Nvidia 8800GTX/768MB
    Here's another fix from EVGA Message Boards- Poster: anarchy998

    this is the fix that always works, first time around, has for alot of people

    Fix: Go to windows/system32/drivers and rename nvlddmkm.sys to
    nvlddmkm.sys.old. Go to the nvidia directory and find the file nvlddmkm.sy_
    and copy it to windows/system32. Using the cmd window (DOS box) type
    EXPAND.EXE nvlddmkm.sy_ nvlddmkm.sys. When the expansion is complete, copy
    the new nvlddmkm.sys to windows/system32/drivers and restart the computer
     
  10. stev1456

    stev1456 Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    MSI GTX 285 W/C
    I did the changes & so far so good
    many thanks for your advice

     

  11. Mark-32

    Mark-32 Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    GTX460+8800GT Phyx HP2408
    Plz HELLLP!!!!
    After installing a fresh copy of windows and before formatiing my D:\ i installed a copy of assassin's greed and all worked fine. then i formatted D: (NTFS) where i usually keep all music files videos and where i install games.
    After that i installed CnC3 Kanes wrath on D: and the game crashes as soon as i double click the icon, then i installed assassins greed on D:\ and the game crashes as well instantly. Even after uninstalling it from D:\ and installing it again on C: drive it didn't fix the problem, almost every game crashes the same way which is why i formated in the 1st place.
    PS: i have 2 x 250GB western digital raid 0
     
  12. BoudahXL

    BoudahXL Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    GTX295 BFG
    -Uninstall the drivers
    -Boot into safe mode
    -Use a driver cleaner utility
    -Remove your Nvidia folder from top level C:\
    -Reboot into normal mode(user mode)
    -Install your drivers

    P.S. In some rare case your system might have the Microshaft nvidia drivers update and sadly on every reboot it might try to re-install your hardware before you have time re-installing YOUR drivers which you downloaded from manufacturer's website.

    And you will have the same errors, because your manufacturer's are not overwriting microshaft's drivers.In that case do these steps.

    -Uninstall the drivers
    -Do not reboot at the end of uninstall
    -Go into device manager and remove "Display Adapter"
    -Boot into safe mode
    -Use a driver cleaner utility
    -Remove your Nvidia folder from top level C:\
    -Reboot into safe mode
    -Install YOUR drivers
    -Reboot into normal mode(user mode)
    -Install your drivers again and overwrite everything.

    That's my recipe, works everytime but I hear there are some other ways too.Good luck!
     

Share This Page